Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7422 Discussions

Browsers Don't Load Pages Until I Disable Killer Network Apps

JAPerson34
Beginner
1,337 Views

Alienware 17 R5. Had a SSD burn up which had the OS on it. Windows 10 Home. I replaced the SSD and reinstalled Windows 10 using Windows 10 Media Installation Tool. However, I could not get my browsers (Firefox, Chrome, Edge) to load pages. I tried installing Windows 10 again, but this time using Dell OS Recovery Tool. Same issue. Someone recommended uninstalling Killer Network App which I did and things worked again. This morning, after being online for 2 hours, the browsers started acting up again. I poked around and see some Killer apps running in the background. Where they there before? Perhaps? So I took a gamble and disabled all of them. Things began working again. However, every time I start my computer, the Killer apps are running in the background again. All I disable now is Killer Network Service app, leaving the others run and it fixes the issue. I had these apps before the computer crashed and had no issues. Why am I having issues now? Help would be greatly appreciated.

Labels (1)
0 Kudos
7 Replies
DeividA_Intel
Employee
1,299 Views

Hello JAPerson34,  



Thank you for posting on the Intel® communities. I am sorry to know that you are having issues with the Intel® Killer™ Software.



In order to better assist you, please provide the following:  


1. Is this the original adapter that came pre-installed on your computer or did you change/install the adapter to this one?  

2. Is the Bluetooth working?

3. What is the killer adapter that you have installed?

4. Did you perform a clean installation of the Killer app?

5. Do you see any errors in the device manager?

6. Do you have problems playing games online or downloading media content(movies, video, streaming apps)?

 


Regards,  

Deivid A. 

Intel Customer Support Technician


0 Kudos
JAPerson34
Beginner
1,281 Views

Thank you David for your reply.

1 & 3. Yes, this is the original adapter. Killer(R) Wireless-AC 1550 Wireless Network Adapter (9260NGW). The ethernet adapter is the Killer E2500 Gigabit Ethernet Controller. That too is original which I never use.

2. Bluetooth is working. I do not know if it was or not when I was having issues.

4. No. I went with what came with the recovery installs and later, Windows 10 updates.

5. Not errors, but some devices were missing drivers which I have since corrected. None of them were network related that I know of. None of them corrected the problem either.

6. I had problems with it all. Steam app was not connecting. I went into Settings and then Apps. There was a Killer app listed that I uninstalled. That fixed the problem for a day. After the problem returned, I checked Task Manager and found some Killer items under Background Processes. I clicked "End Task" for all of them and things began working again. The next time I rebooted, they had all returned. I then only clicked "End Task" for the Killer Network Service process. Since then, it hasn't returned and everything as far as I know seems to be working fine. Currently under Background Processes there are 2 Killer items listed. Killer Analytics Service and KillerAPS. All the Killer software remaining in my system are dated 3/30/22 if that helps any.

0 Kudos
DeividA_Intel
Employee
1,268 Views

Hello JAPerson34, 



Thanks for the information provided, As a test, please try to perform a clean install of the Intel® Killer™ Software.



Let me know if the issue persists.


Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
JAPerson34
Beginner
1,251 Views

Problem with step 8: The final part of the installation will involve forwarding you to the Microsoft Store* to download the Killer Performance Suite user interface. This is required to use the Intel Killer Performance Suite.

This did not download and has been reported by several others.

I went ahead with the restart and so far everything seems to be working fine.

0 Kudos
DeividA_Intel
Employee
1,231 Views

Hello JAPerson34, 



Thanks for the confirmation. I am glad to know that your computer is working properly now, I will wait a little bit just to confirm if the issue returns before closing this thread.


Please let me know if the issue is present again.


Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
JAPerson34
Beginner
1,212 Views

I think we are good on my end. You just need to see what you can do on your end to get that step 8 working.

0 Kudos
DeividA_Intel
Employee
1,195 Views

Hello JAPerson34, 



Thanks for the confirmation, I am glad to know that you are not having the issue anymore. However, the issue with the Microsoft store seems to be affecting several apps and not only the ones from Intel, if you want you could report this behavior to Microsoft.


For now, I will proceed to close this thread but you can open a new one in case you need further support or if you face any issues with our products.



Regards,  

Deivid A.  

Intel Customer Support Technician  


0 Kudos
Reply