Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7431 Discussions

Can't turn on WiFi radio


Hi guys,

I know this is a common problem in which there are hundreds of questions and answers on a variety of forums but I have been trying to tackle a problem for a few days now and although I have learned quite a bit I am unable to find a solution to my problem.

I have an Acer V5-571 laptop which originally came installed with Windows 7 and a Qualcomm Atheros WiFi card. I upgraded to Windows 8.1 and everything worked perfectly. I also recently got a Smart TV with WiFi Direct capability, so I have been trying to set up my laptop to stream my laptop wirelessly to the TV. This I have achieved successfully by swapping out my Broadcomm WiFi card for an Intel N 2230 and after a bit of pain with updating drivers and installing the required programs it works very well.

My problem though is that if radio is disabled I can not re-enable it. The only hardware switch I have is the keyboard hotkey Fn+F3, which does an excellent job or disabling the radio, but doesn't even attempt to enable it again. The only single way I can re-enable the radio is to put the Qualcomm card back in, load up Windows, Fn+F3 to enable radio, shut down, swap back to the Intel card, and boot up again. As anyone can imagine this is not an ideal solution every time I want to turn my WiFi on.

I have tried all sorts of ways in Windows that I have read online that some have found successful, but none have worked for me, and from what I have read there is no way to do it from Windows as the radio is hardware locked and can only be enabled using the radio switch (which on this laptop is Fn+F3)

A few things I have tried;

Updating the BIOS and checking any relevant settings (there are none)

Updating all drivers including Chipset, Graphics and WiFi

Updating/Installing any relative drivers/software from Acer

Installing all possible updates available for Windows 8.1

Removing any drivers related to the old Broadcomm board

Running troubleshooting (as an administrator) on the Network Adapter (this only confirms radio is off)

Disabling/Enabling the adapter in Device Manager and in the Network & Control Centre

Turning WiFi off/on in the Intel PROSet software (no option for radio, and also confirms radio is OFF)

Using an netsh interface enable command in CMD

Tried all kinds of ctrl, alt, Fn and F1-12 combinations just in case

Fn+F3 disables and enables all wireless communication perfectly when the Qualcomm card is inserted

Fn+F3 continues to disable and enable Bluetooth, but will only disable Intel WiFi when the N 2230 card is inserted.

My instinct is that the Fn+F3 hotkey is somehow not linked to the Intel card and needs manually fixing.

Very sorry for the essay and thank you for taking the time to read it all, I would greatly appreciate any help with this.

Many thanks,


0 Kudos
1 Reply

Hi Graham, I see you have tried several troubleshooting steps.

The best recommendation we can provide is to get in contact with the system manufacturer since the WiFi radio switch is a feature that is implemented in different ways depending on the computer manufacturer. You may also need to verify if the adapter you are trying to install was validated for your system model.

http://www.intel.com/support/wireless/wlan/sb/cs-020275.htm Intel® Wi-Fi Products — Wireless Radio Cannot be Enabled From Software

http://www.intel.com/support/wireless/wlan/sb/CS-011644.htm Intel® Wi-Fi Products — Regulatory Information Regarding Hardware Installation or Upgrade

http://www.intel.com/support/wireless/sb/CS-006192.htm Wireless Networking — Installation Error when Installing or Swapping Intel Wireless Adapters