Issues related to Intel® Wireless Adapters and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
6542 Discussions

Can't turn radio on | Intel Centrino Wireless N 1030 Mini-PCI Card


I recently put in my laptop a Intel Centrino Wireless N 1030. Windows sees it fine, and the hardware itself works. The problem is however I have no physical switch for WiFi, and the radio wont turn on using the laptops function key for it (FN + F12). I have tried the latest drivers and older drivers.

My laptop is a Toshiba Satellite P850. I have the latest drivers for rest of the hardware installed. the WiFi function key does work but seems to have no effect on the WiFi card, even tho the flash cards work, and the Pro-Set software can see the card. In both my Windows 7 and Ubuntu builds (and intel proset software) on the system it says the WiFi is turned off by the hardware switch as said above i don't have one, nor does the function key seem to work with it.

This fourm post on Toshiba's forum outlines what I have tried so far: http://forums.computers.toshiba-europe.com/forums/message.jspa?messageID=299642# 299642 http://forums.computers.toshiba-europe.com/forums/message.jspa?messageID=299642# 299642 NOTE: I am JMZ10 on that forum.

Before replying please read that post carefully, as I have tried quite a lot of things, checked a lot of things and so on.

I dunno if its much use coming to intel for help but I figure its worth a try, thanks in advance.

0 Kudos
1 Reply

In this case I may suggest using Intel® Proset Wireless Software to run the Manual Diagnostics Tool; however, it is possible you will get the same result. Usually it is necessary to use the hardware switch, function keys, software switch, or a combination of those methods provided by the system manufacturer in order to enable WiFi radio.

http://www.intel.com/support/wireless/wlan/sb/CS-020275.htm Intel� Wi-Fi Products; Wireless radio cannot be enabled from software

Reviewing the fact that this is not working in two completely different operating systems, and the old card is no longer operating, I suspect a hardware issue with the wireless adapter or the mini PCI Express connector.