Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,231 Views

Centrino Advanced-N 6230 driver properties does not show 802.11n Mode option

Jump to solution

Hello All,

I have a Dell XPS 15 (l502x) that came bundled with Centrino 1030. This card works perfectly, detects all networks, can connect to N networks just fine.

I have recently updated my router to a Asus N56U, which is dual band and thus, decided to upgrade to a Centrino 6230 card so I could use all the new rounter could give. So, I uninstalled Intel drivers, turned the notebook off, swapped the cards, booted windows back again and installed Intel drivers again.

Now to the odd part. Although I'm using the same driver version (15.1.1) from Intel website, with the 6230 card I can't see the option to enable 802.11n network mode, and thus, can't connect to any "N" networks. On Intel ProSET software, all networks that are N, only shows the "G" icon and my 5GHz network shows only the "A" icon. Even worst is that if I connect to a G or A network, then the card won't get a IP from the router, regardless if I try a 2.4GHz or a 5GHz network.

With the old 1030 card, none of the above happens, and I can connect to my 2.4 GHz N network just fine.

I have tried to change all settings from the router and still no good. I'm suspecting this is a hardware issue, but wanted to confirm this is not a known driver issue or if there is something I'm missing out before I send the card back to the retailer for an exchange.

All the best,

Tiago

Tags (3)
0 Kudos
1 Solution
idata
Community Manager
160 Views

According to this product brief: http://www.intel.com.br/content/dam/www/public/us/en/documents/product-briefs/centrino-advanced-n-62... http://www.intel.com.br/content/dam/www/public/us/en/documents/product-briefs/centrino-advanced-n-62..., there are two versions of the Centrino 6230 wifi card - 62230ANHMW which supports 802.11a/b/g/n standards and the 62230AGHRU which supports only 802.11a/b/g standards.

The card I've received was the GHRU one, thus, the lack of the "802.11n Mode" option on the advanced settings.

I'm leaving this info here for future reference, in case anyone else have this same problem.

All the best,

View solution in original post

3 Replies
idata
Community Manager
160 Views

Hello Tiago, thank you for your post.

 

The issue you describe seems to be related to integration. The only setting you can check, is on your laptop in device manager, double click on network adapters then on the Intel® adapter. In the advanced tab click on the "802.11n Mode" option, and make sure on the right it says "enabled".

 

If this does not work then you may need to return the card to Dell as they would have sold you a card that has not been customized for this laptop. (Note that due to FCC and IEEE regulations these cards need to be customized by the laptop manufacturer to may sure that they are and stay compliant with the Radio regulations)

idata
Community Manager
160 Views

Hi Nathalie.

Thanks for your reply. That's the main problem. The option "802.11n Mode" is not present on the advanced dialog. Thus, I can't enable it. I wonder why all other wireless standards works just fine - A and G are both connecting normally, just the N option that's not showing.

So, as you're stating, this means that this card is not compatible with the notebook?

PS: How can I attach an image?

idata
Community Manager
161 Views

According to this product brief: http://www.intel.com.br/content/dam/www/public/us/en/documents/product-briefs/centrino-advanced-n-62... http://www.intel.com.br/content/dam/www/public/us/en/documents/product-briefs/centrino-advanced-n-62..., there are two versions of the Centrino 6230 wifi card - 62230ANHMW which supports 802.11a/b/g/n standards and the 62230AGHRU which supports only 802.11a/b/g standards.

The card I've received was the GHRU one, thus, the lack of the "802.11n Mode" option on the advanced settings.

I'm leaving this info here for future reference, in case anyone else have this same problem.

All the best,

View solution in original post

Reply