Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
6698 Discussions

Centrino Wireless-N 1030 - Sorry but I'm utterly frustrated


The laptop it's in is Fujitsu A531, but it seems I'm not the only one with the problem that doesn't happen only on that type of laptops. OS is win7 x86, I've put the latest driver from this site (the one that came with the laptop was older and didn't work either). It's 15.3.1.s32.

The problem?

I can see all available wireless networks. And I can successfully connect to my own one (it's protected with WPA2 in case it's of some importance).


I've tried just everything I've seen all over internet ppl were suggesting, ipconfig with flushdns/release/renew, disabling 802n on card properties, minimizing power saving on it (set max. performance), etc etc, there is no single option I didn't try to change and nothing helped.

To be safe and not sorry, just to check if there is something wrong with OS, I've took a crappy USB stick I use on my desktop PC to connect to wi fi and it connects normally when plugged into laptop. And it's D-link's cheap junk.

Ppl please help. Just please don't tell me my only option is to buy another D-link stick to use with the laptop.

Just to be sure you understood the problem. Laptop sees the network and connects to the router. But doesn't get internet access for whatever reason. IP address and DNS are set to automatic (router DHCP). I suspect the driver of course

0 Kudos
4 Replies

Hi JoxerTM,

I would like to know if the Intel® Centrino® Wireless-N 1030 came pre-installed in your system, something else that would be helpful to know is if you ever got it to work with your router before and if you have tested any other wireless network with a different AP.


I'm not sure what preinstalled in this case means. If you ask if the laptop came with already installed OS and drivers, then no, OS and drivers were installed after the laptop was bought.

In the meantime, I had another case where the connection behaves the same way (connected to router via wi fi, but "no internet access"). It's a different laptop from my work - Lenovo model T420.

Inside it is not Intel Centrino, but definetly is another Intel Wi Fi device as I've checked the system immediately when I got the problem and spotted the driver with almost the same name that was on Fujitsu machine with Intel Centrino.

On both machines win7 x86 is installed, maybe one of recent win updates causes this behavior? I tend to suspect that too because the laptop from my work used to connect on the router before and one day just stopped working correctly out of no reason. But since we get software automatically updated via SCCM it's possible that the driver was updated with an erroneous version. It's something I cannot check or confirm however as I don't have any control on that and it happens automatically.

Is it possible however that the router simply doesn't "like" Intel's wi fi signal and won't allow the internet connection? The router is D-link model DSL-2640R, See, the laptop from my work manages to connect and establish an internet connection over wi fi in another place where I've seen another type of router (IIRC some white Gigaset model, but I can check that up too).

However, I don't have the laptop from my work on me this very moment. Tomorrow I'll bring it over and post which Intel wi fi device exactly is inside and it's driver version.

Oh and the story doesn't end here. At work we use CheckPoint software for establishing VPN connection when outside of the company but in need to access our network over internet. For whatever reason we can't use the latest version of CheckPoint on Lenovo T420 as it causes BSOD. How do I know the culprit is wi fi device? Because if I disable (fn+F5) wi fi device, BSOD won't happen at all. And also, we use some other laptop models with other wi fi devices in combination with the latest CheckPoint client and on any of them BSOD doesn't occur.

However, if I downgrade CheckPoint client version no BSOD happens.


I have HP Pavilion Beats with Intel Centrino Wireless-N 1030. Wireless connectivity fine until about a month ago when it would disconnect at random but for no more than a few seconds - always just enough to cause grief. I contacted ISP, HP but no one could fix it. No error message under device manager which reported it was working. Finally, it just ceased to work at all and would not find my router. My tablet, my smartphone and my wifi printer could and all had excellent signal. The N 1030 is soldered in place so replacing it myself not an option. I spent hours trying to solve this but eventually gave up and purchased a TP-LINK dual band USB adapter. Installation a doddle, software set it up and there is a wireless management tool. I have had no problems all day, good speeds and can use the dual band access, which the N 1030 does not have. Good luck!


If the connection was working fine before probably something changed and passed unnoticed; I would say usual suspects are driver updates, security software updates, and Windows* updates. So, it could be mostly software related unless the router has been replaced.

I assume you have tried a clean installation of the drivers, disabling firewall or antivirus, AP firmware update. There is also the possibility of using Windows* System Restore.