Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7107 Discussions

Comcast Router "secured but no internet." Arris TG862 modem. Works on some devices, but not others with Intel AGN 5300


Hi all.



I'm having a strange problem on two computers with AGN 5300 wireless card. My modem is the Arris TG862 xfinity modem, if that helps.


I generally have no problems connecting to it with a few cell phones phones, a couple of Macs, and a PC netbook. However, I have two PCs which cannot connect to the internet when I connect them to my comcast wifi network. I just get the little yellow triangle error. I have tried resetting the router, made sure I'm connecting to the right network and using the right password, tried ipconfig in the cmd line, uninstalling/reinstalling drivers, updating drivers, and anything else I could find online, and nothing is working. I even disconnected a couple of other devices in case there is a limit, and that didn't help either.

They're both older laptops which were refurbished. One is a Thinkpad t400 with Windows 7, and the other is a Dell E6400 with Windows 10. Both can connect to wifi when I used wireless tethering with my phone, so I don't think there's anything wrong with either computer wireless capabilities. They both have the Intel AGN 5300 wireless driver. They've never connected to my xfinity wifi either, so it wasn't that they were working and then suddenly stopped.

The wifi works on some other devices otherwise (not sure what the Macs use, but the netbook has a Broadcom adapter, and I can connect with an iPhone, and a few androids), so the connection fine too. Has anyone else experienced this? Is there a solution?

Thanks so much for any help

0 Kudos
1 Reply

Hello Mistermiscer87,



Please keep in mind that the Intel® WiFi Link 5300 (AGN) has been discontinued and is no longer supported. We can provide some suggestions as an extra mile, but cannot guarantee a resolution.



- https://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000006507.html Customer Support Options for Discontinued Intel® Wireless Products.



Looking at your router, it seems to be an 802.11g model (a 2002 legacy standard). Your wireless adapter on the other hand is 802.11a/g/n certified.



While wireless standards are backward compatible, wireless routers don't usually take kindly to this, and often have issues when newer products try to connect. This seems to be your current issue.



There are two ways to address this, we can suggest trying both if possible.



1. Check to see if there is a firmware update available for your router.


2. Limit your wireless adapter to the older standard. You can access the wireless mode settings on your adapter through the Device Manager: http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005585.html Advanced Intel® Wireless Adapter Settings.



Best regards,


Carlos A.
0 Kudos