Showing results for 
Search instead for 
Did you mean: 
Community Manager

Connecting My Wifi's shared internet to...

I've been able to connect my printer via the shared internet, however everytime I try to connect my XBOX 360 I run into a supposed "password mismatch." When I broadcast my Wifi via My Wifi on my laptop my Xbox picks up the signal, yet when I try to connect and type in the security key to connect to the network my XBOX 360 notifies me that there is a Password Mismatch, I've double, and triple checked that the passwords were the same. Then I tried using a different password, still had the same issue. Any suggestions?

-Thanks, John M.

0 Kudos
4 Replies
Community Manager

Hello John,

We have not seen this behavior when using Intel(R) My WiFi Technology, however, we would strongly suggest contacting the XBOX Support team for compatibility.

Check to see if you need anything extra in terms to setup on the XBOX* side, what would be the actual supported security protocols and moreover, if there's any update needed.


Community Manager

Thank you for getting back to me Stitchz@Intel

So I've gone through the troubleshooting on the XBOX website and have been lead to believe that the solution may be in me changing MyWifi's channel.

"The Xbox 360 S console's built-in Wi-Fi uses the 2.4 gigahertz (GHz) frequency band. If your router is broadcasting using another frequency, your Xbox 360 S console cannot connect to your wireless network....." -Xbox Troubleshooting

According to another article I found that I am able to change the channels over which MyWifi can broadcast, which would change the frequencies. I followed the step by step process provided to change my channel and I encountered this error upon clicking the "Advanced" tab when trying to edit a Profile.

Problem signature:

Problem Event Name: BEX64

Application Name: PanUI.exe

Application Version:

Application Timestamp: 4b913daa

Fault Module Name: PanUI.exe

Fault Module Version:

Fault Module Timestamp: 4b913daa

Exception Offset: 00000000000bde04

Exception Code: c000000d

Exception Data: 0000000000000000

OS Version: 6.1.7601.

Locale ID: 1033

Additional Information 1: 18aa

Additional Information 2: 18aa415970f65e122c00fb5a4febcdbe

Additional Information 3: 394b

Additional Information 4: 394bab43d81b51e98977af03e7d25511

Any recommendations?

-Thanks again, John M.

Community Manager

I followed the step by step process provided to change my channel and I encountered this error upon clicking the "Advanced" tab when trying to edit a Profile.

Try closing MyWifi program before going to Advanced tab.

The procedure you followed is correct. The wireless channel and frequency settings are found inside Advanced tab of wireless adapter properties.

If you still encounter error, try uninstalling then reinstall MyWifi tech software.


Hope this helps.
Community Manager

I've uninstalled and reinstalled My Wifi Technology, however if I press the advanced tab the entire program crashes. I've recently put realized the connectivity that my printer has to the computer doesn't require an internet connection. So I proceeded to see if the issues was only with my Xbox. In doing so I attempted to connect my cell phone to the internet that my computer is broadcasting. I ran into the issue that my phone was "unable to obtain address." So essentially my printer has been connected the entire time via an Adhoc network. This "unable to obtain address" error seems fitting because my xbox is constantly attempting to connect to My Wifi Technology and then disconnecting repeatedly.

Any help would be appreciated, thanks John M.