Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7659 Discussions

Connecting issue with Wireless-AC 7260


Hey guys.

I got an Intel AC7260 mini PCI-E wireless card installed on my motherboard, and it might have some issue when connecting to my ASUS RT-AC86U router (latest official firmware, non Merlin or third party).

The wireless card can search and connect to 2.4GHz and 5GHz signals, and seems working fine at first, the link speed is pretty good, but after about 1 minute more or less of heavy network load, like downloading, online video streaming or remote desktop in full speed for example, the wireless network icon of Windows 10 becomes a yellow exclamation sign, all the SSID except for the current connected one cannot be shown, and the computer cannot reach any Internet or LAN address.

The only solution is to click disconnect, run Windows network troubleshoot, which the troubleshoot report that the wireless controller need to be reset, and then it can reconnect to any SSID again, but the issue will happen again soon.

Meanwhile, when this issue is occurring, the mouse cursor will also stucks then recovers every few seconds, no matter it's a corded mouse or wireless mouse.

This issue has nothing to do with the Windows 10 version, and I got the newest version of PROSet Wireless Software (20.50.0) and newest driver version (, x64) installed. Rolling back to an early software and driver version did no help.

The router is working perfect with my iPhones, Macbook Pro, Qualcomm Atheros AC wireless card, Realtek USB AC wireless card and Broadcom AC wireless card.

BTW, the AC7260 adapter is working great with my old Linksys E3000 dual-band 802.11n router in both 2.4GHz and 5GHz with 300Mbps link speed.

So, any solutions or suggestions?


0 Kudos
3 Replies

Hello nfsking2,



Thanks for posting in our communities. We understand that you're experiencing connection issues while your system with an Intel® Dual Band Wireless-AC 7260 connects to an ASUS RT-AC86U* router.



From the adapter side we recommend that you try different drivers. Some users report to have a better experience when using the inbox driver (these are the drivers installed by Windows* if no other drivers are found). To install them, simply uninstall the current driver:


  1. Uninstall the Intel® PROSet/Wireless Software.
    • Open Programs and Features (Uninstall a program) from the Control Panel.
    • Select Uninstall or Change and then Remove.
    • When prompted, choose to discard settings.
  2. Uninstall your wireless driver.
    • Go to Device Manager.
    • Expand the Network Adapters category.
    • Right-click your Intel Wireless Adapter and choose to uninstall it.
    • Make sure to select the option to Delete the driver software for this device.
  3. Clear out your temporary files.
    • Press the Windows* key and R key simultaneously to open the run box.
    • Type in: cleanmgr.exe and press the Enter key or OK.
    • Place a check mark next to Temporary Files. You can leave everything else checked or unchecked.
    • Press OK and wait.
  4. Reboot your computer. Windows* will install the drivers on its own.


As for the router, you may run some tests to discard a work load issue:

- Save/record your configurations and reset the router. Make sure the affected system is the only device connected to the router after reconfiguring. Test the connection.


- Temporarily disable QoS and other security related options. Test connectivity once again.

Please let us know if there's anything else we can help you with.

Best regards,


Eugenio F.
0 Kudos

I've already tried this for many times, it did nothing with this issue.

I've also tried to change the settings of the wireless configuration of the router, like wireless SSID, channel, encryption type. There is no any QoS or VLAN configured in my router, and any settings about energy saving are disabled in adapter driver settings.

The only way to solve it, is to leave the HT mode on HT instead of VHT in the adapter driver settings, but this will cause the link speed keeping on a very slow rate.

BTW, the Windows Event shows that there are a lot of errors about this adapter :

NETwNb64, Event ID = 5007, (Description is not useful as the associated resource from the event log message is not correctly installed)

NDIS, Event ID = 10400 (The network interface "Intel(R) Dual Band Wireless-AC 7260" has begun resetting)

NETwNb64, Event ID = 5032, (Description is not useful as the associated resource from the event log message is not correctly installed)

I did some searching online, and these errors in Windows Event log seemed pretty common with AC7260 adapter, but no one got any useful suggestion or solution.

0 Kudos

Hello nfsking2,



Thanks for your reply.



At this point, we recommend to backup your data and clean install the operating system.



If the issue persists, please https://www.intel.com/content/www/us/en/support/topics/oems.html contact your system OEM (Original Equipment Manufacturer) for further assistance. Some customers have reported similar issues have been solved by replacing the adapter hardware, even with the same model.



However, please bear in mind that this could be a compatibility issue between the router and the adapter. As you mentioned, the system was working right with an older router.



Best regards,


Eugenio F.
0 Kudos