Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
3,476 Views

Dual Band Wireless-AC 8260 Discovers But Won't Pair

This is on a Lenovo Thinkpad P70 with Windows 10 64-bit. It is just over a year old and just out of warranty. I have not previously used Bluetooth on this device, and would now like to attach a Bluetooth 3.0 keyboard.

In the Device Manager Bluetooth was originally hidden and the drivers said "Currently this device is not connected". I uninstalled these, deleting the software, and installed BT_20.10.0_64_Win10.exe (Verion 20.10.0.9). The drivers then said "This device is working properly".

It appears to work, but fails to connect to any Bluetooth devices I have tried. It does discover the devices and show them as available. (See the image). They just don't pair. The same devices pair and work fine with my Galaxy S7 phone and Microsoft Surface Book.

I also tried BT_19.71.0_64_Win10.exe (Version 19.71.0.2) with the same results. I tried the download from the Lenovo site, which is for 19.71.0.2). It appears to run successfully, but the drivers have light blue icons, say "Currently this device is not connected", and you have to select Show hidden to see them. (This was how the Device Manager looked when I started.) Thus, this Lenovo driver update doesn't seem to work.

The BIOS is the latest and Windows is up to date with Creator's Fall Edition.

The Intel drivers both appear to work, but don't pair. I'm not sure what to do next.

0 Kudos
23 Replies
Highlighted
Beginner
12 Views

Hi Carlos,

I got an email that you closed the incident, which is ok. I have not made an update because I am still working on the problem. This is the status:

I did get a USB adapter from Plugable. Their support is very good. However, it has the same problem: It discovers but doesn't pair. I have also found it does Bluetooth Low Energy (BLE) ok.

I have downloaded sample discovery and pairing code for Bluetooth from Microsoft and can trace more deeply into where the problem occurs.

This is the line where pairing occurs:

DevicePairingResult dpr = await deviceInfoDisp.DeviceInformation.Pairing.PairAsync();

1. The devce to pair is in deviceInfoDisp, which comes from the discovery.

2. The call is deviceInfoDisp.DeviceInformation.Pairing.PairAsync();

3. The call returns dpr, which has dpr.Status which has "Authentication Failed" unless the device was off, in which case it has "Authentication Timeout". This is what appears in the Event logs, as well. There are many other possible Status values.

AccessDenied

Your application does not have the appropriate permissions level to pair the device object.

AlreadyPaired

The device object has already been paired.

AuthenticationFailure

Authentication failed, so the device is not paired. Either the device object or the application rejected the authentication.

AuthenticationNotAllowed

The authentication protocol is not supported, so the device is not paired.

AuthenticationTimeout

The authentication process timed out before it could complete.

ConnectionRejected

The device object rejected the connection.

Failed

An unknown failure occurred.

HardwareFailure

The device object indicated there was a hardware failure.

InvalidCeremonyData

The ceremony data was incorrect.

NoSupportedProfiles

There are no network profiles for this device object to use.

NotPaired

The device object is not currently paired.

NotReadyToPair

The device object is not in a state where it can be paired.

OperationAlreadyInProgress

<td style="border-top: 1px solid # e0e0e0; border-botto...
0 Kudos
Highlighted
Community Manager
12 Views

Hello Ken,

 

 

Not the result we were hoping for, but thanks for the update all the same.

 

 

Everything seems to point to an OS level problem. At this point it might be worth revisiting the idea of reinstalling the operating system, either from a https://www.microsoft.com/en-us/software-download/home clean image or using the https://support.microsoft.com/en-us/help/12415/windows-10-recovery-options recovery options.

 

 

However, you could also try running the DISM commands to see if that utility is able to locate and fix the problem (heads up, these take a while to run).

 

 

- https://www.windowscentral.com/how-use-dism-command-line-utility-repair-windows-10-image How to use DISM command-line utility to repair a Windows® 10 image

 

 

NOTE: Any links provided for third party tools or sites are offered for your convenience and should not be viewed as an endorsement by Intel® of the content, products, or services offered there. We do not offer support for any third party tool mentioned here.

 

 

Best regards,

 

Carlos A.
0 Kudos
Highlighted
Beginner
12 Views

Carlos,

Reinstalling the OS and my applications would be over a weeks work. I have done this previously and it has never solved the problem. Not worth it to have a Bluetooth keyboard.

The computer runs fine apart from this problem.

I have already run sfc / scannow and it found no problems for dism (or itself) to fix.

One explanation is that Lenovo has done some OEM thing. Unfortunately their update is broken. I have cleaned out the file store so it won't load an old driver if it fails and may see what happens if I run the update again.

0 Kudos
Highlighted
Community Manager
12 Views

Hello Ken,

 

 

Don't worry, I definitely understand how much of a hassle reinstalling the operating system can be. Mostly because of what comes after reinstalling.

 

 

Please give the DISM commands a shot and let us know if they help.

 

 

Best regards,

 

Carlos A.
0 Kudos