Issues related to Intel® Wireless Adapters and technologies
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6085 Discussions

Installed windows 7 ultimate (64-bit) on a new hard drive, now I can't connect to the internet


Both the Intel Wifi Link 5300 AGN and the Intel 82567LF Gigabit Network Controller adapter displays error code 31 in device manager, and I even downloaded the right drivers, but it cannot install it. I can't update anything because these things doesn't work (and without them I can't even set up an internet connection, not even in ad-hoc)

I have an external HDD which i transferred these driver programs to my pc, from another pc. The computer is fairly old; a Packard Bell Easynote TK-11-BZ-100NC bought in 2011.

Please help! -been long without pc and finally I thought I can start again after installing a new SSHD, but these problems are annoyingly important to fix...

0 Kudos
3 Replies
Community Manager

Hello S3-Gaming,



The Intel® Wifi Link 5300 AGN has been discontinued and reached the end of it's interactive support cycle. However, we can provide some troubleshooting suggestions in a best effort basis. For help with your Ethernet controller we can recommend creating a post on our /community/wired Wired Ethernet Community.



The device manager error code 31 occurs when Windows* can't load the drivers for your device.



The suggested troubleshooting for this issue is to install the latest drivers for your device. Our recommendation is to use the drivers provided by your computer manufacturer, as your adapter may have been customized by them when it was integrated into your system.



As an alternative, you may try using our latest generic Intel® drivers published for your adapter:


https://downloadcenter.intel.com/download/23491 Intel® PROSet/Wireless Software and Drivers for Windows 7* Version 16.7.0



You can read more about customer support options for discontinued Intel® Wireless Products in the following article:


http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000006507.html http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000006507.html



Best regards,


Carlos A.

Yes, I tried that program, and also downloaded and tried to install all of the driver from Packard Bell's own download page for this model. Without success, though. It seems like the drivers are installed, but when I click on the status info in Device Manager, it says that all of the latest drivers are already installed for that device, but it is still unusable.

It could be that both the wireless adapter and the ethernet controller are damaged, but that is not really easy to tell as it is a laptop and I don't even have the tools to bend it open. Do you think it is possible to buy a standalone wifi adapter that can fit into the USB port?

Can I override the integrated adapters with that or will it most likely not happen to work? (InB4 I buy it)

Thank you for the quick response, Intel

Community Manager




It's possible that they both could be damaged, but it's a bit unusual. Specially considering you're receiving the same error code on both.



We can recommend a couple of additional steps:



1. Make sure you're using the latest BIOS version available


2. Make sure the Fast Boot option is disabled in the BIOS


3. Under Power Options, managing advanced power settings, make sure your wireless adapter is set to Maximum Performance.


4. In the device manager properties for your adapter, under Power Management, toggle the option to allow your system to turn off the device to save power.


5. Make sure you've tried both available downloads for your adapter (PROSet, and Driver Only).



If this all fails, you may want to speak to your system manufacturer, as they're always the best source for support in these case.



However, a wireless USB adapter is a perfectly viable option. Since these adapters work through your USB, they don't usually interfere with your built-in adapter. If they do, all you would need to do is to disable your current adapter from the device manager.



Best regards,


Carlos A.