Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,391 Views

Installing AC-7260 causes whole system heavily lag. (BIOS, Grub, Linux and Windows) acer 5750G laptop

After upgrading the original network card to an Intel AC-7260 my laptop is crippled. The card works as advertised, network connection and Bluetooth work but the laptop is almost un responsive. Post and boot (ssd) time takes multiple times longer, grub boot menu takes several seconds from hitting a key to the menu moving. Opening chrome has gone from almost instant to watching the window slowly bloom. CPU, HDD are idle system acts normally with original card replaced.

Any hints would be greatly appreciated. I really need a dual band card and the bluetooth is a real bonus.

0 Kudos
3 Replies
Highlighted
Community Manager
27 Views

Hello Gen_Dave,

 

 

We regret to inform you that what you are doing is not supported.

 

 

In this case, it's very likely that the wireless adapter is not entirely compatible with your laptop. We always recommend contacting your computer manufacturer for an approved parts list before upgrading your wireless adapter, and if possible, to purchase the adapter directly from your computer manufacturer to avoid incompatibility due to differences in sub-models or model versions.

 

 

- http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005846.html Why Doesn't My Laptop Recognize My New Intel® Wireless Adapter?

 

- http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005687.html Regulatory Information Regarding Wireless Hardware Installation or Upgrade.

 

 

We can suggest the following troubleshooting steps, but we cannot guarantee a resolution. The main problem being that your issues seem to be system wide, and not OS specific.

 

 

- Make sure that you're running the latest wireless drivers:

 

Windows*: http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005634.html http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005634.html

 

Linux*: http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005511.html http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005511.html

 

 

- Ensure your power settings are optimal:

 

1. Device Manager > Network Adapters > Intel(R) Dual Band Wireless-AC 7260 > Properties > Power Management > Toggle option to allow Windows* to turn off device.

 

2. Control Panel > Power Options > Set plan to Maximum Performance, or edit current plan > Change Plan Settings > Change Advanced Power Settings > Wireless Adapter > Switch Power Saving Mode options to Maximum Performance.

 

3. Disable fast startup in Windows* (8.1 and above): Power Options > Choose what the power buttons do (left-hand panel) > Change Settings > Uncheck Turn on Fast Start Up > Save.

 

4. In your BIOS, search for "fast boot" type options and disable them.

 

 

We hope this helps.

 

 

Best regards,

 

Carlos A.
0 Kudos
Highlighted
Beginner
27 Views

Thanks for the reply.

I've managed to get it to work fully by blocking pin 51.

Laptop works correctly, wifi is working great bluetooth is working better as well.

Thanks again.

Gareth

0 Kudos
Highlighted
Community Manager
27 Views

Hello Gen_Dave,

 

 

We're very glad to find out that you were able to get around the issue. Thank you for sharing your solution with us, we're sure it will be helpful to other users visiting this forum.

 

 

If you have further questions, just let us know.

 

 

Best regards,

 

Carlos A.
0 Kudos