Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
97 Views

Intel 7260NGW not working in Windows 10 no matter what

Good day everyone!

I've been having a very frustrating time. After having a cheap USB WiFi thing conk out on me, I didn't have much of a budget. I bought one of these PCIe x1 WiFi cards from eBay that is nothing more than a Intel AC 7260 M.2 NGFF WiFi card in a PCIe x1 device with antennae. So I know for a fact that this WiFi card, the Intel AC 7260 (7260NGW) works because I have been using it on my (Windows 10) laptop until literally just a few hours ago. When I plug it into the PCIe adapter card and into the PCIe x1 slot on my desktop's motherboard, a (steady) green light comes on.

When I go into Windows (10, in my case. Which is officially compatible with the AC 7260), Device Manager recognizes both the AC 7260 and the Bluetooth device, but has errors for the former and unknown device status for the latter. Which is strange, because I'm using the exact same generic 2015 drivers that Microsoft has loaded into Windows on the laptop and it works without a flaw. Click on properties and it says "Code 10: Device could not be started". Look deeper and it seems to stem from one specific driver:
netwbw02.inf
no lowerfilter, upperfilter is vwifibus
Problem: 0xa
Status: 0xC0000001

Here's where the weirdness commences. I tried using Intel's official PROset installer. The error persisted. I uninstalled all drivers and clean reinstalled. Still error. I tried Lenovo specific drivers that were older (since the card was pulled from a ThinkPad), this gave me an install error and BSOD'd when trying to restart so I had to do a System Restore.

Before we go any further, I want to clarify that all these efforts mentioned from here onwards were done after the restore where I made sure to uninstall the drivers from the previous network adapter and the previous tries of installing drivers for the AC 7260, and disabled onboard ethernet to make sure. That's where I am now, I am back at the state where Bluetooth works but WiFi does not. The driver issues seem to point towards Microsoft's own driver files relating to the NETwNb64 service.

The errors say that the "PCI device had a problem starting", first driver name: netwbw02.inf, problem: 0xA, status: 0xC0000001; for the second driver: oem54.inf, problem: 0xA, status: 0xC0000001.

Does anyone have a clue what could be causing these driver issues? I know this card is functional, and that it works on Windows 10, with those drivers in specific. I am attaching a screenshot of what the Device Manager configuration looks like on the laptop where it works.

I am on MSI's latest BIOS for motherboard. Using a Ryzen 3 3200G. I have tried changing the PCIe slots and doing the pin taping tricks as suggested online to no avail. Any ideas?

 

Tags (2)
0 Kudos
3 Replies
Highlighted
Beginner
74 Views

So it's been a few days because I wasn't bothered to reset the BIOS. That has been done. First, it didn't see the card in the PCI_E2 slot anyway, so I switched it to the big x16 slot and now the BIOS sees an Intel network card at x1 speed. Unfortunately, this has not solved anything: the code 10 error persists in Windows 10. To clarify: I am following Intel's recommended procedure of uninstalling PROset and the bluetooth drivers from Control Panel, discarding settings, doing a Disk Cleanup to remove temp files, then shutting down. On restarting, I install the Intel bluetooth drivers first, and then the PROset drivers to no success. I have tried forcing Device Manager to pick up on the directory with the unpacked Intel .inf's but it says it already has the best drivers installed. No success..
So is there some fundamental incompatibility between this motherboard, the drivers and Windows 10?

 

0 Kudos
Highlighted
Super User Retired Employee
58 Views

There is no PCIe x1 connector available?

...S

0 Kudos
Highlighted
Super User Retired Employee
57 Views

Here is proper process for performing a clean WLAN Install:

 

  1. If you haven't already, download - but do not install just yet - the latest Bluetooth and WiFi drivers for your adapter. Here are links to these drivers: https://downloadcenter.intel.com/download/29790/Intel-Wireless-Bluetooth-for-Windows-10 and https://downloadcenter.intel.com/download/29520/Windows-10-Wi-Fi-Drivers-for-Intel-Wireless-Adapters...
  2. Disable Internet access. Unplug Ethernet cable and/or disable wireless. Keep disabled until told to re-enable.
  3. From Apps & Features app, uninstall any instances of the Intel PROSet/Wireless Software and Intel Wireless Bluetooth. When prompted, choose to "Discard Settings".
  4. Manually shutdown and reboot your computer.
  5. In Device Manager > Network Adapters, check for entry for Intel Dual Band Wireless-AC 9560. If none, go to Step 8.
  6. Right click on the entry for your Intel Dual Band Wireless-AC 9560 and uninstall it., choosing to "Delete the driver software for this device".
  7. Go to Step 4.
  8. (Optional but recommended) Clean out all temporary files using the Windows Clean Disk tool. I recommend that you checkmark all categories offered, even if no files currently (so it leaves it set up for next invocation).
  9. (Optional but recommended) Clear each of your browsers' cache.
  10. Install the Bluetooth driver package.
  11. Install the Wireless driver package.
  12. Manually shutdown and reboot your computer.
  13. Enable Internet access.
  14. Test.
0 Kudos