Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JJ31
Beginner
3,121 Views

Intel 8260 + HP ZBook Studio G3 Connection issues. Somewhat driver dependent.

Hello Intel Folks

I've got an issue with the wifi on the device listed above. This has been happening on and off throughout the time I've owned the laptop. Before digging into it I initially believed it was my router but I decided to do a test and put another computer I have (coincidentally also an 8260 device) on wifi instead of hardwire. Only the laptop dropped connection and my phones, etc stay connected so I think it's isolated to this device.

I've got windows 10 installed with all the updates.

I began to pay attention to the issue more and noticed that when this happened, the system would no longer show the adapter installed. I would need to reset the entire computer to get it back. Things improved DRASTICALLY with the 19.50 version of the driver. This is the only version of the driver that allows the system to recover a connection but the wifi adapter does appear to cycle either through connection or power or something.

When i installed the 19.60 driver, once the wifi adapter has whatever issue it has, it simply shuts off until I restart. It also caused the system to hang during the restart at the "restarting" screen with the circle of spinning dots. I had to roll the driver back to get an acceptable level of operation.

I have updated the bios in this machine and run the intel driver utility to keep everything up to date.

Any next steps i should be taking to debug this? I've seen similar issues on the forum but nothing quite the same.

0 Kudos
17 Replies
JJ31
Beginner
161 Views

I've seen this in other support topics so i've attached a scan from the System Support Utility to aid in the diagnosis.

idata
Community Manager
161 Views

Hello JJWifiHelp,

 

 

We understand you're having issues with your laptop using the Intel® Dual Band Wireless-AC 8260 and Windows® 10.

 

 

- Does this issue happen regarless of the network, or only with this particular one?

 

- Do you use Miracast* (screen casting) or WiFi Direct (file sharing) regularly on this system?

 

 

Looking at the SSU report that you shared with us we found a couple of settings that may be changed in order to troubleshoot your issue (http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005585.html how to access advanced settings).

 

 

1. DisableMIMO Power Save Mode

 

2. (Optional) Since you're connecting to a Wireless-N network you may disable Wireless-AC to increase compatibility. This is done by switching the HT Mode from VHT to HT Mode.

 

3. Make sure that your router is using the latest firmware. Depending on your router this may be done with the hardware manufacturer or your internet service provider (ISP).

 

 

We look forward to hearing back from you.

 

 

Best regards,

 

Carlos A.
JJ31
Beginner
161 Views

 

I've not traveled with this laptop yet so it's hard to say if it's related to this network. We do have other laptops in the house that connect to this network without issue and never drop the connection. I have confidence that the wireless connection is always available based on all of the other connected devices we check when this happens.

I do use miracast regularly and I love it. I've never done wifi direct yet but if it's useful in the troubleshooting to disable it, I'll try whatever we need to.

I typically use the AC wireless but I will go to N when I am farther from the router such as outside my house. I find it has higher signal strength and tolerates the distance better.

The router is a netgear wndr3700v3. The firmware is as up to date as you can get.

I've set the MIMO Power Save Mode to "No SMPS" and will run with those settings and report out on the weekend if it appears to work. Thanks for the follow up.

idata
Community Manager
161 Views

Hello JJWifiHelp,

 

 

I don't think it's your network, but the compatibility between your AC wireless adapter and your N network could be an issue in some cases. Usually either a firmware update for your router or disabling wireless-ac should fix the issue if that's the case.

 

 

We did run into a somewhat /thread/113129 similar performance issue when using Miracast. That issue was resolved by disabling the Receive Segment Coalescing feature on your operating system.

 

 

To do this, you will need to run command prompt as administrator. You can access this by right clicking your start menu icon and selecting "Command Prompt (admin)", then inputing the following command:

 

  • netsh int tcp set global rsc=disabled

We look forward to finding out how this works out for you.

Best regards,

 

Carlos A.
JJ31
Beginner
161 Views

Carlos,

Thanks for the follow up.

If it helps clarify anything, I don't encounter these performance/reliability issues when using Miracast specifically. They will occur during normal browsing and internet usage as well as Miracast. I will try disabling the RSC feature tonight and see if it makes a difference. I remember coming across that article earlier and may have tried it before.

Beyond a video recording, is there any logging I can do to capture the shutdown/bug/reset event? It's quite easy to re-create. I just have to use the computer for about 30 minutes.

idata
Community Manager
161 Views

Hello JJWifiHelp,

We can take a look at your event viewer logs and WLAN report.

For your WLAN report, you may follow the https://www.tenforums.com/tutorials/47080-create-wlan-report-windows-10-a.html guide posted by tenforums.com*

Now, for your event viewer logs we will need to do some housekeeping first in order to avoid getting too many unrelated events:

1. Open event viewer by pressing the Windows* key + R to open the Run dialog, enter eventvwr (or eventvwr.msc), and press OK.

2. Clear your system event logs:

 

3. Reproduce your issue.

 

4. Export the system event logs:

 

5. Compress the file (if needed) so that it may be attached to your reply:

 

*NOTE: Any links provided for third party tools or sites are offered for your convenience and should not be viewed as an endorsement by Intel® of the content, products, or services offered there. We do not offer support for any third party tool mentioned here.

Best regards,

 

Carlos A.
JJ31
Beginner
161 Views

Carlos

Didn't take very long for it to die and reset. About a half hour.

 

I was using Mircast to project a youtube video to another screen so there was the full spectrum of traffic.

 

There are a lot of logs in the wlan report but the actual event began at this line:2017-05-31T17:27:34

[+]Wireless security stopped.

I can recreate the event later without miracast if it matters. I also should have rebooted before doing the wlan report. I'll do it next time.

Hopefully it's useful.

Thank you

Jesse

idata
Community Manager
161 Views

Hello JJWifiHelp,

Please make the following adjustments to your wireless adapter's settings:

  • Packet Coalescing: Disabled
  • Roaming aggressiveness: 1. Lowest

We can also make sure that your wireless adapter always operates at maximum power:

  1. Open Power Options from Control Panel, or by right clicking your start menu.
  2. Click on Change Plan Settings next to your current power plan, then on Change advanced power settings.
  3. Wireless Adapter Settings > Power Saving Mode > Set both "On battery" and "Plugged in" to Maximum performance.

We look forward to finding out if this makes a difference.

Best regards,

 

Carlos A.
JJ31
Beginner
161 Views

Okay, I've disabled Packet Coalescing and set Roaming Aggressiveness to 1.

I had already made the changes to the power settings earlier so it's fair to say at this point we can rule that out.

Thank you for your ongoing support.

idata
Community Manager
161 Views

JJWifiHelp,

 

 

We're always glad to help. Do let us know how things go.

 

 

Best regards,

 

Carlos A.
JJ31
Beginner
161 Views

No shutdown since the last changes but i haven't used it heavily. I'm trying to stress tested using vnc and miracast but it's not going down.

If i don't get a failure by the end of the weekend, i'm going to upgrade the driver version to 19.60 and try the same settings again.

I'm intrigued. What do those settings do?

idata
Community Manager
161 Views

Hello JJWifiHelp,

 

 

No shutdown is good. We hope things continue this way.

 

 

Packet coalescing basically bunches wireless packets together so that they will be easier to process for your CPU. Which is great, but in some cases may cause issues, as you're well aware now.

 

 

Roaming aggressiveness on the other hand is much simpler. This tells your wireless adapter to look for another network if your signal drops bellow a certain point. The higher the setting, the sooner your adapter will decide to jump ship and try to connect somewhere else. We suggested this one because in your WLAN report there were several issues happening after your adapter tried to roam, meaning this may be one of the issue triggers.

 

 

Best regards,

 

Carlos A.
JJ31
Beginner
161 Views

Thanks for that information.

I think this is a working solution and you've been a great help. After changing those settings, I was able to decide when i was done screen sharing vs it being decided for me.

I've not had any shutdowns but I've also not had a lot of traffic across the system either. Despite the fact that it's working I've got this disease called "engineer" and I have to figure out if it's driver dependent and/or what specific feature so i'm going to go down the rabbit hole a bit.

I'm going to test it for 24 hours with a mix of local traffic before upgrading the WiFi driver and trying it again.

Do you know if there's a way to clear out the wlanreport logs? I'd like to make a log for each config I test.

idata
Community Manager
161 Views

Hello JJWifiHelp,

 

 

We can definitely relate. Celebrating early and then getting blindsided by the issue returning is no fun. We look forward to finding out how your testing turns out.

 

 

I'm not aware of any way to clear the wlan report, but will research and let you know if I find a way.

 

 

Best regards,

 

Carlos A.
idata
Community Manager
161 Views

Hello JJWifiHelp,

 

 

We hope you did not run into any more issues since your last post. If you need any further assistance feel, free to contact us again.

 

 

Best regards,

 

Carlos A.
JJ31
Beginner
161 Views

Carlos

Thanks for following up. I've been quite busy and haven't had time to formalize any tests (best laid plans...). I've had the failure occur twice since then but I was abusing my connection quite heavily (iSCSI, VNC, SMB file sharing). Nonetheless, the changes you suggested made a great improvement.

This is still on the 19.50 driver. I haven't yet pulled logs but I will try to get some data again. I think when the next driver release comes out, I'll upgrade and see if it makes a difference.

If there are any other suggestions you might have for increased reliability, I can try them.

Thank you for your support.

-Jesse

idata
Community Manager
161 Views

Hello Jesse,

 

 

We don't have much else to suggest at this time. However, working a similar case we found that lowering the maximum transmission unit (MTU) setting could also help, and I do believe you may be running into a related issue.

 

 

1. Open a Command Prompt using administrator privileges (Right click on the start menu, select "Command Prompt (admin)" from the list)

 

2. Find your adapter's name: netsh interface ipv4 show subinterfaces

 

3. Note your adapter's name under Interface, mine is Wi-Fi.

 

4. Set your Maximum Transmission Unit (MTU) size to 1400: netsh interface ipv4 subinterface Wi-Fi mtu=1400 store=persistent

 

- Note: If your adapter name has more than one word, you will need to write it in quotations. For example: "Wi-Fi 2" or "Wireless Network Connection".

 

5. You should receive an output stating "Ok." after which you may close your command prompt and test your adapter.

 

 

I've attached a screenshot from one of our test systems for reference.

 

 

Best regards,

 

Carlos A.
Reply