Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
943 Views

Intel 8625 Wi-Fi radio won't enable

Jump to solution

Dear users,

I'm faced with a bit of an odd problem at the moment. I have a desktop PC (Asrock Z370 Extreme4 based) that I wanted to add bluetooth to. The motherboard has space for an E-key M.2 slot and I purchased an AC-8625 to fit in there. The I/O shield has two cutout holes for the antennas to fit through and while finnicky the install went pretty smoothly. Once booted up and in Windows I installed both the wireless and the bluetooth drivers from the Intel website. They both installed fine and the device is recognized in Device Manager. Now here's the issue. I can't possibly get the Wi-Fi to turn on. Whether I enable it in the Config Panel or in the bottom right Network & Connections tab. The device simply won't turn on. Bluetooth on the other hand works absolutely fine and dandy. Reception is great and the soundbar I had planned on using it with sees it and communicates well with it. That said, I do want the wireless to work because if the product is faulty I can still RMA it as DOA. I have tried a wireless USB stick and that seems to work just fine, so I don't see it being a Windows settings issue. Am I missing something here or is my unit simply broken?

Windows 10 x64

Asrock Z370 Extreme4

AC-8625

Kind regards,

MarnickV

Tags (1)
0 Kudos

Accepted Solutions
Highlighted
Beginner
17 Views

It has been fixed. I had a good look at the BIOS (AsRock Z370 Extreme4) to see if there was any settings that needed set for the M.2 E-key slot and low and behold there's actually a setting there that blocks the WiFi antenna from enabling. I turned that off and now it works like a charm!

View solution in original post

0 Kudos
1 Reply
Highlighted
Beginner
18 Views

It has been fixed. I had a good look at the BIOS (AsRock Z370 Extreme4) to see if there was any settings that needed set for the M.2 E-key slot and low and behold there's actually a setting there that blocks the WiFi antenna from enabling. I turned that off and now it works like a charm!

View solution in original post

0 Kudos