Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,447 Views

Intel AC 7260 does not show 802.11n mode preference

Hi,

I've recently bought dual band router TP-Link archer C7 and was hoping to get better WiFi performance by using 5GHz (plenty 2.4 GHz WiFi's in the neighborhood).

I've set up the router, upgraded firmware to the latest one.

On my laptop I have an Intel AC7260 card with latest driver (18.33.3.2) - upgraded today:

I was looking at Intel www to see the recommended card settings (http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005585.html Advanced Intel® Wireless Adapter Settings ) and found the "802.11n mode" which is not visible:

My WiFi connection is still poor (max 10 Mbps while on a cable it goes way over 30).

Can anyone help me how can I turn "n" (or possibly "ac" - which is supperted by the router for 5GHz WiFi) on the Intel card?

Thanks a lot!

0 Kudos
4 Replies
Highlighted
Community Manager
19 Views

Hello zaiac,

The "802.11n mode" is available for 802.11n Intel® Wireless Adapters. It is not a valid setting for the Intel® Dual Band Wireless-AC 7260. The AC 7260 and other 802.11ac adapters use the "HT mode" value:

HT mode (supports 802.11n compatibility)

 

VHT mode (supports 802.11ac compatibility.)

For more information about this, please review the following document:

http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005585.html http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005585.html

Here are some initial recommendations for the connectivity issue:

- Apply the settings recommended in the following advisory:

http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005544.html http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005544.html

- Check the router and make sure that you are using a different SSID for the 5 GHz band, and that it is properly configured for 802.11ac.

- Review the QOS configuration of the wireless Access Point and make sure it has "WMM" enabled for the network. Also, any access list, or priority settings must be disabled, or at least giving high priority to the PC using the AC 7260.

 

 

Regards,

 

Jonathan.
0 Kudos
Highlighted
Beginner
19 Views

Thank you Jonathan for your answer.

Is there any specific reason you are recommending to set up the 5GHz SSID WiFi as different to 2,4 (and not having both with the same name)?

I've followed the recommended settings topic.

WMM is enabled.

Is there any way I can verify if I'm using g/n/ac mode?

Thanks,

zaiac

0 Kudos
Highlighted
Community Manager
19 Views

You can check the Radio type and other properties of a connected wireless network by clicking on the wireless icon of the notification area, then hovering over the network.

 

 

Regarding the SSID's, for optimal performance you would prefer to separate the networks. You will be able to confirm if the computer (or device) connects to the 5 GHz network; take into consideration that 802.11ac only works in the 5 GHz band.

 

Also, you may want to check your Access point documentation to know how to get the best configuration for it.
0 Kudos
Highlighted
Community Manager
19 Views

We have not heard from you since our last message. Feel free to let us know in case you require additional assistance.

0 Kudos