Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MMi7c
Beginner
2,471 Views

Intel AC 7265 WIFI on Thinkpad Helix 2nd Gen intermittently fails to work waking from sleep

When this happens I have to turn WIFI on and off to regain connectivity. Have no issue with other devices such as Surface Pro 3 (using Marvell WIFI), Galaxy Note series phones (Broadcom WIFI), etc. via the same 5GHz 802.11ac to TP-Link Archer C7 v2 firmware 149929 dated 9/29/2014.

Have tried without success:

- Newest Lenovo 17.13.2.2 and Intel 17.13.11.5 drivers

- New laptop BIOS update 1.42 dated 1/15/2015

- Applied all Windows updates including optional KB3000850

- Removing hidden duplicate virtual adapters in Device Manager

The only thing that seems to make it work consistently is setting Transmit Power from default Highest to Medium. Successfully tested twelve sleep/wake cycles whereas normally it would intermittently fail after a couple.

Can Intel please work with Lenovo to investigate, formulate a corrective action and update the driver/firmware so the burden isn't on the customer?

0 Kudos
15 Replies
Jose_H_Intel1
Employee
265 Views

Is the option "Allow the computer to turn off this device to save power" enabled in the Power Management tab of the wireless adapter properties in Device Manager?

Does the driver show up an error in Device Manager?

MMi7c
Beginner
265 Views

joe_intel, I don't have that tab under my device properties with either Lenovo or Intel drivers.

Unfortunately, the issue still occurs so disregard the transmit power setting.

MMi7c
Beginner
265 Views

Progress update. Since "allow the computer to turn off this device to save power" doesn't show as a tab in device properties I did some digging and was able to disable the option via a DWORD 'PnPCapabilities' registry entry set to hex 24 (see link below). Knock on wood it's survived every sleep/wake cycle test including an extended sleep overnight on battery. Fortunately, Core M is so low power using only about 1.5% per hour while on connected sleep (aka connected standby or Instantgo) so it's a viable workaround.

http://www.thewindowsclub.com/allow-computer-turn-device-save-power http://www.thewindowsclub.com/allow-computer-turn-device-save-power

MMi7c
Beginner
265 Views

Disregard last update.

The testing wasn't valid since I had a continuous ping from another computer going that was preventing the AC 7265 WIFI from going to sleep and masking the issue that still occurs even with "allow the computer to turn off this device to save power" disabled.

Furthermore, according to Microsoft the value should be 24 decimal or 0x18 hex. With the correct value in place the device won't wake on the second attempt.

Starting over from scratch with Intel 17.13.11.5 driver and no registry change but with "wake on pattern match" disabled I'm on day two with no loss of WIFI upon waking from sleep. Going to withhold final verdict until it works consistently for a week and after confirming this driver version correctly allows the device to gracefully hibernate on critical 4% battery since I've seen it reboot instead on a few occasions.

Will update in a few days.

MMi7c
Beginner
265 Views

After running for about five days without experiencing limited WIFI waking from short and extended overnight sleep it's safe to say that for my situation disabling "wake on pattern match" under WIFI device properties advanced tab has made the issue completely go away. I don't believe it's driver version specific but using latest Intel 17.13.11.5 driver-only without PROset since it causes "WLAN Extensibility Module has stopped" in event manager. Depleted battery twice to 4% and both times it gracefully hibernated.

KMaso1
Beginner
265 Views

I'm running a Dell Venue Pro 7140 (Core M) with an Intel 7265 wifi adaptor. I'm having exactly the same issue. So far, I have updated my Dell's BIOS to revision A03 with no inprovement. I also performed a factory restore of the OS, followed by full Windows updates (Windows 8.1) to really make sure all is good. None of those made it better.

When the connection is limited on wake-up, disconnecting and reconnecting to the wifi network always fixes it.

I have set 'wake on pattern match' to false, and also set the transmit power to 'medium-high'. I will run this for a period and report back on whether it works.

MMi7c
Beginner
265 Views

Just wanted to clarify that the work-around by disabling 'wake on pattern match' only applies to 802.11ac for me. When using 802.11n it still intermittently loses connectivity when waking from sleep. Will update if I find a work-around for the 802.11n issue but for now I just use it on 802.11ac.

KMaso1
Beginner
265 Views

It seems that setting 'wake on pattern match' to false worked for me,, and also setting transmit power to medium-high; the problem has not recurred. By the way, I'm on an 802.11n network,

I haven't verified which of these settings made the difference, or whether it's a combination of both.

KMaso1
Beginner
265 Views

I have now absolutely verified that disabling 'wake on pattern match' completely fixes this problem on my 802.11n network.

ASouz7
Honored Contributor II
265 Views

KimMason,

Is this wireless adapter the original one that came installed in your computer when you bought it?

POcie
Beginner
265 Views

I am sorry but this card, or rather the drivers are a kind of joke – I have Acer Aspire R7 with card being integrated by OEM. I have almost immediately upgraded to W10 so I have no experience on its behavior on W 8.1 but what I am seeing now is simply unacceptable. I have wake up issue with additional connection drop outs, when intense traffic occurs. With the previous driver card simply lost connection the the router (R7000), after update to 18.12.1 it was fixed but above symptoms occurred. Sorry for being frustrated but I have purchase the laptop to use it and not to go through forums and look for the solution for fixing one of the fundamental notebook function – wi-fi connectivity. If I would like to be a beta tester for an equipment I would signed for it (and most probably get paid for doing it). I have put usb wi-fi dongle from EDIMAX with ( I know…) beta W10 drivers and surprise surprise everything is working, no drop outs no issues whatsoever – so it is possible to make reliable product with working drivers… Thankfully I have it.

Bottom line - thanks INTEL for resolving those issues – so commonly reported - asap.

ASouz7
Honored Contributor II
265 Views

foxlife,

Since you have used out latest drivers and the symptoms still occur our best recommendation would be to contact Acer* and see if they have any fix available as we understand the card is OEM's. On our best effort to help you with this, please check the solutions below that might help you improve your connection.

http://www.intel.com/support/wireless/sb/CS-030709.htm?wapkw=wifi+recommended+settings Recommended Settings for 802.11n Connectivity

http://www.intel.com/support/wireless/wlan/sb/CS-025332.htm Intel® Wi-Fi Products — Resolving Wi-Fi Network Connection Issues

http://www.intel.com/support/wireless/wlan/sb/cs-006205.htm Intel® Wi-Fi Products — Power Save Polling (PSP) Causes Connection Issues with Access Points

http://www.intel.com/support/wireless/wlan/sb/CS-035591.htm Intel® Wi-Fi Products — Current Top 10 Frequently Asked Questions

http://www.intel.com/support/wireless/wlan/sb/CS-025393.htm Intel® Wi-Fi Products — What Are the Advanced Wi-Fi Adapter Settings?

http://www.intel.com/support/wireless/sb/CS-029893.htm Wireless Networking — Frequently Asked Questions - Wi-Fi

POcie
Beginner
265 Views

Thanks for your reply but after checking all possibilities and different drivers I have come back to W8.1 and everything is working with no issues whatsoever.

Waiting for usable drivers to switch to W10.

JKoed
Beginner
265 Views

Currently testing the "wake on pattern match" fix as well on a Dell XPS 13 9343 (2015)

Will report back.

EDIT: So without setting transmit power to medium-high it did not work. Trying that fix now. Will also report back.

MMi7c
Beginner
265 Views

FYI, if disabling "wake on pattern match" alone doesn't fix it try that setting along with the older 17.0.6 driver linked below:

https://downloadcenter.intel.com/download/24873/Intel-PROSet-Wireless-Software-and-Drivers-for-IT-Ad... Intel® Download Center

Reply