Wireless
Issues related to Intel® Wireless Adapters and technologies
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6032 Discussions

Intel AX210 bluetooth not connecting peripherals

Mirec4167
Beginner
2,306 Views

Hello, I would like report issue with Intel AX210 wifi card in my laptop Lenovo Legion Y740, I cannot connect wireless mouse Microsoft Sculpt Comfort and Logitech KB K380, all latest intel drivers installed via Intel driver support assistand, SSU dump is attached.

Please try to resolve with next drivers update

Thank you

0 Kudos
18 Replies
David_G_Intel
Moderator
2,280 Views

Hello Mirec4167

  

Thank you for posting on the Intel️® communities. 

Does this same thing happen with Lenovo's drivers? Please share with us some driver versions you tested.


Regards, 

David G 

Intel Customer Support Technician


Mirec4167
Beginner
2,269 Views

Hello, thank you for your swift reply, the laptop was originally equipped with wireless card Killer 1550i, which I replaced firstly with AX200 and later with AX210. AX200 worked allright, but with AX210 I have before mentioned issues. As you most probably understood, there is no official driver by laptop manufacturer for either AX200 or AX210 as none of them are manufacturer certified for this laptop. Only your generic drivers are available.

Driver version as all details of my laptop I provided in the SSU dumpt, but its the last one currently available 22.50.1.1.

 

BR

Mirec4167
Beginner
2,267 Views

oh, and btw. I also cannot connect my cell phone Samsung Galaxy S21 G991B via BT

n_scott_pearson
Super User Retired Employee
2,258 Views

(Admittedly) Grasping at straws, have you verified that the antennas are properly connected to the card? This sounds suspiciously like what you would see if you had no working antennas.

Hope this helps,

...S

Mirec4167
Beginner
2,250 Views

Hi Scott, thank you but that did not help, I just opened the laptop and replugged the card and its still the same.20210622_093739.jpg

n_scott_pearson
Super User Retired Employee
2,239 Views

In this picture, it looks like the black antenna wire may be touching the tie-down screw. This will cause transmission issues. Try putting a piece of electrical tape between them and over the screw.

...S

Mirec4167
Beginner
2,230 Views

no, its not touching, it just seems like that on the photo as it has been taken from above position, its connected as it exactly the same way as it was by laptop manufacturer, just a different card

n_scott_pearson
Super User Retired Employee
2,220 Views

Put a piece of tape there anyway. The antenna cable may be pressed against the post when the chassis is assembled.

...S

Mirec4167
Beginner
2,205 Views

Hi Scott, ok, I did as you suggested and put a piece of electical tape between the screw and antenna cables just be sure there is no short circuit. But that doesnt solve the issue, I tried all 3 above mentioned devices and still nothing. If I initiate pairing from laptop, the confirmation message on phone appears, but after confirming the connection the laptop says- couldnt connect, try again later. If I try to initiate the connection from my phone, there is no reply from laptop at all, no confirmation popup message on the phone to confirm like before on AX200 or Killer 1550i.

n_scott_pearson
Super User Retired Employee
2,199 Views

So tell me, did you do a clean install of the Wireless and Bluetooth driver packages after changing to the AX210 module? This is an absolute must when you make a change like this; the packages contains multiple drivers, but only the drivers for the module present are installed. When you change modules, you need the clean install to ensure that the updated drivers are installed.

...S

Mirec4167
Beginner
2,189 Views

Hi Scott, yes I did, using device manager and also unistalled related app packages via Program uninstall. Both for Intel BT and WiFi. And downloaded latest drivers from intel site and installed them. 

n_scott_pearson
Super User Retired Employee
2,175 Views

Ok, I got nothing. I am certainly not seeing these issues with my AX210. Intel Customer Support (@David_G_Intel?) will need to step in here and investigate.

Sorry,

...S

Mirec4167
Beginner
2,139 Views

Hi Scott, yes, please do that, I still count on Win 11 roll out on Monday via insider built, will see if the issue remains and will report, thank you

Mirec4167
Beginner
2,110 Views

Hi Scott, so I installed first dev built of Win 11 and I the issue with my phone is resolved, but the mouse and keyboard still the same. If I use quick pairing then both are paired but dont connect. If I disable quick pairing then I cannot pair and connect them at all. Just scanning for devices, but these 2 dont show up, other devices in my home like my LG TV, Govee smart backlight or even some devices of my neighbours do show up. Re-attaching SSU dump again.

David_G_Intel
Moderator
2,101 Views

Thank you for your response Mirec4167. We are currently working on this request, the updates will be posted on the thread.


Regards, 

David G 

Intel Customer Support Technician


David_G_Intel
Moderator
2,076 Views

After checking the information provided, the problem appears to be integration. Since this is not the original card that came with your system, it is recommended that you check with Lenovo Support for compatibility, drivers, and guidance on installing the card.

Windows 11* is not supported yet, so we recommend using Windows 10 * for now. Please check with the laptop manufacturer for further help or information. Keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding.  


Best regards, 

David G 

Intel Customer Support Technician 


Mirec4167
Beginner
2,061 Views

I finally managed to connect all the devices, from some reason drivers for keyboard, mice etc. (HID) have not been loaded using Bluetooth&devices section of Settings. I had to manually install both the KB and mouse using the good old control panel.

Thank you though for your support

Mirec4167_0-1625679027770.png

 

BHarr8
Valued Contributor I
2,051 Views

Related to this there is a known bug with Windows and Bluetooth where if you upgrade your Bluetooth + WIFI combo card with existing paired devices the existing paired devices cannot be unpaired or re-paired.

You can fix this by either going back to the old card and unpairing everything and then upgrading again or delete the paired devices from the registry.:

https://mostechtips.com/solved-cant-remove-bluetooth-device-in-windows-10/#method4

Reply