Showing results for 
Search instead for 
Did you mean: 
Community Manager

Intel Centrino Wireless N-130

Hi. I have recently purchased a new laptop (Samsung NP300EZ-S01RO) that has this specific Wi-Fi card. The problem? My connection speed won't go above 54mbps no matter what. I have Win7 x64, Linksys E1000 (v2) N router. I have the latest Intel drivers from their website, and after blaming my router 2 hours ago I installed DD-WRT firmware on it. I think it's something in the setting, but on a discussion on these forums someone said his N6300 Wireless card was incompattible with the exact same router. Any ideas ? Is this my problem too ?

0 Kudos
2 Replies
Community Manager

Thank you for your Post.

On your post you have not specified what settings you have for the network you set up on the router. But see the links below for the recommendations; first for an issue specifically with only getting 54Mbps connections:

And this one which lists the recommended settings to achieve the best performance in 802.11n

This wireless adapter you have supports a connection up to 150Mbps if there is not too much interference. It supports only 2.4 GHz networks, so you would need to ignore the settings for 5 GHz or 802.11a, since your adapter does not support it

Community Manager

First of all, thank you for your response. I want you to know that I had seen those links before and many others, but all failed. But I gave it another shot.

All my N-130 settings are as specified, except for "Throughput enhancement" which I don't have.

Concerning the settings on my router, the only difference was that i had packet burst enabled, and i disabled them but still no change: 54mbps. Hate this number already !

Concerning the other settings on my router: Security is WPA2 Personal - AES, WMM is enabled, QoS is disabled ( I had to set the speeds and I didn't know if to set the ones I have now or the ones I used to have). If you require other settings you would like to know, put them in a post and I will answer.

Last thing, one of the links you posted said I had to put my router in N-only mode. This is impossible because if I do that, Windows isn't going to let me connect anymore: "Windows was unable to connect to dd-wrt".

If you have any other ideas, I will gladly try anything.