Issues related to Intel® Wireless Adapters and technologies
6408 Discussions

Intel Centrino Wireless-n 2230 - Windows7 - random disconnects



I am the recent owner of an Asus N76VZ notebook, which has an Intel Centrino Wireless-n 2230 card, running on Windows 7 64 bit.

My router is a DLink DIR 615, and I have 2 other machines using wireless (n and g) without any issues for years. Security type is WPA2-Personal, encryption is AES+TKIP. Range/Strength are good/excellent, 4/5.


I am experiencing random wireless disconnects followed by reconnects... sometimes wireless will work for hours, sometimes it will disconnect every 10 minutes. When reconnecting, sometimes it works on first attempt, sometimes it keepes reconnecting for 3 minutes, 1 attempt every 30 seconds. The reconnects are disrupting any activity like online gaming, radio, and sometimes browsing...

The tool I am using to monitor them is the Wireless Event Wiever that comes with the drivers package, but Windows logs are showing the same thing.


I have tried all driver/app versions I could find for the Intel Centrino Wireless-n 2230 card, starting with and from Asus, also the versions available from Intel 15.6.1, 15.8.0, 16.1.1, 16.1.5. There was no improvement. [To make things worse, the Wireless Event Wiever tool that was installed by the newer Intel packages looses the logged events in "realtime" mode when closing, and does not register anything when closed, unlike the one that comes with the drivers from Asus.]


Also I tried every reasonable setting on router and card config: setting a fixed channel, disabling N, changing encryption, setting lowest roaming aggressiveness, nothing worked. Tested with another computer next to me and only the Intel Centrino Wireless-n 2230 was disconnecting from wireless. Disabled power saving for the adapter, that made things worse, wireless would stay off every time computer starts/wakes up.

Tried every checklist trick recommended on Intel support also.


The only info I could find are the log entries, showing an error RxDeAuth, with REASON_PRIOR_AUTH_INVALID, followed by AddToExclude with WEV_EXCLUDE_LIST_REASON_802_11_AUTH_FAILURE, these happen on each disconnect/reconnect.


I have no other ideas to try so I would appreciate some help in finding a solution. Next thing to do would be buying an external wireless Usb adapter, and never buying a computer having Intel Wireless again. So at least an explanation would be nice.


0 Kudos
1 Reply

I replied here: /thread/45696 https://communities.intel.com/thread/45696