Community
cancel
Showing results for 
Search instead for 
Did you mean: 
WConq
Beginner
2,154 Views

Intel Centrino n 2230 will not connect in wireless n?

Hi all,

I am finally resorting to just asking after combing through many of the discussions in regards to the n2230 nic. Here's my issue:

For some reason, my n2230 will not connect on wireless n. It connects just fine at 54Mbps on 802.11g. but if I change the setting in my router to N only, it will not let me connect. I am not having any fluctuations or anything. G is stable at 54Mbps, but N does not work at all.

I know it is not an issue with my router, LinkSys E1200, because I have another laptop, with an Aetheros nic, and it connects with wireless-N just fine. Unless somehow my router can only handle 1 N connection, which is rather absurd.

I have made sure that the encryption is on WPA2-AES,

per

http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm http://www.intel.com/support/wireless/wlan/4965agn/sb/cs-025643.htm

and have gone through the client adapter setting to make sure that my adapter is set to the default settings,

per

http://www.intel.com/support/wireless/sb/CS-030709.htm Wireless Networking — What are the recommended settings for 802.11n connectivity?

The router settings are at mixed 20 or 40 MHz, and is set to channel 11.

Thanks in advance for any and all help!

0 Kudos
11 Replies
Jose_H_Intel1
Employee
155 Views

Hello,

Try to set up the router in 40 MHz (wide channel) and so the Intel® wireless adapter.

http://www.intel.com/support/wireless/sb/cs-025343.htm How to configure 802.11n channel bonding on Intel Wireless adapters

WConq
Beginner
155 Views

It is already set to Auto allowing both 20 and 40 MHz.

HT1
Novice
155 Views

This card has major and I mean Major issues with everything, can't really understand how Intel could ship this out to so many consumers and manufacturers.

The card makes my brand new HP ENVY 15 feel like shit even though it is incredible on everything else.

So intel if you are aware of the issue could you please provide us information that is helpful and not just suggestions because this is either a big hardware problem or a big driver problem(15.8 drivers doesn't fix anything).

Jose_H_Intel1
Employee
155 Views

Please be aware that if you have a connection drop issue (as in the other thread) is completely different from what is being discussed here. We are working to get a fix for that connection drop issue; however, the adapter must connect at 802.11n, so it may be necessary to force both the adapter and router to 40 MHz channel width.

There is also the possibility of a hardware/integration issue and in such case you may want to contact the system manufacturer.

WConq
Beginner
155 Views

As I stated in the original post, I don't have a connection drop issue, I don't have a connection at 802.11n at all. When the router is set to only connect on wireless n, my laptop simply cannot connect to the router. All the while I have wireless n enabled on my nic properties and set to the recommended settings by intel, also stated in the original post.

So this means that I have a hardware/integration issue?

tvete
Valued Contributor II
155 Views

WConq
Beginner
155 Views

I tried that, but it did not help.

I got the proset software along with the driver, and through the proset interface, I can see that my network supports g and n, but the connection is in g at 54Mbps, with a radio frequency of 2.462GHz.

tvete
Valued Contributor II
155 Views

Here's the solution that will most likely work.

You need to enable WMM on the QOS settings

On your Router settings, click on "Applications & Gaming" and select the "QoS" sub-menu. Enable WMM Support.

The reason is that compliant IEEE 802.11n WiFi adapters must have WMM enabled to get the N speed. Non compliant ones like your Atheros will still run on N speeds despite the WMM being disabled.

Check out this link for more info: http://www.smallnetbuilder.com/wireless/wireless-features/30938-dont-mess-with-wmm Don't Mess With WMM! - SmallNetBuilder

WConq
Beginner
155 Views

Wow... that worked... and here I thought having WMM off was supposed to help with my speed, as reported by many others.

I think I was having some spotty speeds one day and found people saying turning WMM off should help with that...

Though out of curiosity, my connection speed is still only at 144Mbps, instead of the mythical 300Mbps. Would that be part of the issue on the other threads that joe_intel spoke of?

tvete
Valued Contributor II
155 Views

You need to set Channel Width to Auto or 40MHz as well as strict WPA2-Personal/AES encryption on the router. In addition, you need to set the channel width to Auto or 40Mhz on the advanced adapter (2.4 GHz) settings like in this pictures:

This should make the 300Mbps on 2.4 GHz work. Keep in mind that your linkspeed will vary from 72 - 300 Mbps since the 300Mbps mode is a lot more susceptible to interference with other routers compared to the 20 Mhz channel width only. Be sure set the best channel to get sustained 300 Mbps.

Message was edited by: theveterans veteran

WConq
Beginner
155 Views

Thanks