Issues related to Intel® Wireless Adapters and technologies
6168 Discussions

Intel Dual Band 3160 AC Fluctuating signal and extremely slow


Hello everyone,

A couple of days back I purchased the Dell Inspiron 15 7000 series( Dell Inspiron 7548) laptop with the Intel (R) Dual Band Wireless AC-3160 however I have noticed that the connection to the Wi-Fi in my home when using wireless is extremely slow and the signal bar fluctuates from 1 bar to 5 and often just disconnects. The wireless adapter works fine when I am right next to the router however in my bedroom it is extremely slow even when there are a few bars of connection and I cannot connect to the internet through ethernet port as there is no port for it! . I feel that this is not a problem with the router or my Wi-Fi in my home because the laptop i used prior to buying this one worked perfectly and other laptops in the house also get full bars of connection and high speeds in my room however my laptop does not. I have updated drivers from Intel main website to the most recently released driver, so I am beginning to think that the wireless card may be faulty. Any help would be immensely appreciated so thank you in advance.

0 Kudos
4 Replies
Honored Contributor II

Hello Jeevanb93,

Please know that any driver update to OEM (Original Equipment Manufacturer) adapters must be done through the OEM's support page, in this case Dell, as the adapters in this category, even though they are Intel(R) products they suffer customizations and adaptations in order to fit the system. Our drivers in our support page are generic and they may not fit the requirements of your system. On our best effort to assist you, here are our recommendations that might help you resolve this issue.

http://www.intel.com/support/wireless/wlan/sb/CS-031509.htm Intel® Wi-Fi Products — Possible Interference by Other Wireless Devices May Impact 802.11n Performance

http://www.intel.com/support/wireless/wlan/sb/CS-034658.htm Intel® Wi-Fi Products - Quick Checks That Might Improve or Fix Connection Issues

http://www.intel.com/support/wireless/wlan/sb/CS-025332.htm Intel® Wi-Fi Products — Resolving Wi-Fi Network Connection Issues

http://www.intel.com/support/wireless/wlan/sb/CS-025393.htm Intel® Wi-Fi Products — What Are the Advanced Wi-Fi Adapter Settings?

1 - Disable the Power Saving Functions:

  • Go to Control Panel >>> Hardware and Sound >>> Power Options >>> Set the High Performance and apply to the default settings.
  • Check the Change Plan Settings >>> Change Advanced Power Settings >>> Wireless Adapter Settings >>> Power Saving Mode and make sure both On Battery and Plugged in are set to maximum performance.

2 - Set the advanced settings of the Adapter:

  • Got to Device Manager >>> Network Adapters >>> Intel® Dual Band Wireless AC 3160 right click and select Properties.

  • Select Advanced tab to set the value u-APSD support to Disabled.

On a side note. Finding the optimized wireless connection settings between the wireless adapter and the router also helps for a steady connection.

Choosing and setting the band and the channel for the wireless connection for your router and adapter is also of great help. If you are in a place that has lots of physical barriers such as walls and the like, we recommend that you use 2.4GHz for better penetration capabilities which improves the connection signal if there are other solid objects in the way between where you want to have the computer and the router.

3 - You can also change the the wireless adapter advanced settings in order to match the settings of your router.

  • Set the wireless mode to 802.11 a/b/g/n. (choose the wireless mode according to the support mode of your router as in the example below.

  • Set the Preferred Band to Prefer 2.4GHz band.

  • Set the HT Mode to HT Mode for 802.11n compatibility. VHT Mode is for 802.11ac compatibility.

  • Set the 802.11n Channel Width for 2.4GHz to limit 20MHz. Please note that 20MHz has smaller bandwidth than 40MHz but it has better penetration capabilities which improves the connection signal.

We do hope this piece of information helped you to resolve this issue.


Thank you Aleki, I will try to change the settings as mentioned above and will let you know about the results.

Thanks again.

Honored Contributor II


We will be more than glad to assist you. We do hope you have it resolved.


Hello aleki_intel,

I made the changes as specified, but I noticed that turning off the Bluetooth helped a bit in the speed issue and I couldn't see any other major changes even after following the steps. Is it because of lower end wireless card used in the system. As I know 3160 is 1x1 stream and actually it operates well when Bluetooth is turned off?

I have posted the link here for your reference https://www-ssl.intel.com/content/www/us/en/wireless-products/wireless-product-selection-guide.html Intel® Wireless Products. The Wireless card I have is Intel Dual Band Wireless 3160 AC. So can I know if there is any other solution for this issue?

Thank you