Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
6713 Discussions

Intel Dual Band Wireless AC 3160 slow Connection and only 2,4 GHz


Hello there,

I have a Zotac ZBOX CI540 nano plus ( Intel Dual Band Wireless AC 3160 ) with Windows 10 Pro and Intel PROSet / Wireless 18.21.0 drivers .



Unfortunately I just get a 2.4GHz connection with 72Mbits .


Previously, I had Windows 8.1 on the computer and the same problem , with the new drivers . With the an old driver ( version 16 ) I had no problems and over 200 Mbits .



My router is a Fritzbox 7490th



Since the location of the router or the computer has not changed . So it's definitely a driver problem .
0 Kudos
3 Replies
Honored Contributor II


We understand you have already updated the drivers to version 18.21.0. When updating the drivers for your Intel® Dual Band Wireless AC 3160, always prefer to use the latest drivers provided by your computer manufacturer first as their drivers are specifically designed to meet all the requirements of your system. However, there are few steps that can help you improve your experience.


1. Disable Bluetooh* if not necessary as it uses the same antennas used by Wi-Fi and this can impact in your connection.

2. Disable Power Saving Functions: Go to control Panel >> Hardware and Sound >> Power Options and set the High Performance and apply to default settings.

3. Change the Power Plan: Access Change Advanced Power Settings >> Wireless Adapter Settings >> Power saving Mode and make sure both On Battery and Plugged in are set to Maximum Performance.

4. Go to Device Manager >> Network Adapters >> Intel® Dual Band Wireless AC 3160 and right click on it in order to open Properties.

5. Next, select the tab Advanced and set the value of U-APSD support to Disabled.

6. Check the value of Transmit Power and make sure it is set to 5. Highest.

7. Set the Preferred Band to prefer 2.4GHz band.

8. Set the Wireless Mode 802.11a/b/g according to the support mode of your router.

9. Set the HT Mode to HT Mode.

10. Set the 802.11n Channel Widith for 2.4GHz to limit 20MHz.

11. Set Roaming Agressiviness to Lowest.

12. Set the Ad Hoc QoS Mode to WMM Disabled.

13. And last but not least, change the channel on your router to a less crowded one, most routers come by default set to channel 11 and 6.


On the OS:

Windows®10 comes with an intelligent feature that uses a lot of bandwidth that comes activated by default upon OS upgarde. It is called Windows Update Delivery Optimization (WUDO) and it is designed to help users to get faster software updates which is quite a good idea to habdle massive traffic of up to 40 Terabits per second (TBps). See illustrative picture below:

To turn this feature OFF, follow the given steps:

1. Go to Settings in the Start Menu.

2. Search for Updates & Security.

3. Under Windows Update, open Advanced Options.

4. Under Choose How Updates are Installed, select Choose How Updates are Delivered.

5. Disable the toggle under Update from More than One Place.


Thanks for the quick and detailed response.



Even before I put all your settings . I have found in other forums These suggestions .


Unfortunately still no improvement .


The driver from the manufacturer's website ( Zotac ) I had also already tried before .



This same problem that the speed is throttled and my wifi does not combine with 5GHz, I have also at my NUC Kit D54250WYK . Here I have an Intel AC 7260.


With Windows 8.1 on my Intel NUC ,i had about 300Mbits, with Windows 10 144Mbits . However, I had the same problem on Windows 8.1 with new drivers . As already mentioned, it worked only with the Intel WLAN Driver Version 16th.

Other devices (Sorry: iPhone/iPad ) connect without any problem to the 5GHz network and have full reception.


Has no one answer ?



It can not be but that Intel has such trouble with the drivers ? If you are looking for Intel 7260 and slow , one obtains various entries that describe the same problem .



Since the driver update from 16 ... does not work anymore !