Issues related to Intel® Wireless Adapters and technologies
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
6566 Discussions

Intel Dual Band Wireless AC 7260 problem with advanced settings!


Today I installed this card in my PC, it worked fine at first, then I noticed it only connected to my network at the 802.11g standard and won't go any higher than 54Mbps.

So I went to Device Manager, went to the card advanced settings and changed them. OK, now it connects to 802.11n standard, but I can't play games on Steam. The connection to the Steam servers is lost, about 10 seconds after launching a game. Reverting the settings back to default, Steam games work but I have to play at a crappy speed of 54Mbps at 802.11g standard.

Please tell me how to force the card to connect at 802.11n standard without messing with the settings in the advanced tab.

0 Kudos
3 Replies
Honored Contributor II

Hello wHiTeLiKeSnOw,

We would like to mention that Intel does not support custom integration of wireless adapters. The end user is not authorized to install these wireless adapters. They can only be installed by the manufacturer or its authorized representative.

Each laptop computer original equipment manufacturer (OEM) may have altered the features, incorporated customizations, or made other changes to the software or software packaging they provide. The software provided has not been verified by your laptop manufacturer as to compatibility or other operation.

In our best effort, we advise you to try the following actions:

1. Manually download and install the most recent driver version for the wireless adapter according to your OS (18.21.0 for current Windows® versions):

https://downloadcenter.intel.com/product/75439/Intel-Dual-Band-Wireless-AC-7260 Drivers & Software

2. If the issue persists, you will need to review the Driver advanced settings. You can start by matching the ones from the advisory:

http://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005544.html?wapkw=intel+wi-fi+recommended+settings 802.11n Connectivity Recommended Settings for Wireless


Thanks jonathan, but it didn't work. I updated the drivers and configured the card, but I still can't play Steam games with it. I can only play if I disable everything from the Advanced settings tab, and am forced to use 802.11g standard. Isn't there any other way to set the card to 801.11n standard without messing the advanced settings?

Honored Contributor II

If your Access point supports 802.11n, you may try disabling some of the AC features in the advanced settings:

HT mode: HT mode


U-APSD Support: Disabled

- Make sure you have the most recent Firmware for you Access point.

- Disable Authentication in the router, and check if the connection improves.

- If your Network works in the 2.4 GHz band, try disabling the Bluetooth device in your PC.