Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
Announcements
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
6692 Discussions

Intel(R) Wireless-AC 9462 not working on 5Ghz networks

Laperche
Beginner
930 Views

Hi,

The complete specifications of my notebook are in the SSU file attached. The notebook is quite new, and i just added extra RAM and an extra SSD, all the rest is original.

I got a Samsung Book NP550XDA-KF2BR for work, and it comes with an Intel(R) Wireless-AC 9462, but, since the beginning of the year, i cannot relate exactly when, i noticed it started failing and losing packages ONLY on 5ghz networks (n or ac, it doesn't matter). But when connected to 2.4ghz it works perfectly.

It happens on all 5Ghz networks I've tried, at work (i have 3 separate places that i connect to at work, in different cities, different routers). My cellphone (Galaxy S21) and my tablet (galaxy tab s8) connect perfectly to these wifi hitting over 300mb.

 

I already read the foruns, tried all different configurations on the device manager for wireless settings, already unninstalled and reinstalled not only the device, drivers, but even the whole windows 11.

 

The logs of the SSU shows a LOT of messages like:

...#SSU#...
#Logs#System Messages#Included
-------------------------------------------------------------------
Intel(R) Wireless-AC 9462 : Internal error and failure
-------------------------------------------------------------------
Intel(R) Wireless-AC 9462: Determined that the network adapter is not working properly.
-------------------------------------------------------------------

 

When on wifi, i am having to router the connection from my cellphone, where i lock the 2.4ghz, and on 802.11n it works perfectly again, like the example that i am using right now, routed from my phone.

Laperche_0-1654798829210.png

 

After trying almost everything i could get my hands on, please dont even bother with netsh and ipconfig commands, i came to the conclusion that it is a mutual crappy job by the Intel card with Windows 11, but it might as well be the card only.

 

Is there any hope for a sollution or, as it seems, i am stuck using 2.4ghz networks?

 

 

0 Kudos
2 Replies
Laperche
Beginner
912 Views

Just updated to Driver version 22.140.0.3 as shown bellow:

Laperche_0-1654805403723.png

 

No changes to the problem, as a simple ping to a trustworthy site shows:

Laperche_1-1654805477116.png

It keeps getting errors, losing packets, but when i return to my routed cell phone (which is connect to the same network on 5Ghz)

Laperche_2-1654805559503.png

Then the internet works perfectly

Laperche_3-1654805589668.png

 

 

 

 

Sage99
Novice
900 Views

you may want to consider getting in touch with the notebook manufacturer for possible hardware issue since you've already isolated the driver, configuration and external factors such as wireless access point and 5Ghz connections (cellphone and tablet).

Reply