Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
5,054 Views

Intel(R) Wireless WiFi Link 4965AGN Driver for Windows 8

Jump to solution

Hi, recently i have been having BSOD due to Intel(R) Wireless WiFi Link 4965AGN, i have been looking for its drivers for Windows 8 but can't seem to find them. Did Intel release its drivers for Windows 8 yet? If yes where can i find it?

Thanks.

0 Kudos
1 Solution
idata
Community Manager
2,156 Views

Thank you for your post.

The Intel® Wireless WiFi Link 4965AGN is not supported under Windows* 8. But Microsoft* did include some base drivers for it. Unfortunately there are no downloadable drivers for this wireless adapter, see below:

http://www.intel.com/support/wireless/wlan/sb/CS-033845.htm http://www.intel.com/support/wireless/wlan/sb/CS-033845.htm

You may want to run Windows* updates, the embedded drivers are usually updated through regular updates from the Operating System.

View solution in original post

7 Replies
idata
Community Manager
2,157 Views

Thank you for your post.

The Intel® Wireless WiFi Link 4965AGN is not supported under Windows* 8. But Microsoft* did include some base drivers for it. Unfortunately there are no downloadable drivers for this wireless adapter, see below:

http://www.intel.com/support/wireless/wlan/sb/CS-033845.htm http://www.intel.com/support/wireless/wlan/sb/CS-033845.htm

You may want to run Windows* updates, the embedded drivers are usually updated through regular updates from the Operating System.

View solution in original post

idata
Community Manager
2,156 Views

Thank you for replying.

I already tried using windows update, but its not listed in the updates.

idata
Community Manager
2,156 Views

Appears there is a sufficient workaround by disabling 802.11n mode. I've recently experienced similar problems with the 4965AGN and Windows 8, including intermittent wireless disconnects that would only restore if the machine were rebooted. On another discussion thread someone had mentioned that there problems went away when they disabled Wireless-N on the adapter. I did the same and I've had no problems since. Downloading the latest drivers from MS and Intel did not fix the problem, it was isolating 802.11n wireless-N mode that did the trick. From other discussion threads it appears the 4965AGN has had issues going back a number of years. Regardless of who is responsible for this driver, I'm glad to have finally found a workaround and my ThinkPad T61P with Intel wireless is working like a champ on Windows 8 by merely disabling 802.11n mode.

idata
Community Manager
2,156 Views

I've been using the default driver provided by Microsoft (dated 15/08/2010) and originally had issues like you described - random disconnects that would only be solved by rebooting the laptop. On a hunch, I disabled the "Allow the computer to turn off this device to save power" option, like so:

Haven't had a single problem since. Hope this helps.

idata
Community Manager
2,156 Views

Following Steve's suggestion fixed my problems! (At least for now).

Many thanks, I've been trying all sorts of driver manipulations to get it to work.

One thing I noticed is that once the power savings kick in, the connection info would display 54Mbps even though my router is capable of 300Mbps (the adapter usually shows 80-117Mbps in the status window). To me, it looks like windows suspends the adapter partially (only the N part) then gets confused by that and can't wake it up - because it's not fully in sleep mode.

LVinh
Beginner
2,156 Views

I've tried both this and the disable N wifi solution above but none works. But then I uninstall the driver and rescan hardware, now the wifi is running perfectly without uncheck power-off option and without rolling back to slow b/g wifi

WBudd
Beginner
2,156 Views

@Bryan your suggestion worked for me. Thank you so much. After 3 days of trying all the other suggestions, and any that I could come up with I was ready to toss my 2007 laptop. Just disabling 801.11n worked and has worked for 2 days now. Perhaps it's a combo of unchecking Allow the computer to turn off this device to save power and your suggestion, but it's working now

Reply