Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Beginner
1,069 Views

Intel Wireless AC 7260 cannot enter 802.11ac mode

Hey guys,

I'm trying to use Intel Wireless AC 7260 card to do some experiments in 802.11ac standard, but with the latest firmware(version 22.24.8.0), the card is now showing as 802.11abgn mode instead of AC.

I have this 7260 card and an ASUS USB-AC56 card in my laptop, and after I type iwconfig, it looks like below:

wlan1 IEEE 802.11abgn ESSID:"Linksys_CSI_5GHz"

Mode:Managed Frequency:5.805 GHz Access Point: 94:10:3E:05:F0:08

Bit Rate=216 Mb/s Tx-Power=16 dBm

Retry long limit:7 RTS thr:off Fragment thr:off

Encryption key:off

Power Management:on

Link Quality=67/70 Signal level=-43 dBm

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:47 Missed beacon:0

wlan2 IEEE 802.11AC ESSID:"Linksys_CSI_5GHz" Nickname:""

Mode:Managed Frequency:5.805 GHz Access Point: 94:10:3E:05:F0:08

Bit Rate:174 Mb/s Sensitivity:0/0

Retry:off RTS thr:off Fragment thr:off

Encryption key:off

Power Management:off

Link Quality=100/100 Signal level=76/100 Noise level=0/100

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:0

As you can see, the ASUS card is working as 802.11AC, while the intel 7260 is working as 802.11abgn.

Does anyone know how to resolve this problem and put Intel 7260 to 802.11AC mode?

Thank you very much for your time!

0 Kudos
6 Replies
Employee
89 Views

Check the advanced Wi-Fi adapter settings in PROSet.

http://www.intel.com/support/wireless/wlan/sb/CS-025393.htm?wapkw=wifi+settings http://www.intel.com/support/wireless/wlan/sb/CS-025393.htm?wapkw=wifi+settings

Look for "HT Mode/VHT Mode"

This settings lets you select HT Mode (High Throughput mode), VHT Mode (Very High Throughput Mode) or lets you disable both modes.

HT Mode supports 802.11n compatibility

VHT Mode supports 802.11ac compatibility.

Check to see if you have this setting in VHT Mode

Valued Contributor II
89 Views

Maybe the drivers are broken in Linux. Try loading Windows and see if you can connect to 802.11ac. If it does, it rules out the hardware issue.

0 Kudos
Beginner
89 Views

Thanks for your reply.

I need to get it working in Linux, and I think the link you provided is for Windows Settings only. Do you know how to set this in Linux?

0 Kudos
Beginner
89 Views

Thanks for your reply.

I'll try it in Windows when possible. As for the linux part, could you please tell me where I can get the latest drivers? I think I have the latest official driver, and it's actually working, it just keeps using 802.11abgn instead of .11ac.

I'm a newbie in Linux, sorry about some many questions.

0 Kudos
Valued Contributor II
89 Views

Here's the only one I can find: https://downloadcenter.intel.com/SearchResult.aspx?lang=eng&FamilyId=1783&LineId=1784&ProductID=3714... https://downloadcenter.intel.com/SearchResult.aspx?lang=eng&FamilyId=1783&LineId=1784&ProductID=3714...

Just select Linux on dropdown list.

I've never used Linux so I can't help you configure the firmware settings.

0 Kudos
Employee
89 Views

Intel Customer Support does not directly support Linux drivers for our wireless products. Here is a link that hopefully helps you find the Linux drivers and support you're looking for: http://www.intel.com/support/wireless/wlan/sb/CS-034398.htm http://www.intel.com/support/wireless/wlan/sb/CS-034398.htm

Driver support can be found on the http://wireless.kernel.org/en/users/Drivers/iwlwifi Linux community page

Other support options:

http://supportmail.intel.com/scripts-emf/welcome.aspx?id=1783,1784 E-mail Technical Support

http://communities.intel.com/community/tech/wireless Wireless Networking Community

 

0 Kudos