Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7496 Discussions

Intel Wireless-AC 9560 Code 10 - Have tried everything!


Hey team, I am out of ideas.

Im currently trying to fix my friends MSI PS63 Modern 8RD laptop. 

The wireless card (Intel Wireless-AC 9560) has stopped working along with the bluetooth. A pretty common issue I've discovered. Despite hours and hours over multiple days on this issue, I've had no luck. 

Heres what I've tried (not in order): 

- Driver update
- Clean driver install
- Tried the latest intel drivers
- Tried the recommended MSI Drivers
- Tried Windows 11
- Tried Windows 10
- Factory Reset Windows 10
- Clean install of Windows 10
- Cold shutdown (Battery reseat, even reseat the wireless card while I was at it)
- Bios Update
- Disabling and reenabling device
- Uninstalling Device & restart
- Safe mode with networking
- Network Reset

Honestly thats probably not even everything I've tried, but alas nothing has worked. The only piece of new information I've being able to ascertain is there appears to be something wrong with the device installing the drivers. 

When I perform a clean install of the drivers, (Uninstalling both Wireless and BT until they both show up in "Other/Unknown Devices") Upon installing the new drivers, the bluetooth will find its new driver just fine, however the wireless card will not and needs to have its driver manually installed. When I check the event log in device manager, it states further install is required. 

I am super stuck and feel like im running out of options short of replacing the wifi card itself. Any help would be appreciated. 


Labels (1)
0 Kudos
3 Replies
Super User

Did you completely disable Internet access (disconnect Ethernet cable, disable Wireless connection) while you clean out the already-installed drivers and then install the latest? If Windows Update is allowed to run, it will screw up the clean install process, guaranteed.


0 Kudos

Hey Scott, Thanks for your reply,

I believe I had tried that, but for the sake of it I just tried again making sure Ethernet is disconnected, still no luck sadly. 

After reinstalling the driver, the Network Adapter continues to sit in "Other Devices" stating there are no compatible drivers for this device, despite these being downloaded directly from the MSI Product Page. The only way I can get the device to even register what it is is by manually selecting the driver in the "Update Driver" panel.

The BT Device finds its new driver just fine.


0 Kudos
Super User

Hhmmm, I have no idea why it would be doing that. I have done *many* installs of these drivers and have never seen this kind of problem occur - though I do remember one other user reporting this. I just looked it up: He solved it by using Intel's drivers instead. Since you tried that, it may be that your adapter has a physical problem. Presuming the 9560 came with the motherboard, I would be contacting MSI regarding replacement.



0 Kudos