Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7503 Discussions

Intel centrino-wireless-N 2200 adapter issues


Toshiba-Satellite P875-S7310w Intel centrino wireless-N 2200 adapter can't be fixed by the MS help. I have searched and tried all past fixes, short of complete replacement of the adapter, but to no avail. Result: had to do a "RESTORE." Any advice, data will not upload or download and wiFi continually drops off. Thanks for any/all assistance.

0 Kudos
3 Replies
Honored Contributor II

Hello Fdragonlady,

We would need more information to provide accurate recommendations, however, here are some initial actions you can try:

- Please run the http://www.intel.com/p/en_US/support/detect?iid=dc_iduu Intel® Driver Update Utility to make sure you are using the recommended driver for your wireless adapter.

- Also, make sure you are using the configuration from the advisory: http://www.intel.com/support/wireless/sb/CS-030709.htm?wapkw=wifi+recommended+settings Wireless Networking — What are the Recommended Settings for 802.11n Connectivity?

For any further assistance, please let us know the following:

- Operating System (including 32 or 64 bits)

- Driver version shown in Device Manager

- Warnings or messages received in the system

- Are you able to see the SSID's and connect to wireless networks?

0 Kudos

Good Day Jonathan,

Thank you for your prompt response to my concerns/issues with my N-2200 wireless adapter. I have tried all of the fixes from all past conversations with community followers; including, but not limited to having to do a complete system restore (point), all to no avail. I have even gone to your download site and tried to download the Proset for Windows 8.1/64-bits driver for the wireless adapter, but nothing happened. It did not down load and all are still sitting on my desktop, awaiting further instructions. Here are the answers to the questions you pose and let me say that I tried to run your Intel Driver update utility. It scanned my hard drive, recommended a fix to install, "PROset/Windows Software & Drivers ( Windows 8/8.1, 32-bit)." Once I looked further, as I was concerned about a 32 bit driver update trying to load on my 64-bit system, your driver information stated that this was the fix for the legacy adapter for 64-bit system. I felt a more at ease after reading this; however, again to no avail, your drivers were not able to be installed onto my system. The message stated that it was blocked from being installed. Oh, by the way all other laptops and wireless devices are connecting to the modem just fine (SURFboard Modem & Wi-Fi Router AC1800M; Model SBG6782-AC.

1. Yes, my adapter is set to configuration settings for 802.11n auto mode. I have even tried it in a channel mode.

2. Operating system 64-bits

3. Driver version:

4. Warnings and/or messages received from the system:

a. "problems found: with wireless adapter or access point - not fixed.

b. Wi-Fi doesn't have a valid IP config

c. "Limited access" wirelessly

d. "unidentified network, not internet access"

e. "cannot connect to this network"

5. Seeing SSID's and connect to wireless networks: yes, but it has no/limited data packets being transmitted and then it is continuously dropping and/or just saying that it can't connect to the internet adapter, can't connect to the internet, etc....and sometimes no, it will not show the SSID's.


I am having the same (Intel Centrino Wireless N 2200 issue on a Toshiba Satelline p845 4200)

I am running:

Windows 10 64bit

Driver Version:

Issue: cannot connect to any ssids (wifi)

Error message: "No, Internet" (SSID is shown and I can put in the password for the SSID but cannot connect).

0 Kudos