Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7662 Discussions

Intel driver corrupt and not working on Lenovo


Dear all,


Maybe you can help me out here. I have a fairly new Lenovo E15 laptop with Intel Wi-Fi 6 AX201 160 MHz in it. I use it for business so no loads of apps or games installed. It is connected to an older Linksys WRT54G on wireless-G standard 54 mbit. Until the last driver update it worked fine. However Windows automatically shoves driver update through my throat and this driver is not working at all. Connection drops every 5 minutes, it is slow as hell and after 15 minutes no connection to be made at all anymore.


I tried every trick in the book there is. Resetting router, resetting wireless adapter, resetting Windows stack through command prompt, changing channels etc. etc. Nothing works. The only thing that works is rolling back to previous driver version Than instantly all works like a charm again.


The problem is that Windows update keeps installing this crappy driver and I constantly have to roll back. Good to know that Lenovo does present driver version as the latest on her support website for my machine. However the Lenovo Vantage update software doesn't show and install it automatically. It states that my system is up to date with previous driver version I did download the latest driver manually from the Lenovo support website and installed it to see if it makes any difference to the driver Windows update pushes, but no luck, same issues.


So it is obvious that all hardware is working fine, and to be honest, all software also, except the latest Intel driver. And it's kind of fishy that Lenovo doesn't offer the update automatically through its Vantage update software.  Windows is up to date, version 20H2 build 19042.1052.


What to do here?


Thanks for your help and greetz!



Labels (1)
0 Kudos
7 Replies
Super User

The latest Wireless driver package from Intel for the AX201 is version 22.50.1. The latest Bluetooth driver package from Intel for the AX201 is version 22.50.0. Unless Lenovo is modifying the driver package and/or having the driver download custom firmware to the card, you can use the latest driver package available from Intel. You will need to ask them yourself to find out if they have modified the package. Presuming that they have not, I suggest you do a clean install with these latest driver packages. Here is the process:

  1. If you haven't already, download - but do not install just yet - the latest Bluetooth and WiFi drivers for your adapter. Here are links to these drivers: https://downloadcenter.intel.com/download/30434 and https://downloadcenter.intel.com/download/30515.
  2. Disable Internet access. Unplug Ethernet cable and/or disable wireless. Keep disabled until told to re-enable.
  3. From Apps & Features, check for instances of Intel PROSet/Wireless Software and Intel Wireless Bluetooth. If none, skip to step 6.
  4. Uninstall each instance of Intel PROSet/Wireless Software and Intel Wireless Bluetooth that is present. When prompted, choose to "Discard Settings".
  5. Manually reboot your computer, keeping Internet access disabled.
  6. In Device Manager, check Network Adapters for an entry for Intel Wi-Fi 6 AX201. If none, go to Step 9.
  7. Right click on the entry for Intel Wi-Fi 6 AX201 and uninstall it, choosing to (checkmark) Delete the driver software for this device.
  8. Go to Step 5.
  9. (Optional but recommended) Clean out all temporary files using the Windows Clean Disk tool. I recommend that you checkmark all categories offered, even if no files currently (so it leaves it set up for next invocation).
  10. (Optional but recommended) Clear each of your browsers' cache.
  11. Install the Bluetooth driver package (rule: always do Bluetooth first).
  12. Install the Wireless driver package.
  13. Manually shutdown and reboot your computer.
  14. Enable Internet access.
  15. Test.

Hope this helps,



Thank you for your reply n_scott_pearson!


I will ask Lenovo on their community weather these driver packages are modified or not before releasing.


Hope to get an answer so I know what to do.


Regards, Master_Burn

0 Kudos

Well thank you Lenovo for no help at all. Didn't receive any reaction on the matter by Lenovo on their community.


Nothing works. New driver 22.50.1 installed with the same result. Reset machine totally with the same result.


WiFi seems to be working fine on N-standard. It just won't communicate properly anymore on G-standard. Connection drops constantly and is very slow for as long the connection is established.


I'm sorry but this is just lame....

0 Kudos

Ok, Lenovo replied. The only thing they can offer is a roll back to the previous driver version that works and block the update. So no real solution there either.


Lenovo now offers driver update through Vantage software, no result.

I installed latest Intel driver 22.50.1 to see if it makes any difference, no result.

I reset my machine to factory settings, no result.

Only a roll back to version does fix this issue.


So I guess it's pretty safe to say that the driver is corrupt as of version for G-standard connections.


I had many driver issues with Lenovo laptops, my previous ones also. Most of the time the drivers were corrupt and corrected by Lenovo (much) later. Lenovo and/or Intel should test better in my opinion before releasing. I can say that my other laptops by other manufacturers don't have these issues as much.


Right, because of my experiences and the simple fact that I do have to work with it, I will replace the hardware router to N-standard. I do not have the time for Lenovo and/or Intel to come up with a solution in the next months or so. However it still is lame...


Regards, Master

0 Kudos

Hello @Master_Burn


Thank you for posting on the Intel️® communities. 


After checking the information provided, it is a good idea to upgrade the router as mentioned above. Based on the problem description and after the troubleshooting performed, the router used might not be fully compatible with the AX technology and this can cause different behaviors on the network performance. To resolve this, you can try the following:



David G 

Intel Customer Support Technician 

0 Kudos

We have not heard back from you, so we will close this thread. Please remember to check with the OEM for more information. 

Best regards,  

David G. 

Intel Customer Support Technician  

0 Kudos

I'm experiencing this EXACT, PRECISE same issue. I have a Lenovo ThinkPad Carbon X1 Gen 7 (which I only use for business, so has very few things installed) with an Intel Wireless-AC 9560 160 MHz card, and I had to have a motherboard swap done yesterday. Afterwards, my wifi was completely bricked -- major trouble connecting to networks, drops every 5 minutes if you can get it connected, and eventually after around 15 minutes it just stops working entirely. This was the case not only on my office's wifi network (which is comprised of a relatively new fios router that is fully up-to-date), but also on my home wifi network. Just like the original poster, I tried every trick in the book -- resetting router(s), resetting wireless adapter, resetting Windows stack through command prompt, changing channels, clean install of new Intel driver, etc. etc. I even did a full wipe of my computer and clean install of Windows, but nothing worked. The only thing that works is rolling back to previous driver version, then, instantly, all works like a charm again -- it connects just fine, doesn't drop, etc. What's also weird is that prior to the motherboard replacement yesterday, I was on the newer driver and all was copacetic. Has there been any progress identifying what's causing this issue??

0 Kudos