Community
cancel
Showing results for 
Search instead for 
Did you mean: 
ACast36
Beginner
1,198 Views

Intel wireless AC 9560 not working on Ubuntu 16.04 LTS Preempt RT kernel

I am using Ubuntu 16.04 LTS and am using a ASUS ROG Z390 I motherboard which has an Intel wireless AC 9560 WIFI. With a generic kernel (4.15.0-58-generic), the wifi works. I have patched PREEMPT RT kernels (I have tried with 4.16.7rt1 and 4.13.13rt5 kernels) and found that the wireless option on Ubuntu does not even appear. 

 

 

 

When I run dmesg | grep iwl I get:

 

[  5.001828] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)

[  5.035994] iwlwifi 0000:00:14.3: loaded firmware version 33.610294.0 op_mode iwlmvm

[  5.090448] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318

[  5.097363] kernel BUG at drivers/net/wireless/intel/iwlwifi/pcie/rx.c:425!

[  5.097366] Modules linked in: iwlmvm(+) mac80211 iwlwifi cfg80211 ucsi_acpi typec_ucsi typec acpi_als kfifo_buf mac_hid acpi_pad industrialio parport_pc ppdev lp parport autofs4 hid_generic usbhid uas usb_storage e1000e ptp ahci pps_core libahci wmi i2c_hid hid video

[  5.097376] RIP: 0010:iwl_pcie_rxq_alloc_rbs+0x199/0x1f0 [iwlwifi]

[  5.097385] _iwl_pcie_rx_init+0x23a/0x710 [iwlwifi]

[  5.097388] iwl_pcie_rx_init+0x2d/0x3a0 [iwlwifi]

[  5.097392] ? iwl_mvm_nic_config+0xe2/0x150 [iwlmvm]

[  5.097395] iwl_trans_pcie_start_fw+0x290/0x6b0 [iwlwifi]

[  5.097399] iwl_mvm_load_ucode_wait_alive+0xe5/0x300 [iwlmvm]

[  5.097403] iwl_run_init_mvm_ucode+0x91/0x330 [iwlmvm]

[  5.097406] ? iwl_run_init_mvm_ucode+0x91/0x330 [iwlmvm]

[  5.097409] ? iwl_wait_init_complete+0x20/0x20 [iwlmvm]

[  5.097412] iwl_op_mode_mvm_start+0x8f4/0xc10 [iwlmvm]

[  5.097416] ? iwl_op_mode_mvm_start+0x8f4/0xc10 [iwlmvm]

[  5.097420] _iwl_op_mode_start.isra.11+0x47/0xa0 [iwlwifi]

[  5.097425] iwl_opmode_register+0x6c/0xd0 [iwlwifi]

[  5.097428] iwl_mvm_init+0x35/0x1000 [iwlmvm]

[  5.097456] RIP: iwl_pcie_rxq_alloc_rbs+0x199/0x1f0 [iwlwifi] RSP: ffffbcfa870b78d0

 

 

Is it that the Intel 9560 does not work with PREEMPT RT kernels ? What could be done to make it work with PREEMPT RT kernels ?

 

 

0 Kudos
1 Reply
Wanner_G_Intel
Moderator
493 Views

Hello ACast36,

 

Thank you for posting on this Intel Community.

 

We support the use of the drivers only in the kernel version the driver was a part of.

 

1. For general questions about Intel Wi-Fi on Linux, email linuxwifi@intel.com.

2. To report a bug or issue, follow the guidance on the bugs and support page.

 

For more information, please refer to these support links:

 

Linux* Support for Intel® Wireless Adapters

Linux* Drivers and Linux Community Page

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

Reply