Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AZuba1
Beginner
1,802 Views

Low download speed with AC 8260

Hello,

I have issue with Intel(R) Dual Band Wireless-AC 8260 on my notebook Lenovo Thinkpad x260

OS Windows 10 x64 pro

Download speed dramatically low on all wireless mode (a, b, g) 2,4 or 5 - nevermind. It is less than 1Mbps

Upload is goog - about 100 Mbps on the a and g mode.

I have another Lenovo laptop (x240). It's working fine without any issues with speed.

0 Kudos
5 Replies
idata
Community Manager
178 Views

Hello Filalex,

 

 

We understand that your computer is showing a slow wireless connection. This type of behavior can be caused by different factors, here are some initial recommendations for this:

 

 

- Install the latest driver provided by the https://www.intel.com/content/www/us/en/support/topics/OEMs.html Computer Manufacturer Support. Or you can also try the generic version of https://downloadcenter.intel.com/download/26782/Wireless-Intel-PROSet-Wireless-Software-and-Drivers-... Intel® PROSet/Wireless Software and Drivers for Windows® 10* [19.60.0].

 

- Apply the configuration mentioned in the following document: https://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005544.html Recommended Settings for 802.11n Connectivity.

 

 

If the issue persists, please provide the following information:

 

 

- https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility Download Intel® System Support Utility, run the tool and use it to create a report with all sections, once the report is created, click on the "Next" button. In the following screen, save the report to a file. Then use the Advanced editor options of the communities to add the resulting file to your post as an attachment.

 

- Access point model and firmware version.

 

- What is the download/upload speed you expect to see? and which method are you using to test the speed?

 

- Has the connection worked fine before?

 

 

Regards,

 

Jonathan B.
AZuba1
Beginner
178 Views

Hello Jonathan B.

1) Install the latest driver - done, version 19.60.0.7

2) apply https://www.intel.com/content/www/us/en/support/network-and-i-o/wireless-networking/000005544.html Recommended Settings for 802.11n Connectivity. - done

3) run the https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility Intel® System Support Utility - done, the report in the attachement

4) access point - Cisco AIR-AP1852 (OS version 10.3.141.0)

5) upload speed - 110 Mbit/s, download speed 200 kbit/s - same results on different modes (2,4GHz b,g,n and 5GHz n,ac)

6) on the old laptop (Lenovo x240) with wifi N7296 no issue - the speed about 100Mbit/s on both direction.

Thanks you.

idata
Community Manager
178 Views

Hello Filalex,

 

 

We checked the log and the information looks normal for your configuration, the adapter is using 802.11ac with 144.4 Mbps connection rate:

 

 

Radio Type: 802.11ac

 

Receive Rate: 144.4 Mbps

 

Transmit Rate: 144.4 Mbps

 

Signal Strength: 99%

 

 

We would like to mention that the difference you get between download and upload is very significant, so there may be an issue in the network. Here are some additional actions for you to consider:

 

 

- Engage the network administrator and look for any bandwidth allocation feature that may be limiting the connection.

 

- Contact Cisco Support and check with them about this as well.

 

 

From the adapter side, here are couple actions that may improve connectivity, even though they may not account for the difference of 110 Mbps Upload vs 200 kbps Download:

 

 

- Disable the Bluetooth* component of your wireless adapter, this is normally done with a hardware switch in the PC, or with a key combination, it can also be done within Windows* settings.

 

- In the advanced driver properties, try enabling U-APSD support. As it may work better with newer Access points. You can disable it again if there is no improvement.

 

U-APSD support: Enabled

 

 

Regards,

 

Jonathan B.
AZuba1
Beginner
178 Views

Hello all.

The issue was resolved.

Default Maximum Segment Size (MSS size) on enterprise WLC (like Cisco and others) is 1363. But this settings is incompatible with AC 8260. Changing MSS on a WLC to 1360 resolves the issue.

Please, add this information to KB.

idata
Community Manager
178 Views

Hello Filalex,

 

 

We are glad to know the issue was solved. We are sure this information will be very useful for any other users facing this situation.

 

 

Regards,

 

Jonathan B.
Reply