Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7646 Discussions

Mouse lag - Skull Canyon - Windows 10 - mouse pointer lags movement of mouse

idata
Employee
5,551 Views

I have a new NUC6i7KYK Skull canyon box, latest BIOS & driver update. Windows 10, also updated. The mouse I have used for years, a Logitech M510 wireless feels like the pointer is being dragged through thick molasses. Move the mouse, the pointer follows but after an agonizingly short delay. Ditto for my backup mouse, a Logitech M305 wireless, and also to a lesser degree but still maddeningly laggy, a Microsoft bluetooth notebook mouse 5000. Mouse lag occurs whether I have the USB wireless transciever plugged directly into the NUC or on a 30cm extension cable.

The microsoft bluetooth mouse is usable, but barely so. I dread having to move the mouse. USB wired keyboard seems unaffected, maybe a tad slow on character input but it doesn't drop characters. Other USB devices working fine.

These mice were working fine on a Windows 10 system based off a Core i7 3770 for years.

Should note that I have also updated my monitor to a Hisense 55" UHD TV running 2160p @ 60Hz. My previous system was also 2160p but consisted of 4 debezzeled samsung 27" monitors on an Nvidia 680 graphics card.

I'm about to run out and get a wired mouse out of desperation. Any ideas what could be the problem?

0 Kudos
15 Replies
WRohd
Novice
3,380 Views

I have the same problem.

Running Linux Ubuntu 16.04

The USB sniffer tells me that Linux does not receive data from the Logitech USB transceiver while the mouse stalls.

Moving the mouse very near to the transceiver mostly fixes the problem. I now have short USB cable running to nearby the mouse.

The same Logitech USB transceiver and the same mouse do not have that problem at all when used on other computers.

I can only think of one possible reason: either the NUC6i7KYK or my new monitor AOC U3277PQU are emitting unwanted noise in the frequency range used by Logitech.

After reading your post I decided to to some searching.

This link points to WiFi as a possible problem, so next I will experiment with different channels for my network: https://askubuntu.com/questions/463858/change-logitech-unifying-reciever-frequency-band# 464882 https://askubuntu.com/questions/463858/change-logitech-unifying-reciever-frequency-band# 464882

Will let you know about my findings.

idata
Employee
3,382 Views

Hi all,

 

 

Thanks Wolfagang61; this seems like a compatibility issue, I test it here with all Windows® 10 updates and latest drivers, using a Logitech* M185, and it works as it should.

 

From this I recommend you to install the latest driver for your mouse.

 

http://support.logitech.com/en_us/category/mice-and-pointers http://support.logitech.com/en_us/category/mice-and-pointers

 

 

Regards,

 

Hellen.

 

0 Kudos
WRohd
Novice
3,382 Views

Hi Hellen,

As I wrote, I am using Linux. Actually since many years, on all my systems. Never had any problems with Logitech Unifiying mouses. In the beginning I needed WIndows for configuring them but meanwhile this is also possible with Linux.

Logitech does not have a Linux driver for this mouse, never had one and most certainly never will There are no drivers needed for Linux.

You did not mention that you tested the mouse in parallel with Wifi traffic in the 2.4GHz range - so I assume you did not. The mouse also uses that frequency range. Did you read the link I posted?

0 Kudos
idata
Employee
3,382 Views

I suspect it's USB 3.0 radiofrequency interference (RFI). My previous system had USB 2.0 ports, and my wireless mouse was attached to one of those. NUC of course has only USB 3.0 ports. So even placing the mouse dongle on an extension to bring it within inches of the mouse (while it did have some effect at reducing lag) did not fix the problem. I hate to go back to a wired mouse but it seems that's a strategy to avoid the RFI.

http://www.intel.com/content/www/us/en/io/universal-serial-bus/usb3-frequency-interference-paper.html USB 3.0* Radio Frequency Interference on 2.4 GHz Devices

0 Kudos
idata
Employee
3,382 Views

Just to add more info.

I've used both the Logitech Performance MX and MX Master mice with the Skull Canyon, under Windows 10 Pro.

Performance MX with Unifying Receiver plugged directly into one of the rear USB 3.0 ports. This use was because the Skull and mouse were within about a foot of each other.

MX Master with Unifying Receiver plugged into a Logitech Extension cable which is plugged into one of the rear USB 3.0 ports. This use is because the Skull is now about 5 feet away from my mouse.

The Unifying Receiver is now about 2 feet from the mouse sitting on the baseplate of a monitor.

No lag in either configuration.

Not sure if I need the extension... never used the MX Master without it. The extension was a left over from my previous pc which sat on the floor beside my desk - somewhat out of site and where I did experience lag.

The Skull is now on top of my desk.

0 Kudos
idata
Employee
3,382 Views

Hi,

 

 

Let me investigate about this, in order to replicate this,

 

Could you please attach the result of the Intel® System Support Utility and the Intel® Graphics Report?

 

Intel® System Support Utility:

 

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility

 

 

Intel® Graphics Report:

 

http://www.intel.com/content/www/us/en/support/graphics-drivers/000005848.html http://www.intel.com/content/www/us/en/support/graphics-drivers/000005848.html

 

 

Could you please also attach your TV's model?

 

 

Regards,

 

Hellen.
0 Kudos
idata
Employee
3,382 Views

Howdy, the TV Model is the Hisense 55H7B2. Can't see how to attach so I'll just copy/paste the results of the requested reports:

<?xml version="1.0"?>

1.2.0.58

07/18/2016

00:00:13.3037721

http://www.intel.com/content/www/us/en/search.html?keyword=Iris+Pro+Graphics+580" />

<Setting id="Video...

0 Kudos
Chris_V_Intel
Moderator
3,382 Views

Hey guys, I think that unfortunately you're seeing the USB 3.0 2.4 GHz WIFI issue rear it's ugly head.

https://www-ssl.intel.com/content/www/us/en/io/universal-serial-bus/usb3-frequency-interference-paper.html USB 3.0* Radio Frequency Interference on 2.4 GHz Devices

http://www.pcmag.com/article2/0,2817,2423604,00.asp Wireless Witch: The Truth About USB 3.0 and Wi-Fi Interference | Samara Lynn | PCMag.com

https://www.asus.com/support/faq/1004004 Using USB3.0 and 2.4Ghz USB wireless device on a notebook at the same time may experience radio frequency interference.

The thing that is frustrating is, as you've said, it'll work fine on one device and not so good on another, not only that, but one USB device will work fine, and another won't.

0 Kudos
idata
Employee
3,382 Views

Hi,

 

 

Guys I'm investigating about this, I will test with the new Driver version, and then I'll let you know once I get a result.

 

 

Regards,

 

Hellen.

 

0 Kudos
idata
Employee
3,380 Views
0 Kudos
idata
Employee
3,380 Views

Hi Helen, I am downloading the graphics driver now. I do believe this is a graphics issue (maybe also RFI). I switched my wireless mouse for a wired one, and the wired one was working fine until yesterday when I changed screen resolution, then changed it back. Now the wired mouse has the same lag problem. So probably not completely RFI. Will report back after installing the driver linked above.

-Mark

Edit to add: Graphics driver updated - USB wired mouse still lags.

0 Kudos
idata
Employee
3,380 Views

Hi Loweacer,

 

 

This issue is still under investigation, as soon I get an answer I'll let you know.

 

 

Regards,

 

Hellen.

 

0 Kudos
Ronny_G_Intel
Moderator
3,380 Views

Hi Mark,

I have expericed the issue that you described when using a very large screen and havent really been able to find a workaround for that, it seems that you were also having a combination of USB 3.0 2.4 GHz WIFI issue.

Are you still dealing with this issue? Are you running latest BIOS (rev41) https://downloadcenter.intel.com/download/26210/BIOS-Update-KYSKLi70-86A-?product=89187 Download BIOS Update [KYSKLi70.86A] ?

Thanks,

Ronny G

0 Kudos
idata
Employee
3,380 Views

I have a workaround that works:

1) Wired USB Mouse (Logitech G300s)

2) Set 55" LCD TV to GAME mode.

Mouse lag is negligible now. I am running BIOS rev41

.

It's not ideal because I'd rather use a wireless mouse, and Game mode on the TV results in such a bright picture that I'm wearing a welder's helmet to prevent eye damage. But it does work now.

-Mark

0 Kudos
Ronny_G_Intel
Moderator
3,380 Views

Hi lowracer,

I am glad that you were able to find a fix for this issue (I understand it is not perfect) and thanks a lot for sharing the results.

I can understand the mouse issue due to interference but i never heard anything about the "game mode", I will keep an eye on that, thanks for the information.

Regards,

Ronny G

0 Kudos
Reply