Wireless
Issues related to Intel® Wireless Adapters and technologies
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
6024 Discussions

Mouse lags with the latest 11th generation INTEL laptop platforms

F_ORE
Novice
496 Views

Many users are reporting frequent mouse lags with various models of Bluetooth mouse on the latest INTEL laptop platforms. Different OEMs are involved such as ASUS, DELL, Lenovo, HP, MSI etc. along with all mouse producers including Logitech and Microsoft. It appears to be a software problem not a hardware defect. In fact it arises from the sudden suspension of the Bluetooth radio when the user stops using his mouse even for a few seconds. This behavior makes a Bluetooth mouse virtually unusable.

I also noticed that listening to music using Bluetooth earbuds prevents mouse lags, further confirming what I said before about this issue.

No solution is available so far, only two not perfect workarounds.

The first and more reliable (in fact I recommend it) is to uncheck the box "Allow this PC to deactivate this device to save power" in the power management tab of the "Intel® USB serial bus 3.XX eXtensible host controller" device (you should have two occurrences of it so the first one should be enough) in device manager under the USB serial Bus controllers category. You might have to apply this fix again after a Windows update.

This workaround doesn't fix completely the problem because a few mouse lags still occur sporadically but overall it renders the mouse usable again and more importantly it doesn't have side effects of any sorts.

The second workaround is a registry hack so you have to use Regedit (of course with administrative privileges so launch it with "Run as administrator") to reach the following key:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\VID_8087&PID_0026\5&ed1e05a&0&10\Device Parameters]

there you have to set to 0 the DWORD value of "DeviceSelectiveSuspended" and you need to add two more DWORD values all set to 0 which are "SelectiveSuspendEnabled" and "SelectiveSuspendSupported". Then you must restart Windows.

The last workaround, although it fixes completely the mouse lags, it results in severe issues when the laptop tries to go in standby or wakes up, especially if you are running in battery mode. The Bluetooth radio might stop responding (so you have to turn it off and back on) or worse it could lead to blue screens of death (BSODs) the latter at least according to some users, I personally can't confirm the BSODs.

I am experiencing this issue too with my ASUS ZenBook S UX393EA

Windows 10 Pro 21H1 (19043.1110)
INTEL Wireless Bluetooth 22.30.0.4

UEFI firmware 10.1.2.303

 

Any news from INTEL?

0 Kudos
1 Solution
F_ORE
Novice
279 Views

installing BT and WiFi 22.80.1 drivers finally fixed this issue for me on Windows 10

View solution in original post

3 Replies
F_ORE
Novice
460 Views

I updated BT and WiFi drivers to 22.60.0.6 I still need to use the option "Allow this PC to deactivate this device to save power" but the lags decreased further

F_ORE
Novice
387 Views

new BT driver 22.70.2 appears to mention this very issue in the release notes "On some systemsBluetooth mouse movement may not be smooth..." so I gave a try... in fact the lags decreased even without the option "Allow this PC to deactivate this device to save power" but still occur sporadically sometimes in a rapid and repetitive fashion

in the other hand there are increasing reports that in Windows 11 (beta of course) there are no mouse lags at all

F_ORE
Novice
280 Views

installing BT and WiFi 22.80.1 drivers finally fixed this issue for me on Windows 10

Reply