Showing results for 
Search instead for 
Did you mean: 
Community Manager

Problems upgrading driver Intel® PROSet/Wireless WiFi Connection Utility

Although I know that there have been other topics about issues with this program, mine seems to be slightly different.

Alienware M11X r-3

Windows 7 64 bit

Intel® WiFi Link 1000

Running Intel® PROSet/Wireless WiFi Connection Utility

When attempting to upgrade to version 15.1.1 I was given an error message stating "The feature you are trying to use is on a network resource that is unavailable. Click OK to try again, or enter an alternate path to a folder containing the installation package "Intel PROSet Wireless.msi" in the box below."

This is followed by a pathing box to allow you to tell the program the current location of the installer file, which by default points to "C:\Windows\Installer\_{290D4DB2-F1B4-4B8E-918D-D71EF29A001B}\", a folder which does not exsist on my hard drive.

So, in essence, I cannot upgrade my drivers and program because somehow the installer MSI for the previous version has gone MIA from my computer. Is there any work around, or alternatively is there any way I could be provided with the installer MSI for the older version so that I can simply point the newer installer to it?

0 Kudos
2 Replies
Community Manager

Thank you for your post, the error message you describe may refer to corruption. A couple of things you can do;

First create a system restore point so you can always return to this status (

There are a couple of scenarios where this issue can show up:

  • The most common cause is that the installation file was corrupted during the download.

Try to download it again, see the link below to the latest driver version:

You may try using a different browser and try first saving the file then executing it.

  • The installer tries to extract the files on your machine but the default TEMP directory is not writeable for the Windows user that is currently running .exe (try running it as administrator) or there is not enough space available for the Windows user that is currently running setup.exe. Clean out the TEMP files this to free some space and to avoid any corrupt files or previous downloads.
  • In rare cases the problem may be caused by antivirus/antispyware software blocking the installer.

Also if you are trying to run the installer remotely it may cause some trouble too. Try running it locally

Community Manager

thank you for the reply, nathalie, but I think you are misinterpreting the problem. I DID try downloading the drivers multiple times, but it didn't work, nor did I think it would, considering that I also tried uninstalling the old drivers first, and was given the same error message when attempting to uninstall the older drivers. You see, the download for the update is perfectly fine, but it's written in such a way that it seems to first want to access the uninstallation driver from the original install, and THAT is what is missing from my computer. I know this because when I go into install/uninstall programs I get the same error message when attempting to simply remove the program from my computer.

So that's the issue. I can't get the older version of the program off of my computer in order to put a newer version onto it, because the _older_ version is corrupted in some way, and it's installer is missing, and the newer version is trying to find it's installer in order to uninstall it before continuing further.

So with that in mind, what can I do to fix it?


I forgot to say that yes, I have also attempted running the new and old files as admin manually, and I regularly clean out my temp directories as well as scan for viruses. My system *did* at one point have a virus on it that took some work to remove, so I suppose that it is possible that the older version of the install was corrupted while the virus was on my system, and when the virus was removed the file stayed corrupted. Either way, I still need some type of method of uninstalling the older version of the program, either manually or through an uninstaller, so I can upgrade/repair. The current version refuses to work at all properly for broadcasting a wireless network signal, as it is supposed to be able to do, which is why I attempted to upgrade in the first place.

I am comfortable with manually deleting files and registry entrees if that's what it would take, I just need to know what to delete and remove from the registry.

Message was edited by: Eric Borden