Wireless
Issues related to Intel® Wireless Adapters and technologies
5969 Discussions

Siemens Field PG M6 Wirless Adapter Code 28 (no compatible driver) AC 9560

JimHough
Beginner
1,527 Views

Hello,

I have a Siemens Field PG M6 with Windows 10 (20H2) that has been working fine up until the 24th March.

The WIFI Adapter is not being recognized by Windows and shows in the device manager with code 28.

I have tried the Intel Driver & Support Assistant and it just keeps showing that "Windows® 10 Wi-Fi Drivers for Intel® Wireless Adapters" needs to be installed. It goes through the procedure of installing then scans and it shows again.

The hardware ID is reporting as follows:

PCI\VEN_8086&DEV_A370&SUBSYS_00008086&REV_10
PCI\VEN_8086&DEV_A370&SUBSYS_00008086
PCI\VEN_8086&DEV_A370&CC_028000
PCI\VEN_8086&DEV_A370&CC_0280

I don't know why windows is not recognizing a driver for it.

Any help would be greatly appreciated.

Thanks

0 Kudos
9 Replies
Alberto_Sykes
Employee
1,509 Views

JimHough, Thank you for posting in the Intel® Communities Support.


In order for us to provide the most accurate assistance on this matter, we just wanted to confirm a few details about your system:

What is the model of the motherboard?

If this is a laptop, what is the model of it?

Is this a new computer?

Was it working fine before with the Siemens Field PG M6?

When did the issue start?

Did you make any recent hardware/software changes?

The wireless card, did you purchased it separately or did it came installed on the computer?

Does the problem happen at home or work environment?

Please attach the SSU report so we can verify further details about the components in your platform, please check all the options in the report including the one that says "3rd party software logs":

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91...


Any questions, please let me know.


Regards,

Albert R.


Intel Customer Support Technician


JimHough
Beginner
1,500 Views

What is the model of the motherboard?

A5E44342895

If this is a laptop, what is the model of it?

This is a Siemens Simatic Field PG M6

Is this a new computer?

This computer was bought about three years ago

Was it working fine before with the Siemens Field PG M6?

It was working fine until 24th March 2021

When did the issue start?

24th March 2021

Did you make any recent hardware/software changes?

No, unless windows updates installed some

The wireless card, did you purchased it separately or did it came installed on the computer?

It was already installed

Does the problem happen at home or work environment?

Both

Alberto_Sykes
Employee
1,490 Views

JimHough, Thank you very much for providing that information and the SSU report.


According to the SSU report, we can confirm that the computer is working with NETGEAR WNDA3100v3 N600 Wireless Dual Band USB Adapter, and as you mentioned, the Intel® Wireless-AC 9560 is not even being detected so we cannot confirm which is the Wireless driver being used.


We always recommend to install the Wireless driver provided by the manufacturer of the computer, since that driver was heavily customized by them to work with your specific platform.


I looked in Siemens for the Wireless driver provided by them and I was not able to find it. So, we suggest to get in contact directly with them to confirm which is the proper driver validated and tested by them for your system:

https://support.industry.siemens.com/cs/products/6es7718-.....-0.../simatic-field-pg-m6?pid=1326557&...

https://support.industry.siemens.com/cs/start


At this point, what we can try is a clean installation of the Intel® Generic Wireless driver version 22.40.0 following the instructions in the links below, once you get the chance, please let us know the results:

https://downloadcenter.intel.com/download/30279/Windows-10-Wi-Fi-Drivers-for-Intel-Wireless-Adapters

https://www.intel.com/content/www/us/en/support/articles/000022173/wireless/intel-wireless-gigabit-p...


Regards,

Albert R.


Intel Customer Support Technician


Alberto_Sykes
Employee
1,478 Views

Hello JimHough, I just wanted to check if the information posted previously was useful for you and if you need further assistance on this matter?


Regards,

Albert R.


Intel Customer Support Technician


JimHough
Beginner
1,470 Views

I have tried the clean install of the 22.40.0 drivers but it is still showing in device manager as unknown:

JimHough_1-1617809982925.png

I have logged a support request with Siemens but they are just asking me to install the original drivers which does not appear to work either.

The Intel Driver and Support Assistant continuously reports that an update is available but when I go through the installation procedure it just re-appears.

JimHough_2-1617810220062.png

 

Best Regards,

Jim 

 

Alberto_Sykes
Employee
1,460 Views

JimHough, Thank you very much for providing those details and sharing the picture.


We will do further research on this matter, as soon as I get any updates I will post all the details on this thread.


Regards,

Albert R.


Intel Customer Support Technician


Alberto_Sykes
Employee
1,432 Views

Hello JimHough, I just received an update on this matter.


After reviewing the case and based on the troubleshooting steps provided, this seems to be a hardware issue. 

 

One of the options for you since the issue started after a Windows* update is to try to roll back to a previous restore point before the updates and to contact Microsoft for guidance. If the problem remains, chances are the hardware has a physical problem and will need to be replaced.

Also, check with OEM/PC for a physical inspection of the computer in case of a faulty hardware component:

https://www.plm.automation.siemens.com/global/en/support/


Regards,

Albert R.


Intel Customer Support Technician


Victor_G_Intel
Moderator
1,413 Views

Hello JimHough,


Were you able to check the previous post?  


Please let me know if you need further assistance.  


Best regards,


Victor G. 

Intel Technical Support Technician


Alberto_Sykes
Employee
1,395 Views

Hello JimHough, Since I have not heard back from you, we are closing the case, but if you have any additional questions, please post them on a new thread so we can further assist you with this matter.


Regards,

Albert R.


Intel Customer Support Technician


Reply