Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7434 Discussions

The recent update to the Intel Centrino 6250 driver did not work and disabled (broke?) the WiFi adapter


On June 1, 2015, I did a Windows Update (Window 7 Pro, 64bit) for my Dell Precision M4500. One of the updates was for the Intel Centrino 6250 driver. The Intel Centrino 6250 came with the computer, and has not been modified in any way.

As Windows 7 was updating, I lost wifi connectivity. Soon after, Windows 7 reported the update for the driver failed. Multiple efforts to update all ended in failure. The wifi connectivity remained broken through multiple reboots, installation efforts, etc.

Each reboot showed an effort to automatically install the "new hardware" (the wifi card) but each time ended in failure.

Tried to perform a rollback, but Windows7 told me that I had to check the disk first as it was corrupted. Disk check efforts revealed no corruption to the drive. Still can not get around the rollback road block.

I downloaded the most recent drivers from Dell, specific to my computer, and tried to install them. No joy. As an aside, I deleted the failed driver prior to trying to install the new driver.

I downloaded the most recent drivers from Intel and tried to install them (having deleted prior driver installations). No joy.

As of today, still no wifi connectivity.

Today, I am connected to the internet via ethernet cable. For grins, I checked the Device Manager and found the following message about the WiFi card:

The Device Manager states the device status as:

Reinstall the drivers for this device. (Code 18)

To reinstall the drivers for this device, click Reinstall Driver.

When reinstalling the driver, I can hand pick prior versions of the driver (Versions,,,, and Regardless of the version picked, the following message appears:

"Windows encountered a problem installing the driver software for your device"

"Windows found driver software for your device but encountered an error while attempting to install it"

"Intel(R) Centrino(R) Advanced-N 6250 AGN"

"The name is already in use as either a service name or a service display name"

Any help or suggestions would be greatly appreciated.

Thank you,


0 Kudos
4 Replies
Honored Contributor II

Hello Tenby5,

When you uninstalled the drivers for this wireless card, did you do it to the point that Windows* will no longer detect and file whatsoever for this wireless card? If not, try that and reinstall the latest drivers from your computer manufacturer support page. If necessary, contact them directly for live troubleshooting since the wireless card is the original card that came installed when you bought your PC. Alternatively, you can also use our Intel® Driver Update Utility by clicking in this link to help you identify and make sure you are using the correct drivers: http://www.intel.com/p/en_US/support/detect?iid=dc_iduu Intel® Driver Update Utility.

1 - Please, also check for BIOS updates as well as it may also help resolving the issue

2 - Check also Firewall and antivirus setting to make sure they are not keeping your system from installing.

0 Kudos


Thank you for the response and suggestions. The problem is resolved for now. Here is how it played out:


Today, I connected my computer to an ethernet cable to enable internet access.


I checked Firewall and Antivirus and found nothing which would inhibit the installation/updating of the driver.


I removed the drivers and as far as my computer thinks, there is no wifi card. The device manager showed no wifi card whatsoever.

I double-checked my efforts by using the driver utility you referenced. The utility could not find the card.

Having confirmed nothing remains, I used Dell's driver package for the card. The first two times, after the intel splash screen appeared, I received a message that "the installation was blocked."

The third time, the installation program functioned (creating a restore point and then allegedly installing the driver). At the end of the process, a splash window appeared in the center of my screen which read "success." At the same time, a pop-up window appeared in the lower right hand of my screen telling me the installation failed and the driver was not installed. Confused, yet? It gets better!

Opening my device manager, I saw under Network Adapters "Intel® Centrino® Advanced-N 6250 AGN # 9 (I've noticed each time I try the install the number following the # increases by 1). The graphic for the device manager had a yellow exclamation point sign on it.

Clicking on the graphic for the Centrino's device properties led me to the following error message:

This device is not configured correctly. (Code 1)

The name is already in use as either a service name or a service display name.

To find a driver for this device, click Update Driver.

Under the "driver tab" I saw the driver version wass

Next, I hit "update driver" and elected to install the next earlier driver version

That driver seemed to install, and the computer polled for wireless networks. When I tried to connect to a network, I got the same bottom-right corner pop-up message that the driver was not installed. However, the Intel PROSet/Wireless WiFi Connection Utility kicked in and allowed me to connect to our wifi network.

Looking at the device manager for the card now, the yellow exclamation point is gone.


To confirm connectivity, I unplugged the ethernet cable and confirmed the wifi card was receiving/sending.


I'm not sure what I did that worked this time, but the problem is, at least for now, solved. I do not intend on updating the Centrino driver unless absolutely forced to do so. Is there any security risk or other non-standard reason why I should update the driver?


Thank you,




Honored Contributor II


Intel recommends that whenever the wireless card is OEM's, all drivers update must be done through them first as they design the driver to be fully compatible to their system and wireless adapter. Our drivers found in our support page are generic and may not be compatible with the OEM system.

0 Kudos

...having the same problem with my little Dell 11" after a May 30th update....I am finally trying to resolve it today. Thanks for the info! You would think by now there would have been a conversation between Microsoft and Intel about this problem.

0 Kudos