Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DDosh2
Beginner
975 Views

Throughput problem with AC7260 adapter & driver 16.6.0.8

Hi everyone, I have a new Lenovo X240 with a Intel Dual Band AC 7260 adapter,

Originally X240 comes with driver version 16.1.5.2, I have test it in a wireless shielding room with D-link DIR-868L (which uses a broadcom chip)

And use Ixia software for throughput testing, the speed is fine with this version (link rate:866Mbps, real speed: 400~500Mbps),

However, after I upgrade the AC7260 driver to 16.6.0.8, in the same environment the realwindows_8 speed can only reach about 100Mbps (link rate still shows 866Mbps).

then I roll back the driver, speed comes to 400~500Mbps again.

I have tried using other 802.11ac adapters with the D-Link router, all speed are fine, so what's wrong with my AC7260 and driver 16.6.0.8?

Any idea how to solve this?

Thanks in advance!

PS I tested in both Windows 8 and Windows 8.1

Tags (3)
0 Kudos
3 Replies
RChor1
Beginner
119 Views

what the **** is happening??, with the latest update my WiFi disconnects every time I close the laptop lid, please fix this.

One word was edited out by a moderator.

RChor1
Beginner
119 Views

sorry for my language

tvete
Valued Contributor II
119 Views

It's the drivers. I also get much lower throughput for my 7260N with 16.6.0.8. I rolled back to 16.1.5.2 and everything is fine. I don't even get that much disconnects and speed drops to 2 - 11 Mbps with 5 GHz band completely not functioning. I still do get them around once a week when connected to 2.4 GHz band. I never had this problem though when connected at the 5 GHz band.

The 16.1.5.2 is the best driver for both bands. 16.8.0.6 is the best one for stability at 2.4 GHz but is horrible at 5 GHz band.

Reply