Wireless
Issues related to Intel® Wireless Adapters and technologies
6288 Discussions

Unable to install new wifi driver - now using Intel(R) Wi-Fi 6 AX201 160MHz and not working!

CGayo
Beginner
704 Views

Hello, the Wifi driver updated recently and it stopped working. I returned to a previous version but still not working. I tried to download the new driver from the Assistant but it says it cannot install on my Windows 1909 compilation 18363.1854. Currently I am using driver version 22.70.0.6 and it works with my mobile phone, but not with my WIFI router.

 

Could it be that there are some mismatches in the new driver? Can you offer an alternative?

 

Thanks

 
 
 
 
0 Kudos
6 Replies
n_scott_pearson
Super User Retired Employee
684 Views

Well, you could upgrade Windows 10 to a more-recent version (like 21H1). You do know version 2004 reaches End-of-Service in December and all previous versions (other than LTS) ends in December, right? Intel drivers typically only support three versions back. See article here: Microsoft: Windows 10 2004 Reaches End of Service Next Month.

Just saying,

...S

CGayo
Beginner
649 Views

Dear Scott,

 

you are totally right, I had to update my Windows. However now it is versio 21H1, compile 19043.1348, Windows Feature Experience Pack 120.2212.3920.0, and the controller AX201 160MHz is 22.80.1.1 and my Wifi router still not working...

 

Anyone has an idea? I am afraid to tell my landlady I cannot use the Internet.

 
 
 
n_scott_pearson
Super User Retired Employee
640 Views

I can only suggest that you try doing a clean install. Here are the steps:

  1. If you haven't already, download - but do not install just yet - the latest Bluetooth and WiFi drivers for your adapter. Here are links to these  drivers: https://www.intel.com/content/www/us/en/download/19351/windows-10-and-windows-11-wi-fi-drivers-for-i... and https://www.intel.com/content/www/us/en/download/18649/intel-wireless-bluetooth-for-windows-10.html?....
  2. Disable Internet access. Unplug Ethernet cable and/or disable wireless. Keep disabled until told to re-enable.
  3. From the Apps & Features applet, check for instances of Intel PROSet/Wireless Software and Intel Wireless Bluetooth. If none, skip to Step 6.
  4. Uninstall each instance of Intel PROSet/Wireless Software and Intel Wireless Bluetooth that is present. When prompted, choose to "Discard Settings".
  5. Manually reboot your computer, keeping Internet access disabled throughout.
  6. From the Device Manager applet, check the Network Adapters section for an entry for Intel Wi-Fi 6 AX201 and check the Bluetooth section for an entry for Intel Wireless Bluetooth that has an intel driver associated with it. If neither is the case, go to Step 10.
  7. Right click on the entry for Intel Wi-Fi 6 AX201 and uninstall it, choosing to (checkmark) Delete the driver software for this device.
  8. Right click on the entry for Intel Wireless Bluetooth and open its properties. If it has an Intel driver associated with it, then uninstall it, choosing to (checkmark) Delete the driver software for this device.
  9. Go to Step 5.
  10. (Optional but recommended) Clean out all temporary files using the Windows Clean Disk tool. Ensure you have enabled cleaning of System Files. I recommend that you then checkmark all categories offered, even if no files currently in this category (so it leaves it set up for next invocation).
  11. (Optional but recommended) Clear each of your browsers' cache.
  12. Install the Bluetooth driver package (my rule: always do Bluetooth first).
  13. Install the Wireless driver package.
  14. Manually shutdown and reboot your computer.
  15. Enable Internet access.
  16. Test.

Hope this helps,

...S

CGayo
Beginner
627 Views

Dear Mr Scott Pearson,

 

I love you and I am not gay. Seriously you are a retired employee? They should pay you a fortune.

 

Zillion thanks

 

César

 
 
 
n_scott_pearson
Super User Retired Employee
617 Views

Yep, fully retired since the beginning of 2015. This is something to keep the mind engaged in retirement and to give back a bit lot.

...S

CGayo
Beginner
611 Views

Volunteering is a great deed talented retired people can do to help society. I am currently living in the Ukraine and I have met German, British and American retired people volunteering and helping society in here (and enjoying low prices and easy social life!).

 

The controller worked yesterday to connect to the Wifi router but it is again malfunctioning (I restarted in the morning). No data through it. Any idea why could that happen? Maybe something that downloaded automatically or some problem in the router itself? I am connecting now with my mobile hotspot and it works fine. Also my Xiaomi Redmi note 5 is connecting to the router.

 

Thanks

 
 
 
Reply