Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DavidTseng
Novice
4,545 Views

Wi-Fi 6 AX200 cannot open the 5G frequency band for hotspot use

Wi-Fi 6 AX200 product, using ubuntu 20.04 LTS operating system, using the third-party software hostapd recommended by Intel for management, only 2.4G frequency band can be turned on, 5G frequency band cannot be turned on, how to configure to turn on 5G frequency band, and 2.4 G can be used at the same time. Thank you!

--------

OS version screenshot

微信图片_20201018093023.png

-------

lspci

微信图片_20201018093017.png

------------

Third-party software hostapd version:

微信图片_20201018093013.png

-----------

hostapd 5G configuration file

微信图片_20201018092948.png

----------

wifi驱动版本:https://github.com/intel/backport-iwlwifi

----------

Iw list command to view the supported frequency bands in ap mode:

微信图片_20201018092956.png

------------------

The firmware version used by wifi:

微信图片_20201018092952.png

----------------

./hostapd -d hostapd.conf run error

微信图片_20201018092943.png

 

==============

Can you help me determine what caused this error problem, thank you very much!

 

 

Tags (3)
0 Kudos
29 Replies
Alberto_Sykes
Employee
3,444 Views

DavidTseng, Thank you for posting in the Intel® Communities Support.

 

In reference to your inquiry, please try the following troubleshooting steps in order to determine if there might be a problem with the Wireless configuration:

 

WiFi troubleshooting steps

 

Step 1: Check whether the kernel version supports this device:

The reference table of Wireless adapters and corresponding kernel versions is available in the following link:

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

The latest FWs are available by the following link:​

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/

If the kernel version corresponds to the Wireless adapter, proceed with step 2.

 

Step 2: Check whether the Wireless adapter is connected correctly:

Type the following command to the terminal: # lspci​ 

Verify that the Intel network controller ​is identified, as on a picture below. If not, then the system doesn't identify the Intel networidentifyk adapter and you will need to make sure it's properly integrated. You may need to request help from the system manufacturer. If the wireless adapter is properly identified - proceed with the step 3.

Alberto_R_Intel_0-1603131959995.png

 

Step 3: Check whether this is an iwlwifi issue:

Type the following command to the terminal: # modinfo iwlwifi​ (example of the command output is on the picture below). If there is no output, then the module isn’t installed this is the distribution installation issue.

Alberto_R_Intel_1-1603132129555.png

 

Please type: # lsmod | grep iwlwifi​    

Alberto_R_Intel_2-1603132230732.png

 

If the result is empty, the driver hasn't been loaded. Most likely to be a distribution issue.

To verify, please type: # dmesg | grep iwlwifi​    

Alberto_R_Intel_3-1603132314914.png

 

If the result is empty, the driver wasn’t initialized and this is a distribution issue. If the result is populated as on the above picture, proceeed with the step 4.

 

Step 4: Check whether the suitable firmware is installed:

Please type: # dmesg | grep “no suitable firmware found!”​

Alberto_R_Intel_4-1603132409336.png

 

If the result is not empty, it means you don’t have a suitable FW (api mentioned in the dmesg).

Please visit here​ https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi for supported FW, or here​ ​https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/ for the latest versions.

If these steps didn't reveal the issue or didn't solve the problem, proceed with the Step 5: 

 

Step 5: Collect the debug data:

Please type: # dmesg | grep ASSERT​ 

If the output is empty, please follow this wiki: https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging to extract dmesg and trace-cmd.

If the output has value, please collect from the wiki FW dump too.

 

Any questions, please let me know.

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

 

 

DavidTseng
Novice
3,423 Views

The following is a screenshot of the operation according to your steps, please help to see why there is no 5G signal?

step 1:   uname -a

1.png

2.png

step2:   lspci

3.png

step3:   modinfo iwlwifi

4.png

     lsmod | grep iwlwifi

5.png

    dmesg | grep iwlwifi

6.png

    step 4: dmesg | grep "no suitable firmware found!"

7.png

   step5: dmesg | grep ASSERT

8.png

=====================

9.png

The 5G frequency band still cannot be turned on. Could you tell me where it is not configured? Which version of the operating system Intel is compatible with? 

Alberto_Sykes
Employee
3,415 Views

DavidTseng, Thank you very much for providing that information.


In reference to your question, we will do further research on this matter, as soon as I get any updates I will post all the details on this thread.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


DavidTseng
Novice
3,411 Views

Thanks for your help!

Yesterday, the step5 of the operation missed the debug operation.

----

Open iwlwifi debug, but no more information.

cat .config

 
 

dmesg | grep wilwifi

2.png

-----

Looking forward to your more reply

 

 

DavidTseng
Novice
3,395 Views

Hi Alberto ,

Saw the information from the https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi 

3.png

 

Does it mean that only Ap 2.4G mode is supported?

 

have a nice day!

Alberto_Sykes
Employee
3,372 Views

DavidTseng, You are very welcome, I just received an update on this matter.

 

Just to let you know, we are currently still working on your case and in order for us to provide the most accurate assistance on this matter, we just wanted to confirm a few details about your system:

What is the model of the motherboard?

If this is a laptop, what is the model of it?

What is the model of the Router?

Is this a new computer?

Was it working fine before?

When did the issue start?

Did you make any recent hardware/software changes?

The wireless card, did you purchased it separately or did it came installed on the computer?

What is the OS version?

Already using a driver from our Linux driver's site?

Are you using the Intel® desktop kit or just the Intel® Wireless card?

Does the problem happen at home or work environment?

 

In regard to your question, "Does it mean that only Ap 2.4G mode is supported?", we will confirm if that is the case once we received the information requested on this post, once you get the chance please let us know those details.

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

 

DavidTseng
Novice
3,366 Views

Hi, thanks  for your reply

According to your question above, we have the following reply.

The platform we purchased from Advantech, model: FWA-1212VC.

At the same time got a wireless network card intel Ax 200 from them.

OS version: Ubuntu 20.04, kernel 5.4.0-51.

The firmware and drivers downloaded from the intel official website have not been modified in any way.

 

If you want to know more details, I am glad to provide you with it.

 

Alberto_Sykes
Employee
3,350 Views

Hi DavidTseng, You are very welcome, thank you very much for sharing those details.


We will continue with our research on this matter, as soon as I get more details I will post all the updates in this thread.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel



Alberto_Sykes
Employee
3,243 Views

Hello DavidTseng, I just received an update on this matter.


In order for us to continue with our research on this case, we just wanted to confirm: 

What is the error message?

How did you enable and test the hotspot?

 

Did you try enabling 5Ghz frequency via the Run a Command window?

-When the hotspot is enabled, press Alt+F2 to bring up ‘Run a Command’ box, input nm-connection-editor, and hit Enter

-Select and edit ‘Hotspot’. (If you don’t see it, wifi-hotspot is not turned on, go back to step one)

-In the WiFi tab set the Band option accordingly

  

If by any chance, you are unable to set this up, please provide an image or video and attach it to the thread so we can further assist you with this topic.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel



DavidTseng
Novice
3,200 Views

My operating environment is: Ubuntu 20.04, kernel 5.4.0-51, using console mode. Can not operate Alt + F2,  NOWOnly 5G band hotspots can not be used,  while 2.4G band hotspots can be used .  

We are very anxious, hurry up and solve it, thank you very much.

DavidTseng
Novice
3,141 Views

Hi,

     In the PC  win10 system. Load the latest wireless driver, configure the wireless hotspot, and turn on the 5G frequency band hotspot.

    Tip: "The selected network band is not available. Please select another band and try again".


    The 5G band hotspot still cannot be opened, which is consistent with the performance of Linux.

Alberto_Sykes
Employee
3,118 Views

Hi DavidTseng, You are very welcome, thank you very much for providing those results.


We will keep working on this matter, as soon as I get more information I will post all the details on this thread.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


Alberto_Sykes
Employee
2,965 Views

Hello DavidTseng, I just received an update on this matter.

 

Due to regulatory information, we just wanted to confirm in which country the tests that you shared were performed? 


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


Alberto_Sykes
Employee
2,937 Views

Hello DavidTseng, I just wanted to check if you saw the information posted previously and if you need further assistance on this matter?


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


DavidTseng
Novice
2,902 Views

Hi Albert R,

I'm so sorry that  reply question now.

My test environment was conducted in Beijing, China.

Best wishes!

Alberto_Sykes
Employee
2,893 Views

Hi DavidTseng, No problem at all, thank you very much for clarifying that information. 


We will continue with our research on this matter, as soon as I get more updates I will post all the details on this thread.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel 


Alberto_Sykes
Employee
2,762 Views

DavidTseng, I just received another update on this topic.


For your information, we just wanted to let you know that all 5Ghz in China SKUs are set to Passive, these are not allowed for SoftAP operation by our Intel® NIC and this specific OTP/NVM. That is actually the reason why you cannot open a 5GHz frequency band for the hot spot use.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


aktinkon
Beginner
2,695 Views

Hello. Let me join the discussion, thanks.

I have the same problem. AX200 units I am working with were sold to the Ukraine and to US. In both cases all frequencies in Band 2 (5 GHz) are marked as "no IR" or "disabled" according to "iw list" output. May you please tell me in what jurisdiction Intel allows SoftAP operations and how to get this firmware?

WBR, Oleksii

bamhm182
Beginner
2,510 Views

I'd also like to post on this to see if anyone comes across a fix. When in Windows 10, I can create a 5GHz mobile hotspot without a problem. When in Linux, I'm getting `no IR`, `radar detection`, and/or `disabled` on all 5GHz channels, which results in hostapd not being able to create a 5GHz AP.

I am using the following system in the US:

Motherboard: ASUS Zenith II Extreme Alpha

CPU: AMD ThreadRipper 3970X

 

If there's anything I can do to help figure this out, please let me know.

jpereira
Novice
2,166 Views

Hello,

I'm facing the same problem. I bought this module specifically for using in AP mode and I cannot get it to work.

I'm using Debian Buster with kernel 5.4.73. I have the AX200 card installed on an ASUS J4105-ITX motherboard.

I bought the AX200 in Sweden at Mouser.se (probably shipped from USA).

There are many people facing the same problem on internet: The board can only work in AP mode on 2.4GHz network. Nobody seems to be able to fix the issue and the general recommendation is to throw the intel module on the trash and buy a Qualcomm Atheros module.

I tried to compile the drivers from source, the kernel, and hostapd without success on fixing the issue.

Apparently, for what I could find, this module is "self managed" and this can be seen when running:

$ sudo iw reg get
global
country SE: DFS-ETSI
(2400 - 2483 @ 40), (N/A, 20), (N/A)
(5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
(5725 - 5875 @ 80), (N/A, 13), (N/A)
(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#3 (self-managed)
country 00: DFS-UNSET
(2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ
(2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ
(2447 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
(5170 - 5190 @ 160), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS
(5190 - 5210 @ 160), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS
(5210 - 5230 @ 160), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS
(5230 - 5250 @ 160), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS
(5250 - 5270 @ 160), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS
(5270 - 5290 @ 160), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS
(5290 - 5310 @ 160), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS
(5310 - 5330 @ 160), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS
(5490 - 5510 @ 240), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS
(5510 - 5530 @ 240), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS
(5530 - 5550 @ 240), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS
(5550 - 5570 @ 240), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS
(5570 - 5590 @ 240), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS
(5590 - 5610 @ 240), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS
(5610 - 5630 @ 240), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS
(5630 - 5650 @ 240), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS
(5650 - 5670 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-160MHZ
(5670 - 5690 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-160MHZ
(5690 - 5710 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-160MHZ
(5710 - 5730 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-160MHZ
(5735 - 5755 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-160MHZ
(5755 - 5775 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-160MHZ
(5775 - 5795 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-160MHZ
(5795 - 5815 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-160MHZ
(5815 - 5835 @ 20), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ

Here we can see that my system is set to Sweden (country SE: DFS-ETSI), but the card is unset (country 00: DFS-UNSET). Since the module is unset it doesn't allow AP mode using 5GHz because the module doesn't know what are the channels it can use to initiate radiation on my region.

Apparently, the module should scan my neighbors networks and based on the results it would know where it is located and set the region automatically, correct me if this is wrong because I couldn't find a good explanation for this. It would also mean that if I'm far from the city this module wouldn't work...

I also tried to use the module option "lar_disable=1" when loading the iwlwifi module:

modprobe iwlwifi lar_disable=1

The module option "lar_disable=1" should disable LAR (Location Aware Regulatory) which I think has to do with disabling the self managed mode, but even with this option the module reports NO-IR (no initiate radiation) for 5GHz channels, it seems to work on older intel modules. Since lar_disable is being dropped (https://bugzilla.kernel.org/show_bug.cgi?id=205695#c6) in more recent kernels we shouldn't rely on it anyway.

So, the problem seems to be in how make the module "discover" where it is located. How can we trigger it?

Please give a solution for this,

 

BR,

JP

Reply