Wireless
Issues related to Intel® Wireless Adapters and technologies
5970 Discussions

Wi-Fi suddenly disconnects when playing games

georgedudu1337
Beginner
675 Views

Hello. As the title says, when playing games for 10-15 minutes (World of Warcraft or CS:Go for example) I get disconnected all of a sudden. When I check the 'internet' menu there are no networks available (as if i don't have a wireless driver). After 20-30 seconds, without doing anything, everything comes back to normal. All networks reappear and my connection is restored.
I tried:

-reinstalling windows (but keeping the files)

-updating BIOS, wi-fi drivers and all other drivers.

-looking into event viewer.

Looking into event viewer i noticed I get many errors, such as:s.png

0 Kudos
14 Replies
Maria_R_Intel
Moderator
626 Views

Hello georgedudu1337,


Thank you for posting on the Intel* Community.


To better assist you, please provide us with the below details:


  • Was the wireless card working fine before?
  • Are you able to see any errors on the device manager? (for example code 10 under network adapters)
  • Is the wireless card you made to your system?



Provide the Intel® System Support Utility (Intel® SSU) 

 


Best regards,

Maria R.

Intel Customer Support Technician


georgedudu1337
Beginner
622 Views

I'm not sure if I know the answer to the first question, but I hope this helps: Never had wi-fi problems until recently.

As for the Events under the wireless driver, there is "Event ID 411" but I'm not sure if that's the right answer..

And for the third question, I'm not sure I understand. Sorry..

Here is the scan tho.

georgedudu1337
Beginner
619 Views

After reading this topic on the intel community (most importantly, the last reply on the topic) I noticed something. My Bluetooth Device (Personal Area Network) under 'Network Adapters' says it has the driver from the year 2006, while on the Intel Driver Assistant, it says it has the driver from last month or something. And the guy in the last reply in the link above said something about having an outdated bluetooth wireless driver and an up-to-date wireless driver while having a 5Ghz wi-fi results in this exact problem, with 5002 and 5005 event errors. 

georgedudu1337
Beginner
616 Views

Sorry for the 3rd reply in a row, but I just wanted to say that I installed 2 different drivers for the bluetooth wireless (one from Intel, one from the HP website) and it still shows the old version, from 2006 (10.X.XXXXX.X instead of 20+.X.XXXXX.X)

n_scott_pearson
Super User Retired Employee
610 Views

I shake my head every time I see folks confused by Intel's, um, sillier decisions. Fact is, Intel uses the date field for the storage of other information. Bottom line, do not make any decisions based upon the contents of the date field. Use the version strings for all decision-making.

...S

Khun_Doug
Valued Contributor I
587 Views

Georgedudu,

You didn't mention the network setup. Please describe the wireless router or access point, and how that unit is connected to the Internet. And as another useful bit of information, are you using the Bluetooth when these disconnects begin happening?

 

Maria_R_Intel
Moderator
546 Views

Hello georgedudu1337,


Thank you for your response and the information provided.


Based on the reports, I noticed that you are using the wireless driver version 22.30.0.11, which is a generic version from Intel.


There are two different types of drivers, generics provided by Intel and Equipment Manufacturer drivers, that are customized to work with each specific system, so the first thing to do is to check which type of driver is installed in your system.


We highly recommend using the drivers that are provided by the system manufacturer or via Windows Update to eliminate the potential impact caused by loading non-customized drivers (Intel's generic drivers that were not tested on your specific system). The system manufacturers regularly customize Intel generic drivers to meet the needs of their specific system design. In such cases, the use of the Intel generic driver update is not recommended.



Can you please try a clean installation of the drivers? just for testing the HP* driver, version 21.80.2.1


Please try the following steps and let us know about the outcome: 

 

1. Try a clean install of the wireless drivers following these steps to the letter: https://www.intel.com/content/www/us/en/support/articles/000022173/network-and-io/wireless.html  

 

Step 1: Download and save the drivers on your computer: 

Get the latest system-specific driver from your computer manufacturer support https://support.hp.com/ca-en/drivers/selfservice/omen-by-hp-15-dc1000-laptop-pc-series/26122182/mode...


Step 2: Uninstall the Wi-Fi driver. 

  1. Uninstall your Wi-Fi driver. 
    1. Go to Device Manager
    2. Expand the Network Adapters category. 
    3. Right-click your Intel Wireless Adapter and choose to uninstall it. 
    4. Make sure to select the option to Delete the driver software for this device
    5. Repeat steps A through D until the option to Delete the driver software for this device is greyed out. 

 

2. Restart your computer. 

 

Step 3: Driver installation. 

Locate the drivers you downloaded back in Step 1. Run as administrator, and follow the wizard to completion. To run as administrator, right-click over the file you downloaded and select the option to Run as administrator. You should test first the driver provided by HP* as they have been validated to work with your system, if that does not work then you can do the same procedure with the Intel generic driver.  

 

2. Set the recommended settings for 802.11AC Connectivity: https://www.intel.com/content/www/us/en/support/articles/000024678/network-and-io/wireless.html  

 

3. Set the wireless card to Maximum Performance: https://www.intel.com/content/www/us/en/support/articles/000005879/network-and-io/wireless.html  


If the issue persists, please provide us with the below details:


  • Is the issue with both bands 2.4GHz and 5.0GHz?
  • By any chance, did you test different routers/Access points?


Best regards,

Maria R.

Intel Customer Support Technician


georgedudu1337
Beginner
533 Views

I've done all that, after reinstalling windows and refromatting my PC.  Issue still persists. I still get Event Id 5002 "Intel(R) Wireless-AC 9560 160MHz : Has determined that the network adapter is not functioning properly." and Event Id 5011  Intel(R) Wireless-AC 9560 160MHz : A required parameter is missing from the registry.

And now I noticed this (i think it's the first time this happened:  [EVENT ID 10317]Miniport Intel(R) Wireless-AC 9560 160MHz, {e6eec114-1e9f-444f-9d45-b7d2660cf50f}, had event Fatal error: The miniport has detected an internal error)

Also, this happens a lot too [Event ID 10] ACPI: ACPI BIOS is attempting to write to an illegal PCI Operation Region (0x16), Please contact your system vendor for technical assistance.

To answer your questions:

I am not sure if it's 2.4ghz or 5ghz, but I am pretty sure it is 2.4ghz as the internet router  was purchased about 2 years ago.

I haven't tried on any other connections since I can't connect to any routers/wifi. I can try with my phone hotspot tho.

georgedudu1337
Beginner
527 Views

I tried again on my phone hotspot and the same thing happened.

But this time when I looked at device manager, i noticed an icon that indicates an error I suppose

It said: 

This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful.

I also tried the network troubleshooter and this is what it said (attached picture)

 

Khun_Doug
Valued Contributor I
495 Views

Georgedudu,

Have you contacted HP support to see what they suggest regarding this problem? The reason I ask is this appears to possibly be a hardware issue, nothing to do with drivers or Windows versions and updates. HP may want to replace the network adapter.

As a test to be the laptop OS install is not at fault, have you tried using a USB wireless adapter to see if the laptop functions properly, especially on long play sessions. If the laptop works well after long play, and there are no network issues with a USN adapter, you almost certainly can point to a bad adapter or something on the motherboard that connects to the adapter.

 

georgedudu1337
Beginner
476 Views

My warranty expired and Hp doesn't talk to people whose warranty expired (:

My internet is 5GHZ by the way.

Khun_Doug
Valued Contributor I
464 Views

Georgedudu,

The Intel reps may have other ideas, but to me this appears to be a hardware error. It could be a fault on the laptop motherboard. But more likely the adapter has failed. That leaves you with a few choices.

- You can send the laptop in for service or take it to your local laptop shop, and have them replace the adapter.

- If you are handy with tools and PC repair, you can try replacing the adapter yourself.

- You can use a USB adapter. There are numerous USB adapters that support wireless AC.

If you choose to use the USB option, I would try disabling the defective adapter in BIOS, or in Device Manager. That will likely help to prevent other network errors.

 

georgedudu1337
Beginner
458 Views

I want to thank everyone for their replies and help.

I ended up ordering this USB wifi adapter. I mostly play video games so I hope it is good for that. Can anyone tell me if it's okay for online gaming? (Counter-strike Global Offensive [fps] and World of Warcraft [MMORPG]). I have a 5ghz wi-fi and the connection I think is about 67mbps (I download with like 8.4mbps)

Khun_Doug
Valued Contributor I
451 Views

Georgedudu,

That Wi-Fi adapter should work. One thing you may want to consider is moving up to the AC1300 or AC1300 high-gain version. As your bandwidth increases, the better model will be able to better utilize that bandwidth. I know it's a few more pounds (or whatever currency), but they are likely to have far more throughput.

 

Reply