Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7655 Discussions

Windows 10 Hyper-V and Intel Wireless AC 9560 160Mhz very slow



If I use Hyper-V through Ethernet through usb-c, all is working perfectly. When I do the same thing with the wireless device, the performance of the host decrease extremely. I made a lot of research on Internet and a lot of people got the same problem but nobody has founded a solution. I updated with the latest version of the driver from intel website and it changed nothing. If you propose a solution, it will help a lot of people.

Thank you for your help,

  1. When did this issue start happening? From the first day, I bought the PC. : 03/03
  2. Could you please confirm if this happens on the host or guest machine? Host
  3. Was the Intel® Wireless adapter preinstalled in the computer? Yes
  4. Please run the Intel® System Support Utility on the host machine to scan your unit and attach the report to this thread. Please, find attached the required file



0 Kudos
4 Replies
Super User

Since your previous thread wasn't closed yet, there is no need to open a new thread.




0 Kudos

Sorry for the misunderstanding. I received an email saying it will be closed.

0 Kudos


I believe we have the same issues.

Using Lenoovo T490 (AC 9560 160Mhz) and Lenovo P53 (AX 200 160mhz) we get 0 upload speed once the wireless nic gets bonded with a hyper v virtual interface.

Experementing i found that this work around makes things better for me with my P53 :


Disabling LSO ( Large send offload ) on the virtual NIC on both the Host and Guest OS.

Device manager > Hyper V Ethernet adapter # "nr" > Properties > Advanced .


Remember to do this procedure on both host and guest os.


LSO is a feature that offloads packet tasks from CPU to NIC HW.


So intel, are you sure that this is a Microsoft problem and not a wireless NIC driver problem ?


Best regards Sebastian

0 Kudos

I’m experiencing the same issue for my company.  We use Dell 5300 laptops with Intel AC 9560 wireless adapters.  All laptops are running Windows 10 v2004.  Speedtest.net gives normal results for both upload and download speed (about 100mbps up / 100mbps down).  Once I create an external virtual switch and use that wireless adapter, the download speed remains the same, but the upload speed drops to about 0.4 mbps.  I don’t even need to create a virtual machine for the problem to start.

I tried some suggestions like disabling LSO (large send offload v2) on the “HyperV Virtual adapter”.  I also tried changing the “MIMO Power Save Mode” from “Auto SMPS” to “Static SMPS”.  Neither helped with the issue.  This has been going on for many months and I’m forced to set up HyperV to use the Ethernet adapter.  Please help!!

0 Kudos