Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SA4
Beginner
1,587 Views

Windows 7 AC 7260 will not connect to AC 8260 on Linux Kernel 4.1 configured as Access Point

Hi,

Here's my configuration:

  1. AC-8260 WiFi module running on Linux Kernel 4.1 as Access Point.
  2. Windows 7 OS with AC-7260 WiFi Module as client.
  3. Windows 10 OS with AC-7260 WiFi Module as client.

Problem:

  • # 3 connects to # 1 if using the latest driver version 18.33.11.2 date: 10/31/2017. This is good. It doesn't work if using the previous version of the driver 18.33.9.3 date: 10/1/2017, but thats OK since latest driver works. But it does tell me that something changed for good in the latest driver that helps with the connectivity.

     

  • Here is the main problem: # 2 above cannot connect to # 1 even with the latest driver version 18.33.11.2. Tried several other previous drivers but they wouldn't work either. hostapd on linux reports the following errors:
    • Dec 19 02:50:27 .....daemon.notice hostapd: wlan0: STA IEEE 802.11: did not acknowledge authentication response.

Any help would be greatly appreciated.

0 Kudos
8 Replies
idata
Community Manager
74 Views

Hello SriniFaro,

We understand you're setting up system # 1 as the Access Point, system # 3 can connect if using the latest drivers, but system # 2 cannot connect regardless of driver version.

In order to look into this, could you please provide us with a System Support Utility report for all three systems (or at least 1 and 2).

  1. For Windows*:
    1. Download and run the http://downloadcenter.intel.com/download/25293 Intel® System Support Utility.
    2. Select to scan "everything," and run the scan while connected to your wireless network (if possible).
    3. Save the report and attach it to your reply.
  2. For Linux*:
    1. Download the https://downloadcenter.intel.com/download/26735 Intel® SSU for Linux* and save the ssu.tar.gz file to your system.
    2. Extract the ssu.sh file from ssu.tar.gz and save to your system.
    3. To run the ssu.sh script from a Linux terminal, Open Applications->Accessories->Terminal.
    4. From the current directory, navigate to the current folder where the ssu.sh file resides. For example, if you saved the ssu.sh file to a folder called SSU File, the command would be cd SSU File.
    5. Run the ssu.sh file using this command: ./ssu.sh
    6. If no output file is specified, the Intel® SSU writes the output to the .txt file.
  3. If possible, please test the following scenario and let us know the results:
    1. Set up system # 3 as a hotspot: Start > Settings > Network & Internet > Mobile Hotspot > Set up the hotspot and turn on "Share my Internet Connection with Other Devices."
    2. Connect system # 2 to # 3 and let us know if the connection is successful. This will help us identify if it's an issue specific to your Linux AP or a greater issue connecting to hotspots and hosted networks for the AC7260 in Windows* 7.
  4. How many systems will be connecting as clients to the system # 1 AP?

We look forward to hearing back from you.

Best regards,

 

Carlos A.
SA4
Beginner
74 Views

Here's the information you requested.

  1. Windows SSU output attached.
  2. Linux SSU output attached. Note that we are running a custom Linux distribution based on Kernel 4.1; so, the SSU on Linux could not gather much information. If you need anything specific for this, please let me know.
  3. Tested the mobile hotspot. Works fine. I am able to ping from my Win7 to Win 10. Also, the Win 10 shows that the Win7 is connected. No problem whatsoever.
  4. We intend to connect 5 clients to the Linux system's WiFi AP.
idata
Community Manager
74 Views

Hello SriniFaro,

 

 

Thank you for the information. Please bear with us while we investigate the issue, we'll let you know if we need any additional details.

 

 

Best regards,

 

Carlos A.
SA4
Beginner
74 Views

Thank you. Just want to add more information:

  • there is NO problem with using Ubuntu "Live USB" 16.04 LTS on the laptop (that natively has Win 7 and AC 7260). It is able to communicate without any problems with # 1. It immediately connects and stays connected.
  • Even though I said, # 3 is able to communicate with # 1, I do see some times, it is not able to do that reliably.
idata
Community Manager
74 Views

Hello SriniFaro,

 

 

Thanks for this update.

 

 

- If you run the live CD in PC # 1 or # 3, and set up the AP there, can # 2 still not connect if using Windows*?

 

- Could (or have) you tried using the wireless drivers provided by your computer manufacturer for # 2? - http://www.dell.com/support/home/us/en/19/drivers/driversdetails?driverId=48WF6 Intel® 7260 WiFi Driver for Dell Precision M6800*

 

 

NOTE: Any links provided for third party tools or sites are offered for your convenience and should not be viewed as an endorsement by Intel® of the content, products, or services offered there. We do not offer support for any third party tool mentioned here.

 

 

We will continue investigating. However, due to the nature of this problem, we recommend for you to additionally reach out and engage your computer manufacturer as well as Linux* forums. Let us know of any updates you receive from their side.

 

 

Best regards,

 

Carlos A.
SA4
Beginner
74 Views

  • I went to Dell's page you linked below and tried. # 2 still cannot connect to # 1.
  • Using LiveCD, i created a AP on # 3, and I can connect from # 1, no problems at all. Please note that in this case, both sides are using AC-7260.

Is there anything else you want me to try. Thanks for your support.

idata
Community Manager
74 Views

Hello SriniFaro,

 

 

So far, we understand that the # 2 PC (7260/Win7*) can connect to Windows* created hotspots, and all other systems have no issues regardless of who's the client and who's the host.

 

 

- Can # 2 (7260/Win7*) connect to # 3's (7260/Win10 PC, but using Linux*) LiveCD hotspot?

 

- How are you creating the AP in Linux*?

 

- Have you tried setting up the profile on # 2 manually?

 

 

We look forward to hearing back from you.

 

 

Best regards,

 

Carlos A.
idata
Community Manager
74 Views

Hello SriniFaro,

 

 

We haven't heard back from you in a while.

 

 

Where you able to resolve this problem? Did the Linux* forums provide any assistance?

 

 

Best regards,

 

Carlos A.
Reply