Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7525 Discussions

Wireless-AC 7260 extremely slow speeds


Hello everybody!

I use my Asus Zenbook UX303L with Intel Dual Band Wireless-AC 7260.

The speeds I get via speedtest.net: UP 10 to 15 Mbps & DOWN 50 to 70 Mbps (I have 100Mbps UP&DOWN which I verified on LAN).

When I connect to my local NAS, I get 4 to 6 MBytes for download, which is so frustrating.

The router i use TP-Link 300Mbps Wireless N Gigabit Router (TL-WR1042ND), which is 3 m away and in sight.

OS is Win 8.1 Pro 64bit with i7-4510U and 8GB RAM

System power saving mode of wireless adapter is set to Maximum performance.

The 7260 Wireless adapter:


driver ver.

2.4Gh - auto

5.2Gh - auto

Ad Hoc ch - 1

Ad hoc QoS Mode - WMM Enabled

ARP - Enb

Bluetooth APM - Enb

fat ch intolerant - Dis

GTK - Enb

HT mode - VHT mode

mixed mode prot - CTS-to-self enb

NS - enb

packet coalescing - Enb

preferred band - no pref

roaming - medium

sleep on WoWLAN - dis

throuhput booster - dis

transmit power - highest

U-APSD - dis

wake on magic pocket - enb

wake on pattern - enb

wireless mode - a/b/g

When reading these forums, I read tip to change WMM from disabled to enabled, which actually helped a bit since NAS download speed ranged between 1 to 2 MBytes before.

I also tried to wirelessly download something from local NAS using other quite similar Asus with the same network adapter (and the same settings and driver) and its speed was approx. 16 MBytes. (Which is still not good at all, but still way better than mine.)

When using almost 3 years old Dell Latitude laptop, I get 70 to 80 Mbit on speedtest.net via wifi.

Thank you for your help.

0 Kudos
3 Replies
Honored Contributor II

Hello tom.suky,

The wireless settings you have should work fine in most environments. You might want to change the Roaming to low or medium low, however, it may not account for all the performance difference you noticed.

It would be good to check with the router manufacturer if there are any firmware updates for the Access point.

For testing purposes, you may want to disable the Bluetooth adapter and check if that improves the WiFi connection.

Also, check if you get better results changing the position of the PC, or placing it close to the Access point.

0 Kudos
Valued Contributor II

Faulty antenna on the zenbook, or the zenbook has some programs that conflict/take away bandwidth . BTW 16 MB/s (that's 128 Mbps throughput FYI) is the norm for N connection so there's no problem on the other asus with 7260. I get about 50 MB/s (400 Mbps throughput) on my laptop connected to 802.11ac router.

0 Kudos


I am having similar issues on my work laptop. I work from home for the parent company and have a PolyCom IP phone connected by wireless bridge plus a host of other devices that work flawlessly with my Netgear Rangemax WNDR3700 router. My Dell Latitude with dual-band 7260 simply will not stay connected to the 2.4ghz. side of my router. I have to go to the 5ghz. before the connection is solid.

I used the Intel Wireless Event Viewer in real time to view events while using the connection utility to connect to the 2.4ghz. wireless radios on the router. The connection consistantly goes into roaming, authenticating, roaming, authenticating pretty much non-stop. This makes for a very slow / sporadic connection whereas my Fonality HUD drops offline/online/offline etc.

When I use the same method to connect to the 5ghz. radios of the router, all is good. So there is definitely a problem with the 2.4ghz driver pack for this card. I believe it is in the authentication/security side as the logs on the router show WLAN denial requests because of authentication about every fifth attempt.

Security is set to WPA2 Personal PSK/AES - again, no problems from the 3 Roku boxes, Xbox 360, XboxOne, PS3 or iPhone/Pads in the house. Just this machine and 7260.

So, you are NOT crazy....


0 Kudos