Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
928 Views

Wireless AC 7260 varying speed...

Jump to solution

I'm using this adapter in a headless Linux fileserver and find that large files transfer quickly and reliably, no problem there.

The 'iwconfig' command shows link quality 70/70 and signal -37dBm, so that's excellent.

My problem is during remote administration of this server, when I experience a lot of lag when typing. The 'iwconfig' command

shows that the bitrate is then a lowly 6 Mbps, which explains the lag.

I've experimented a bit with putting some load on the adapter by sending varying numbers of ping requests, after which I again

checked the bitrate. There seems to be a progression, where the bitrate of the adapter increases in steps, starting at 6.0 Mbps

(the idling speed) via 9.0, 12.0, 18.0, 24.0, 36.0, 48.0, 54.0, 58.5, 87.8, 117.0, 175.5, 234.0, 263.0, 292.5, 351.0, 390.0, 468.0,

526.6, 585.0, 650.0, 780,0 en topping off at 866.7 Mbps after about 25 ping requests to my ISP.

 

That seems to explain why my large files transfer quickly, and why my administration work is as slow as molasses.

My question: is there a way of switching the adaptor into high speed mode independent of throughput? I've already tried switching

off power management, but didn't make a difference.

0 Kudos

Accepted Solutions
Highlighted
Novice
7 Views

Well, it turned out to be that Intel firmware! A bit of searching showed the latest version to be iwlwifi-7260-12.ucode, which requires a recent Linux kernel. So, I installed a 3.19 kernel (from Debian experimental) and added that version 12 firmware from kernel git sources to /lib/firmware, rebooted and things were fine.

What specifically has changed? While the 7260 AC adapter still reverts back to its idling speed of 6Mbps fairly quickly (presumably to save battery power on laptops), it now also reacts more quickly to activity. The response is positively snappy when power-save is switched off, just doing some typing in a remote admin session is sufficient to achieve the maximum speed of 866.67Mbps, so no more irritating lag! That's called progress.

View solution in original post

0 Kudos
3 Replies
Highlighted
Valued Contributor II
7 Views

I think that's isolated in Linux drives since I get zero latency and constant 866.7 Mbps in my Windows 7 laptop.

0 Kudos
Highlighted
Novice
7 Views

Could be, but I spent some time going through the source code for the Linux iwlwifi driver and didn't see any reference

to tx-rate stepping. My feeling is that it is managed in the iwlwifi-7260-9.ucode firmware, and that comes from Intel.

0 Kudos
Highlighted
Novice
8 Views

Well, it turned out to be that Intel firmware! A bit of searching showed the latest version to be iwlwifi-7260-12.ucode, which requires a recent Linux kernel. So, I installed a 3.19 kernel (from Debian experimental) and added that version 12 firmware from kernel git sources to /lib/firmware, rebooted and things were fine.

What specifically has changed? While the 7260 AC adapter still reverts back to its idling speed of 6Mbps fairly quickly (presumably to save battery power on laptops), it now also reacts more quickly to activity. The response is positively snappy when power-save is switched off, just doing some typing in a remote admin session is sufficient to achieve the maximum speed of 866.67Mbps, so no more irritating lag! That's called progress.

View solution in original post

0 Kudos