Wireless
Issues related to Intel® Wireless Adapters and technologies
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
6422 Discussions

not able to enable multiqueue support on ixgbe 3.7.17 drivers

dpal1
Beginner
1,257 Views

Hi

I have compiled the ixgbe driver and loaded it.

I have given what information may be important.

insmod ./ixgbe.ko MQ=1,1 RSS=8,8 FdirMode=1,1 mtu=9600 IntMode=2

# dmesg | grep ixgbe

ixgbe 0000:08:00.1: PCI INT A -> Link[LN45] -> GSI 45 (level, high) -> IRQ 45

ixgbe 0000:08:00.1: setting latency timer to 64

ixgbe: Multiple Queue Support Enabled

ixgbe: Receive-Side Scaling (RSS) set to 8

ixgbe: Flow Director filtering mode set to 1

ixgbe: 0000:08:00.1: ixgbe_check_options: Flow Director hash filtering enabled

ixgbe: 0000:08:00.1: ixgbe_check_options: FCoE Offload feature enabled

ixgbe 0000:08:00.1: (unregistered net_device): FCoE offload feature is not available. Disabling FCoE offload feature

ixgbe 0000:08:00.1: irq 137 for MSI/MSI-X

ixgbe 0000:08:00.1: irq 138 for MSI/MSI-X

ixgbe 0000:08:00.1: irq 139 for MSI/MSI-X

ixgbe 0000:08:00.1: irq 140 for MSI/MSI-X

ixgbe 0000:08:00.1: irq 141 for MSI/MSI-X

ixgbe 0000:08:00.1: irq 142 for MSI/MSI-X

ixgbe 0000:08:00.1: irq 143 for MSI/MSI-X

ixgbe 0000:08:00.1: irq 144 for MSI/MSI-X

ixgbe 0000:08:00.1: irq 145 for MSI/MSI-X

ixgbe 0000:08:00.1: (PCI Express:5.0GT/s:Width x8) 00:1b:21:96:dc:43

ixgbe 0000:08:00.1: dna1: MAC: 2, PHY: 2, PBA No: G21371-001

ixgbe 0000:08:00.1: dna1: Enabled Features: RxQ: 8 TxQ: 8 FdirHash RSS LRO

ixgbe 0000:08:00.1: dna1: Intel(R) 10 Gigabit Network Connection

ixgbe 0000:08:00.0: dna0: NIC Link is Up 10 Gbps, Flow Control: RX/TX

# ethtool -S dna1

NIC statistics:

rx_packets: 0

tx_packets: 0

rx_bytes: 0

tx_bytes: 0

rx_errors: 0

tx_errors: 0

rx_dropped: 0

tx_dropped: 0

multicast: 0

collisions: 0

rx_over_errors: 0

rx_crc_errors: 0

rx_frame_errors: 0

rx_fifo_errors: 0

rx_missed_errors: 0

tx_aborted_errors: 0

tx_carrier_errors: 0

tx_fifo_errors: 0

tx_heartbeat_errors: 0

rx_pkts_nic: 0

tx_pkts_nic: 0

rx_bytes_nic: 0

tx_bytes_nic: 0

lsc_int: 0

tx_busy: 0

non_eop_descs: 0

broadcast: 0

rx_no_buffer_count: 0

tx_timeout_count: 0

tx_restart_queue: 0

rx_long_length_errors: 0

rx_short_length_errors: 0

tx_flow_control_xon: 0

rx_flow_control_xon: 0

tx_flow_control_xoff: 0

rx_flow_control_xoff: 0

rx_csum_offload_errors: 0

alloc_rx_page_failed: 0

alloc_rx_buff_failed: 0

lro_aggregated: 0

lro_flushed: 0

lro_recycled: 0

rx_no_dma_resources: 0

hw_rsc_aggregated: 0

hw_rsc_flushed: 0

fdir_match: 0

fdir_miss: 0

fdir_overflow: 0

fcoe_bad_fccrc: 0

fcoe_last_errors: 0

rx_fcoe_dropped: 0

rx_fcoe_packets: 0

rx_fcoe_dwords: 0

fcoe_noddp: 0

fcoe_noddp_ext_buff: 0

tx_fcoe_packets: 0

tx_fcoe_dwords: 0

os2bmc_rx_by_bmc: 0

os2bmc_tx_by_bmc: 0

os2bmc_tx_by_host: 0

os2bmc_rx_by_host: 0

tx_queue_0_packets: 0

tx_queue_0_bytes: 0

tx_queue_1_packets: 0

tx_queue_1_bytes: 0

tx_queue_2_packets: 0

tx_queue_2_bytes: 0

tx_queue_3_packets: 0

tx_queue_3_bytes: 0

tx_queue_4_packets: 0

tx_queue_4_bytes: 0

tx_queue_5_packets: 0

tx_queue_5_bytes: 0

tx_queue_6_packets: 0

tx_queue_6_bytes: 0

tx_queue_7_packets: 0

tx_queue_7_bytes: 0

rx_queue_0_packets: 0

rx_queue_0_bytes: 0

rx_queue_1_packets: 0

rx_queue_1_bytes: 0

rx_queue_2_packets: 0

rx_queue_2_bytes: 0

rx_queue_3_packets: 0

rx_queue_3_bytes: 0

rx_queue_4_packets: 0

rx_queue_4_bytes: 0

rx_queue_5_packets: 0

rx_queue_5_bytes: 0

rx_queue_6_packets: 0

rx_queue_6_bytes: 0

rx_queue_7_packets: 0

rx_queue_7_bytes: 0

# grep pci_enable_msix *.h

kcompat.h:# undef pci_enable_msix

kcompat.h:# define pci_enable_msix(a, b, c) -ENOTSUPP

As you can see the multiqueues are not enabled? Please help.

Regards.

0 Kudos
2 Replies
dpal1
Beginner
321 Views

small error there in NIC stats.(updated)

NIC statistics:

rx_packets: 36755172

tx_packets: 0

rx_bytes: 23829196498

tx_bytes: 0

rx_errors: 0

tx_errors: 0

rx_dropped: 0

tx_dropped: 0

multicast: 0

collisions: 0

rx_over_errors: 0

rx_crc_errors: 0

rx_frame_errors: 0

rx_fifo_errors: 0

rx_missed_errors: 0

tx_aborted_errors: 0

tx_carrier_errors: 0

tx_fifo_errors: 0

tx_heartbeat_errors: 0

rx_pkts_nic: 37086809

tx_pkts_nic: 0

rx_bytes_nic: 24042645863

tx_bytes_nic: 0

lsc_int: 1

tx_busy: 0

non_eop_descs: 0

broadcast: 18410

rx_no_buffer_count: 0

tx_timeout_count: 0

tx_restart_queue: 0

rx_long_length_errors: 0

rx_short_length_errors: 0

tx_flow_control_xon: 0

rx_flow_control_xon: 0

tx_flow_control_xoff: 0

rx_flow_control_xoff: 0

rx_csum_offload_errors: 0

alloc_rx_page_failed: 0

alloc_rx_buff_failed: 0

lro_aggregated: 0

lro_flushed: 0

lro_recycled: 0

rx_no_dma_resources: 0

hw_rsc_aggregated: 0

hw_rsc_flushed: 0

fdir_match: 0

fdir_miss: 37076273

fdir_overflow: 0

fcoe_bad_fccrc: 0

fcoe_last_errors: 0

rx_fcoe_dropped: 0

rx_fcoe_packets: 0

rx_fcoe_dwords: 0

fcoe_noddp: 0

fcoe_noddp_ext_buff: 0

tx_fcoe_packets: 0

tx_fcoe_dwords: 0

os2bmc_rx_by_bmc: 0

os2bmc_tx_by_bmc: 0

os2bmc_tx_by_host: 0

os2bmc_rx_by_host: 0

tx_queue_0_packets: 0

tx_queue_0_bytes: 0

tx_queue_1_packets: 0

tx_queue_1_bytes: 0

tx_queue_2_packets: 0

tx_queue_2_bytes: 0

tx_queue_3_packets: 0

tx_queue_3_bytes: 0

tx_queue_4_packets: 0

tx_queue_4_bytes: 0

tx_queue_5_packets: 0

tx_queue_5_bytes: 0

tx_queue_6_packets: 0

tx_queue_6_bytes: 0

tx_queue_7_packets: 0

tx_queue_7_bytes: 0

rx_queue_0_packets: 0

rx_queue_0_bytes: 0

rx_queue_1_packets: 0

rx_queue_1_bytes: 0

rx_queue_2_packets: 0

rx_queue_2_bytes: 0

rx_queue_3_packets: 0

rx_queue_3_bytes: 0

rx_queue_4_packets: 0

rx_queue_4_bytes: 0

rx_queue_5_packets: 0

rx_queue_5_bytes: 0

rx_queue_6_packets: 0

rx_queue_6_bytes: 0

rx_queue_7_packets: 0

rx_queue_7_bytes: 0

[root@vehere-pc examples]#

Jose_H_Intel1
Employee
321 Views

For Linux* support please visit this link:

http://wireless.kernel.org/en/users/Drivers/iwlwifi iwlwifi - Linux Wireless

Reply