oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions related to download, Installation and licensing for Intel oneAPI Toolkits and software development tools.

Build error with the example projects

damageG
Beginner
432 Views

I get the following error when trying to build the simple-add example on windows

 

* Executing task: C/C++: gcc.exe build active file

Starting build...
cmd /c chcp 65001>nul && C:\msys64\ucrt64\bin\gcc.exe -fdiagnostics-color=always -g C:\Users\gregg\source\intel\simple-add\src\simple-add-buffers.cpp -o C:\Users\gregg\source\intel\simple-add\src\simple-add-buffers.exe
In file included from C:\Program Files (x86)\Intel\oneAPI\compiler\latest\include/sycl/accessor.hpp:14,
from C:\Program Files (x86)\Intel\oneAPI\compiler\latest\include/sycl/sycl.hpp:11,
from C:\Users\gregg\source\intel\simple-add\src\simple-add-buffers.cpp:22:
C:\Program Files (x86)\Intel\oneAPI\compiler\latest\include/sycl/atomic.hpp:11:10: fatal error: CL/__spirv/spirv_types.hpp: No such file or directory
11 | #include <CL/__spirv/spirv_types.hpp> // for Scope, MemorySemanticsMask
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.

 

If I choose the cl compiler under debug, I get a bunch of these. 

inline variables require at least '/std:c++17'

 

The VS code documentation seems to be a bit out of date. Are there any examples with the latest versions?

 

0 Kudos
4 Replies
Vipin_Singh1
Moderator
382 Views

Hi Gregg, Could you please share the below details with us?

 

  • Exact name and version of Intel® Toolkit or Intel® Compiler (if it's Stand-alone product).
  • Has the product been installed successfully?
  • Version of Microsoft Visual Studio installed along with it's build version.
  • OS build on which you are installing the product.
  • Other versions of Intel® Parallel Studio XE or Intel® oneAPI already installed on the system.

 

To assist you further, we would require these details.


0 Kudos
damageG
Beginner
330 Views

All of the Intel stuff and Visual Studio is the latest as of a couple days ago. To get it to install properly, I had to uninstall Visual Studio and an old version of the Intel oneAPI and then reinstall everything.

 

This is all on Windows 11 Pro.

 

I don't think I have Parallel Studio installed.

 

Thanks for your help

0 Kudos
Vipin_Singh1
Moderator
311 Views

Hi Gregg, please note that older versions of Intel® Toolkits are not available publicly, only the latest version Intel® Toolkits and other latest products are available for download and installation.

 

Intel® has decided that Intel® Toolkits Versions: 2024.0.0 and earlier are not supported anymore. We urge users to upgrade to the latest version of Intel® developer tools. The unsupported versions do not include the latest functional and security updates. These versions are targeted to be removed after a period. We understand that this might be challenging, but it's important to note that the users with active priority support can only access older product versions.

 

For more information refer to the link: https://www.intel.com/content/www/us/en/developer/articles/release-notes/oneapi-supported-product-versions.htm, and scroll down to the Unsupported Product Version.

 

Intel® oneAPI users with active Intel Priority Support can access older versions via a secure portal you gain access to as part of your support subscription. 

 

FAQ's Priority Support Link: https://www.intel.com/content/www/us/en/developer/get-help/faq-priority-support.html


0 Kudos
Vipin_Singh1
Moderator
282 Views

Hi Gregg, unfortunately, we were unable to hear back from you. 


If you have any further queries, please post a new question, as this thread will no longer be monitored by Intel®. 


0 Kudos
Reply