oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions for Intel oneAPI Toolkits, Intel Parallel Studio XE and Intel System Studio
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
738 Discussions

Cannot un-install Parallel Studio XE 2020 nor install Fortran Classic

Robert_Kiser
Beginner
397 Views

Hello all

 

Somehow, my Intel Parallel Studio XE 2020 installation has become corrupted.  I attempted to un-install it via the Windows Control Panel 'Program and Features' utility but nothing happens.  (I'm running Windows 10.)  Also could not change it nor repair it.  Visual Studio (versions 2019 and 2022) doesn't seem to know that the Intel Fortran is still there.

Further, I could not install Fortran Classic (OneAPI).  It gets about 40% and then says "rolling back updates . . ' and then quits.

I would like to know if there is some way that I can get rid of all the Intel Fortran software currently on my system and start fresh.  I presume that I'd have to delete some registry entries and delete some directories.  Perhaps edit some configuration files and/or Environment variables.  Something, somewhere, is getting Parallel Studio and Fortran Classic hung up, but I have no idea what or where.

Is there a guide for how to do this, that I can read?  Or, failing that, can someone tell me how to proceed?  I'm stumped.

 

Thanks in advance,

Bob Kiser

0 Kudos
7 Replies
JohnNichols
Valued Contributor II
391 Views

I would suggest you are at the stage of reinstalling Windows.  It happens.  

I have tried deleting everything, but you cannot clean it all up.  

Good luck.  

 

jimdempseyatthecove
Black Belt
364 Views

>>I would suggest you are at the stage of reinstalling Windows. 

I'd first suggest uninstalling MS VS, then reinstalling MS VS

 

>> I attempted to un-install it via the Windows Control Panel 'Program and Features' utility but nothing happens.

This could happen if you delete the Parallel Studio folder before performing the Uninstall.

 

Note, if this was the case, then the reinstall MS VS might fix the Fortran Classic (OneAPI) installation issue, as the failure may be related to the MS VS (as opposed to general Intel registry entries). However, if the cause of the rollback is due to Registry issues, then you may have to reinstall (or roll back Windows to pre-MS VS installation).

 

Jim Dempsey

Ron_Green
Moderator
363 Views

I'm going to move this thread over to our Startup / Installation team.

Robert_Kiser
Beginner
335 Views

Hello All

To follow up on what I've encountered about this:

 

I did as the posters above suggested and un-installed all my versions of VS (2019 and 2022), then rebooted.

 

Then I again tried to uninstall Intel Parallel Studio and this time it worked and the uninstall went smoothly.  (I'm guessing that something in its integration with VS was hanging up the Parallel Studio uninstaller.)

 

Then I re-installed VS 2022 and rebooted.

 

Then I tried to install Intel Fortran Classic and all went smoothly.  (Did not see the point in trying to re-install Parallel Studio.)

 

And I was once again able to compile and run Fortran programs.

 

So, for those of you following along behind me with the same sort of issue, uninstalling VS is certainly worth a try.  Your mileage may vary, but it worked for me.

 

Many thanks to the posters above.  Saved me me a lot of grief.

Nick3
New Contributor I
291 Views

On the chance someone else is looking at the same problem, here's another possible solution;

When I tried to uninstall Parallel Studio, I was getting failures as well.

It turns out, one of our IT folks (admin account) originally installed it, and that was the only account that had permissions to uninstall it.  A different (admin) account did not have permissions to uninstall it (folder access permissions), and that's what was causing the uninstall failures.

Soumya_M_Intel
Moderator
283 Views

Hi Robert_Kiser,


Thanks for posting about the process and the current status of the concern on the thread. Just to make sure of the situation, we would like to know if there are any other queries or concerns before closing the thread.


Please feel free to let us know. We are here to assist you.


Regards,

Soumya


Soumya_M_Intel
Moderator
266 Views

Hi Robert_Kiser,


We understand that you might be using the product as the installation concern has been resolved. However, we are checking in as we have not heard from you on our previous response.


If you came across any further concerns, please feel free to reply within the next 24 business hours to keep this thread active.


Regards,

Soumya


Reply