oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions for Intel oneAPI Toolkits, Intel Parallel Studio XE and Intel System Studio
736 Discussions

Cant install Intel oneAPI Base Toolkit (offline or online)

tommelt
Beginner
596 Views

It get an error when I try to install using the offline or online install of the base toolkit.

version: 2022.1.1-119.2022.01.25.11.54.59.183486

 

I am installing it to a server for which I do not have sudo access.

 

I had previously installed the 2021 one-api version.

 

It complains with the following;

During the execution of the application '/home/meltzert/intel/installercache/downloadcache/intel.oneapi.lin.python3,v=2022.0.1-127/exec_script.sh' with arguments '/home/meltzert/intel/oneapi' errors were received:'RuntimeError: NumPy was built with baseline optimizations: 
(SSE SSE2 SSE3 SSSE3 SSE41 POPCNT SSE42) but your machine doesn't support:
(SSSE3).
'
Error: Sequence execution failed.

 

I have attached the logs for the online and offline installer:

online: "installer.install.intel.oneapi.lin.basekit.product,v=2022.1.1-119.2022.01.25.11.54.59.183486.log"

 

offline: "offline.log"

 

I would appreciate your help.

 

I have python install via conda:

python --version
Python 3.6.12 :: Anaconda, Inc.


Thanks

Labels (1)
0 Kudos
1 Solution
tommelt
Beginner
571 Views

Hi Soumya,

 

The operating system info is: Rocky Linux release 8.5 (Green Obsidian)

 

Out of interest, I have since found a work around for the problem.

 

The installation was failing at the intel-python stage. But I don't need intel-python so I just removed it and did a custom install.

 

It's not a fix because the problem may still exist, but I don't need it. So, feel free to close this request.

 

Cheers,

Tom

View solution in original post

3 Replies
Soumya_M_Intel
Moderator
580 Views

Hi tommelt,


Thanks for posting your concern on the forum and providing the logs along with it. Please let us know the operating system's complete name and version. It will allow us to check further.


Regards,

Soumya


tommelt
Beginner
572 Views

Hi Soumya,

 

The operating system info is: Rocky Linux release 8.5 (Green Obsidian)

 

Out of interest, I have since found a work around for the problem.

 

The installation was failing at the intel-python stage. But I don't need intel-python so I just removed it and did a custom install.

 

It's not a fix because the problem may still exist, but I don't need it. So, feel free to close this request.

 

Cheers,

Tom

Soumya_M_Intel
Moderator
561 Views

Hi Tom, 


Thanks for getting back to us on the post. Glad to know that the custom installation worked successfully.


Our higher team is currently working on a fix for a similar issue. I will inform them about the issue you faced as feedback for future developments.


As per your response, we are closing this thread. It will no longer be monitored by Intel®. However, feel free to create a new thread if there are any queries or concerns. Have a nice day ahead.


Regards,

Soumya


Reply