oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions for Intel oneAPI Toolkits, Intel Parallel Studio XE and Intel System Studio
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
738 Discussions

Error in installing oneAPI intel-basekit on WSL 2

rigustafson
Beginner
696 Views

Hi,

I have the exact same problem as here: https://community.intel.com/t5/Intel-oneAPI-Registration/Error-during-installing-oneAPI-basekit-on-W...

I receive this error:

ERROR: kernel source directory "/usr/src/linux-5.10.16.3-microsoft-standard-WSL2" either does not exist or not a valid kernel source directory.

Please use the following command to install kernel header on Ubuntu:
apt install linux-headers-5.10.16.3-microsoft-standard-WSL2

I tried to install the suggestion above, but that resulted in:

E: Unable to locate package linux-headers-5.10.16.3-microsoft-standard-WSL
E: Couldn't find any package by glob 'linux-headers-5.10.16.3-microsoft-standard-WSL'

I am installing on Ubuntu 20.04 LTS on WSL 2 according to https://estuarine.jp/2021/03/install-oneapi/?lang=en

 

Any help?

Thanks!

0 Kudos
1 Solution
rigustafson
Beginner
671 Views
Hi,

I was able to fix the issue on my end. Thanks for your assistance.

View solution in original post

3 Replies
Soumya_M_Intel
Moderator
683 Views

Hi rigustafson,


Thanks for posting your concern in our forum. We appreciate your patience. Our higher team is already investigating a few other similar reports. Please provide us the below details and output of the commands. They will allow us to look into the issue better.

 

  1. The version of the Intel® oneAPI Base Toolkit
  2. The complete output from the installation
  3. The installation log
  4. The output of the below commands:
  • which python
    • 2. which bzip2
    • 3. echo $PATH
    • 3. echo $LD_LIBRARY_PATH

 

Looking forward to your update. Have a nice day ahead.


Regards,

Soumya


rigustafson
Beginner
672 Views
Hi,

I was able to fix the issue on my end. Thanks for your assistance.
Soumya_M_Intel
Moderator
668 Views

Hi rigustafson,


Thanks for updating us on the progress status. Glad to know that your issue is resolved. Proceeding further we are closing this thread. However, if you need any additional information, please feel free to post a new question as this thread will no longer be monitored by Intel®. 


Regards,

Soumya


Reply