oneAPI Registration, Download, Licensing and Installation
Support for Getting Started questions for Intel oneAPI Toolkits, Intel Parallel Studio XE and Intel System Studio
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
738 Discussions

How to install Intel One API toolkits on AMD based GPU to link FORTRAN SUBROUTINES for ABAQUS?

Amit_mcgill
Beginner
1,615 Views

Hi,

I am not able to install the One API toolkits on my computer. I am using AMD Ryzen (9 3900) processor and AMD Radeon RX 5 series GPU. 

I went through the link Install Intel GPU Drivers  and Intel® oneAPI Toolkits DPC++ Library System Requirements , it seems One API toolkits only support intel based CPU and GPU hardware's. 

I am very confused and clueless, how to solve this issue? Do I have to change the GPU? Any recommendation is appreciated. 

McGill_PC_problem_OneAPI base toolkit.PNG

0 Kudos
1 Solution
ArpanB_Intel
Moderator
1,540 Views

Amit, if you were a part of our previous Student, Academic or Open Source Developer Tools program and wish to extend your existing license, please email your expired serial number and contact information to software_tools_request@intel.com to request a license. We believe that would resolve this situation.


View solution in original post

3 Replies
ArpanB_Intel
Moderator
1,591 Views

Hi Amit, before we proceed with our support, could you share the OS build information on which you are installing the toolkit with us, in case our engineers need to test it out themselves. In terms of the supported system requirements, we do not support AMD based GPU's. For more information on the system requirements, please click here: https://software.intel.com/content/www/us/en/develop/articles/intel-oneapi-base-toolkit-system-requi....


Amit_mcgill
Beginner
1,576 Views

Hi Arpan, 

Thank you for your response. I am using Microsoft Windows 10 Education as an operating system. Before I was using Intel Parallel Studio XE and this was working fine. Now because of the recent development, I can't renew my student's license for parallel XE. I am forced to use OneAPI toolkits, which don't get installed on AMD GPU. 

As per your response, it seems I need to change my AMD GPU to Intel-based GPU to use it. Do you have any other recommendation to short this out?

Regards

Amit

ArpanB_Intel
Moderator
1,541 Views

Amit, if you were a part of our previous Student, Academic or Open Source Developer Tools program and wish to extend your existing license, please email your expired serial number and contact information to software_tools_request@intel.com to request a license. We believe that would resolve this situation.


Reply